summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2010-07-19 21:32:22 +0000
committerChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2010-07-19 21:32:22 +0000
commit4275f3514d9a7cece174f7e364ed2fe1d4171b1f (patch)
tree5132eaa6a912a8d2a322727a1fff2e6c49220203 /www-plugins
parentStable for HPPA (bug #314523). (diff)
downloadgentoo-2-4275f3514d9a7cece174f7e364ed2fe1d4171b1f.tar.gz
gentoo-2-4275f3514d9a7cece174f7e364ed2fe1d4171b1f.tar.bz2
gentoo-2-4275f3514d9a7cece174f7e364ed2fe1d4171b1f.zip
check for agg USE flag when vaapi is enabled
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'www-plugins')
-rw-r--r--www-plugins/gnash/ChangeLog6
-rw-r--r--www-plugins/gnash/gnash-0.8.7_p20100706.ebuild7
2 files changed, 11 insertions, 2 deletions
diff --git a/www-plugins/gnash/ChangeLog b/www-plugins/gnash/ChangeLog
index ae03ee89b4f5..b6629f09e85b 100644
--- a/www-plugins/gnash/ChangeLog
+++ b/www-plugins/gnash/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for www-plugins/gnash
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-plugins/gnash/ChangeLog,v 1.33 2010/07/14 01:03:00 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-plugins/gnash/ChangeLog,v 1.34 2010/07/19 21:32:22 chithanh Exp $
+
+ 19 Jul 2010; Chí-Thanh Christopher Nguyễn <chithanh@gentoo.org>
+ gnash-0.8.7_p20100706.ebuild:
+ check for agg USE flag when vaapi is enabled
14 Jul 2010; Jeroen Roovers <jer@gentoo.org> gnash-0.8.5.ebuild,
gnash-0.8.6.ebuild, gnash-0.8.7.ebuild, gnash-0.8.7_p20100706.ebuild:
diff --git a/www-plugins/gnash/gnash-0.8.7_p20100706.ebuild b/www-plugins/gnash/gnash-0.8.7_p20100706.ebuild
index 76653d153c9a..d9eeeabf1996 100644
--- a/www-plugins/gnash/gnash-0.8.7_p20100706.ebuild
+++ b/www-plugins/gnash/gnash-0.8.7_p20100706.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-plugins/gnash/gnash-0.8.7_p20100706.ebuild,v 1.4 2010/07/14 01:03:00 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-plugins/gnash/gnash-0.8.7_p20100706.ebuild,v 1.5 2010/07/19 21:32:22 chithanh Exp $
EAPI=3
CMAKE_REQUIRED="never"
@@ -84,6 +84,11 @@ pkg_setup() {
die "vaapi requires the ffmpeg USE flag."
fi
+ if use vaapi && use !agg; then
+ eerror "Support for VAAPI currently requires the agg renderer."
+ die "vaapi requires the agg USE flag."
+ fi
+
if ! ( use agg || use cairo || use opengl ); then
eerror "You are trying to build Gnash without choosing a renderer [agg|cairo|opengl]."
die "Please enable a renderer"