summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2014-10-15 15:10:28 +0000
committerPacho Ramos <pacho@gentoo.org>2014-10-15 15:10:28 +0000
commit36db81dee3e3eff476476e54b13c4f9555b2de5a (patch)
treeeb595c6710397b4f71831f353b286ad314e3d378 /www-plugins
parentSupport multilib providers for deps. Bump to EAPI=5. (diff)
downloadgentoo-2-36db81dee3e3eff476476e54b13c4f9555b2de5a.tar.gz
gentoo-2-36db81dee3e3eff476476e54b13c4f9555b2de5a.tar.bz2
gentoo-2-36db81dee3e3eff476476e54b13c4f9555b2de5a.zip
Drop old
(Portage version: 2.2.12/cvs/Linux x86_64, signed Manifest commit with key A188FBD4)
Diffstat (limited to 'www-plugins')
-rw-r--r--www-plugins/nspluginwrapper/ChangeLog6
-rw-r--r--www-plugins/nspluginwrapper/nspluginwrapper-1.4.4-r1.ebuild97
-rw-r--r--www-plugins/nspluginwrapper/nspluginwrapper-1.4.4-r2.ebuild108
-rw-r--r--www-plugins/nspluginwrapper/nspluginwrapper-1.4.4.ebuild96
4 files changed, 5 insertions, 302 deletions
diff --git a/www-plugins/nspluginwrapper/ChangeLog b/www-plugins/nspluginwrapper/ChangeLog
index 1c76f0376210..50b63bd7ca58 100644
--- a/www-plugins/nspluginwrapper/ChangeLog
+++ b/www-plugins/nspluginwrapper/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for www-plugins/nspluginwrapper
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-plugins/nspluginwrapper/ChangeLog,v 1.29 2014/10/15 15:09:20 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-plugins/nspluginwrapper/ChangeLog,v 1.30 2014/10/15 15:10:28 pacho Exp $
+
+ 15 Oct 2014; Pacho Ramos <pacho@gentoo.org> -nspluginwrapper-1.4.4-r1.ebuild,
+ -nspluginwrapper-1.4.4-r2.ebuild, -nspluginwrapper-1.4.4.ebuild:
+ Drop old
15 Oct 2014; Pacho Ramos <pacho@gentoo.org> nspluginwrapper-1.4.4-r3.ebuild:
Support multilib providers for deps. Bump to EAPI=5.
diff --git a/www-plugins/nspluginwrapper/nspluginwrapper-1.4.4-r1.ebuild b/www-plugins/nspluginwrapper/nspluginwrapper-1.4.4-r1.ebuild
deleted file mode 100644
index 34342113311a..000000000000
--- a/www-plugins/nspluginwrapper/nspluginwrapper-1.4.4-r1.ebuild
+++ /dev/null
@@ -1,97 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-plugins/nspluginwrapper/nspluginwrapper-1.4.4-r1.ebuild,v 1.4 2012/05/03 06:08:02 jdhore Exp $
-
-EAPI=2
-
-inherit eutils multilib nsplugins flag-o-matic
-
-DESCRIPTION="Netscape Plugin Wrapper - Load 32bit plugins on 64bit browser"
-HOMEPAGE="http://nspluginwrapper.org/"
-SRC_URI="http://web.mit.edu/davidben/Public/nspluginwrapper/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64"
-IUSE=""
-
-RDEPEND=">=x11-libs/gtk+-2:2
- net-misc/curl
- app-emulation/emul-linux-x86-xlibs
- app-emulation/emul-linux-x86-gtklibs
- >=sys-apps/util-linux-2.13"
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
-
-autoinstall() {
- if [[ -x /usr/bin/${PN} ]]; then
- einfo "Auto installing 32bit plugins..."
- ${PN} -a -i
- ls /usr/$(get_libdir)/nsbrowser/plugins
-
- # Remove wrappers if equivalent 64-bit plugins exist
- # TODO: May be better to patch nspluginwrapper so it doesn't create
- # duplicate wrappers in the first place...
- local DIR64="${ROOT}/usr/$(get_libdir)/nsbrowser/plugins/"
- for f in "${DIR64}"/npwrapper.*.so; do
- local PLUGIN=${f##*/npwrapper.}
- if [[ -f ${DIR64}/${PLUGIN} ]]; then
- einfo " Removing duplicate wrapper for native 64-bit ${PLUGIN}"
- ${PN} -r "${f}"
- fi
- done
- fi
-}
-
-src_prepare() {
- epatch "${FILESDIR}/${PN}-1.3.0-gdk-native-windows.patch"
- epatch "${FILESDIR}/${P}-parallel-make.patch"
- epatch "${FILESDIR}/${P}-compile-on-hardened.patch"
- sed -i -r "s:^libnoxshm_LDFLAGS = :libnoxshm_LDFLAGS = -L/usr/$(ABI=x86 get_libdir)/ :" Makefile
-}
-
-src_configure() {
- replace-flags -O3 -O2
-
- ./configure --enable-biarch \
- --target-cpu=i386 \
- --with-lib32=$(ABI=x86 get_libdir) \
- --with-lib64=$(get_libdir) \
- --pkglibdir=/usr/$(get_libdir)/${PN}
-}
-
-src_compile() {
- emake LDFLAGS_32="-m32 ${LDFLAGS}" || die "emake failed"
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "emake install failed"
-
- dosym "/usr/$(get_libdir)/${PN}/x86_64/linux/npconfig" "/usr/bin/${PN}"
- keepdir "/usr/$(get_libdir)/${PLUGINS_DIR}"
-
- dodoc NEWS README TODO
-}
-
-pkg_postinst() {
- autoinstall
- elog "Any 32bit plugins you currently have installed have now been"
- elog "configured to work in a 64bit browser. Any plugins you install in"
- elog "the future will first need to be setup with:"
- elog " \"nspluginwrapper -i <path-to-32bit-plugin>\""
- elog "before they will function in a 64bit browser"
- elog
-}
-
-# this is terribly ugly, but without a way to query portage as to whether
-# we are upgrading/reinstalling a package versus unmerging, I can't think of
-# a better way
-
-pkg_prerm() {
- einfo "Removing wrapper plugins..."
- ${PN} --auto --remove
-}
-
-pkg_postrm() {
- autoinstall
-}
diff --git a/www-plugins/nspluginwrapper/nspluginwrapper-1.4.4-r2.ebuild b/www-plugins/nspluginwrapper/nspluginwrapper-1.4.4-r2.ebuild
deleted file mode 100644
index 4b1c7d9c3b90..000000000000
--- a/www-plugins/nspluginwrapper/nspluginwrapper-1.4.4-r2.ebuild
+++ /dev/null
@@ -1,108 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-plugins/nspluginwrapper/nspluginwrapper-1.4.4-r2.ebuild,v 1.2 2012/05/03 06:08:02 jdhore Exp $
-
-EAPI=2
-
-inherit eutils multilib nsplugins flag-o-matic toolchain-funcs
-
-DESCRIPTION="Netscape Plugin Wrapper - Load 32bit plugins on 64bit browser"
-HOMEPAGE="http://nspluginwrapper.org/"
-SRC_URI="http://web.mit.edu/davidben/Public/nspluginwrapper/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE=""
-
-RDEPEND=">=x11-libs/gtk+-2:2
- net-misc/curl
- app-emulation/emul-linux-x86-xlibs
- app-emulation/emul-linux-x86-gtklibs
- >=sys-apps/util-linux-2.13"
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
-
-autoinstall() {
- if [[ -x /usr/bin/${PN} ]]; then
- einfo "Auto installing 32bit plugins..."
- ${PN} -a -i
- ls /usr/$(get_libdir)/nsbrowser/plugins
-
- # Remove wrappers if equivalent 64-bit plugins exist
- # TODO: May be better to patch nspluginwrapper so it doesn't create
- # duplicate wrappers in the first place...
- local DIR64="${ROOT}/usr/$(get_libdir)/nsbrowser/plugins/"
- for f in "${DIR64}"/npwrapper.*.so; do
- local PLUGIN=${f##*/npwrapper.}
- if [[ -f ${DIR64}/${PLUGIN} ]]; then
- einfo " Removing duplicate wrapper for native 64-bit ${PLUGIN}"
- ${PN} -r "${f}"
- fi
- done
- fi
-}
-
-src_prepare() {
- epatch "${FILESDIR}/${PN}-1.3.0-gdk-native-windows.patch"
-
- epatch "${FILESDIR}/${P}-parallel-make.patch"
- epatch "${FILESDIR}/${P}-compile-on-hardened.patch"
- epatch "${FILESDIR}/${P}-dont-unload-libraries.patch"
- epatch "${FILESDIR}/${P}-dont-include-gthread.patch"
-
- sed -i -r "s:^libnoxshm_LDFLAGS = :libnoxshm_LDFLAGS = -L/usr/$(ABI=x86 get_libdir)/ :" \
- Makefile || die "sed failed"
-}
-
-src_configure() {
- replace-flags -O3 -O2
-
- ./configure \
- --with-cc="$(tc-getCC)" \
- --with-cxx="$(tc-getCXX)" \
- --enable-biarch \
- --target-cpu=i386 \
- --with-lib32=$(ABI=x86 get_libdir) \
- --with-lib64=$(get_libdir) \
- --pkglibdir=/usr/$(get_libdir)/${PN} \
- || die "configure failed"
-}
-
-src_compile() {
- emake LDFLAGS_32="-m32 ${LDFLAGS}" || die "emake failed"
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "emake install failed"
-
- dosym "/usr/$(get_libdir)/${PN}/x86_64/linux/npconfig" "/usr/bin/${PN}" \
- || die "dosym failed"
-
- keepdir "/usr/$(get_libdir)/${PLUGINS_DIR}" || die "keepdir failed"
-
- dodoc NEWS README TODO
-}
-
-pkg_postinst() {
- autoinstall
- elog "Any 32bit plugins you currently have installed have now been"
- elog "configured to work in a 64bit browser. Any plugins you install in"
- elog "the future will first need to be setup with:"
- elog " \"nspluginwrapper -i <path-to-32bit-plugin>\""
- elog "before they will function in a 64bit browser"
- elog
-}
-
-# this is terribly ugly, but without a way to query portage as to whether
-# we are upgrading/reinstalling a package versus unmerging, I can't think of
-# a better way
-
-pkg_prerm() {
- einfo "Removing wrapper plugins..."
- ${PN} --auto --remove
-}
-
-pkg_postrm() {
- autoinstall
-}
diff --git a/www-plugins/nspluginwrapper/nspluginwrapper-1.4.4.ebuild b/www-plugins/nspluginwrapper/nspluginwrapper-1.4.4.ebuild
deleted file mode 100644
index 8ffcdd6f0474..000000000000
--- a/www-plugins/nspluginwrapper/nspluginwrapper-1.4.4.ebuild
+++ /dev/null
@@ -1,96 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-plugins/nspluginwrapper/nspluginwrapper-1.4.4.ebuild,v 1.5 2012/05/03 06:08:02 jdhore Exp $
-
-EAPI=2
-
-inherit eutils multilib nsplugins flag-o-matic
-
-DESCRIPTION="Netscape Plugin Wrapper - Load 32bit plugins on 64bit browser"
-HOMEPAGE="http://nspluginwrapper.org/"
-SRC_URI="http://web.mit.edu/davidben/Public/nspluginwrapper/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64"
-IUSE=""
-
-RDEPEND=">=x11-libs/gtk+-2:2
- net-misc/curl
- app-emulation/emul-linux-x86-xlibs
- app-emulation/emul-linux-x86-gtklibs
- >=sys-apps/util-linux-2.13"
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
-
-autoinstall() {
- if [[ -x /usr/bin/${PN} ]]; then
- einfo "Auto installing 32bit plugins..."
- ${PN} -a -i
- ls /usr/$(get_libdir)/nsbrowser/plugins
-
- # Remove wrappers if equivalent 64-bit plugins exist
- # TODO: May be better to patch nspluginwrapper so it doesn't create
- # duplicate wrappers in the first place...
- local DIR64="${ROOT}/usr/$(get_libdir)/nsbrowser/plugins/"
- for f in "${DIR64}"/npwrapper.*.so; do
- local PLUGIN=${f##*/npwrapper.}
- if [[ -f ${DIR64}/${PLUGIN} ]]; then
- einfo " Removing duplicate wrapper for native 64-bit ${PLUGIN}"
- ${PN} -r "${f}"
- fi
- done
- fi
-}
-
-src_prepare() {
- epatch "${FILESDIR}/${PN}-1.3.0-gdk-native-windows.patch"
- epatch "${FILESDIR}/${P}-parallel-make.patch"
- epatch "${FILESDIR}/${P}-compile-on-hardened.patch"
-}
-
-src_configure() {
- replace-flags -O3 -O2
-
- ./configure --enable-biarch \
- --target-cpu=i386 \
- --with-lib32=$(ABI=x86 get_libdir) \
- --with-lib64=$(get_libdir) \
- --pkglibdir=/usr/$(get_libdir)/${PN}
-}
-
-src_compile() {
- emake LDFLAGS_32="-m32 ${LDFLAGS}" || die "emake failed"
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "emake install failed"
-
- dosym "/usr/$(get_libdir)/${PN}/x86_64/linux/npconfig" "/usr/bin/${PN}"
- keepdir "/usr/$(get_libdir)/${PLUGINS_DIR}"
-
- dodoc NEWS README TODO
-}
-
-pkg_postinst() {
- autoinstall
- elog "Any 32bit plugins you currently have installed have now been"
- elog "configured to work in a 64bit browser. Any plugins you install in"
- elog "the future will first need to be setup with:"
- elog " \"nspluginwrapper -i <path-to-32bit-plugin>\""
- elog "before they will function in a 64bit browser"
- elog
-}
-
-# this is terribly ugly, but without a way to query portage as to whether
-# we are upgrading/reinstalling a package versus unmerging, I can't think of
-# a better way
-
-pkg_prerm() {
- einfo "Removing wrapper plugins..."
- ${PN} --auto --remove
-}
-
-pkg_postrm() {
- autoinstall
-}