summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2012-11-18 13:43:34 +0000
committerChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2012-11-18 13:43:34 +0000
commit1ca32b8066aced91029020fa78600e7af77c32ce (patch)
treec97bf03321818f2b8e892cc0c4dbef44f60d9a75 /www-plugins
parentBump haddock to 2.13.1 with no keywords, as depends on ghc 7.6.1 which is not... (diff)
downloadgentoo-2-1ca32b8066aced91029020fa78600e7af77c32ce.tar.gz
gentoo-2-1ca32b8066aced91029020fa78600e7af77c32ce.tar.bz2
gentoo-2-1ca32b8066aced91029020fa78600e7af77c32ce.zip
Add workaround for gles failure, bug #440148.
(Portage version: 2.1.11.31/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'www-plugins')
-rw-r--r--www-plugins/lightspark/ChangeLog6
-rw-r--r--www-plugins/lightspark/files/lightspark-0.7.0-libxmlpp-gles.patch159
-rw-r--r--www-plugins/lightspark/lightspark-0.7.0.ebuild6
3 files changed, 169 insertions, 2 deletions
diff --git a/www-plugins/lightspark/ChangeLog b/www-plugins/lightspark/ChangeLog
index 6343fe5224a2..b85aeecf8841 100644
--- a/www-plugins/lightspark/ChangeLog
+++ b/www-plugins/lightspark/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for www-plugins/lightspark
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-plugins/lightspark/ChangeLog,v 1.46 2012/10/29 13:36:30 chithanh Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-plugins/lightspark/ChangeLog,v 1.47 2012/11/18 13:43:34 chithanh Exp $
+
+ 18 Nov 2012; Chí-Thanh Christopher Nguyễn <chithanh@gentoo.org>
+ +files/lightspark-0.7.0-libxmlpp-gles.patch, lightspark-0.7.0.ebuild:
+ Add workaround for gles failure, bug #440148.
*lightspark-0.7.0 (29 Oct 2012)
diff --git a/www-plugins/lightspark/files/lightspark-0.7.0-libxmlpp-gles.patch b/www-plugins/lightspark/files/lightspark-0.7.0-libxmlpp-gles.patch
new file mode 100644
index 000000000000..523f550b189e
--- /dev/null
+++ b/www-plugins/lightspark/files/lightspark-0.7.0-libxmlpp-gles.patch
@@ -0,0 +1,159 @@
+diff -ur a/src/backends/netutils.cpp b/src/backends/netutils.cpp
+--- a/src/backends/netutils.cpp 2012-10-28 16:49:04.000000000 +0100
++++ b/src/backends/netutils.cpp 2012-10-30 01:05:26.947904601 +0100
+@@ -18,13 +18,13 @@
+ along with this program. If not, see <http://www.gnu.org/licenses/>.
+ **************************************************************************/
+
++#include "backends/security.h"
+ #include "scripting/abc.h"
+ #include "swf.h"
+ #include "backends/config.h"
+ #include "backends/netutils.h"
+ #include "backends/rtmputils.h"
+ #include "compat.h"
+-#include "backends/security.h"
+ #include <string>
+ #include <algorithm>
+ #include <cctype>
+diff -ur a/src/main.cpp b/src/main.cpp
+--- a/src/main.cpp 2012-10-28 16:49:04.000000000 +0100
++++ b/src/main.cpp 2012-10-30 01:29:12.446786100 +0100
+@@ -18,9 +18,9 @@
+ **************************************************************************/
+
+ #include "version.h"
++#include "backends/security.h"
+ #include "swf.h"
+ #include "logger.h"
+-#include "backends/security.h"
+ #include "platforms/engineutils.h"
+ #ifndef _WIN32
+ # include <sys/resource.h>
+diff -ur a/src/plugin/plugin.cpp b/src/plugin/plugin.cpp
+--- a/src/plugin/plugin.cpp 2012-10-28 16:49:04.000000000 +0100
++++ b/src/plugin/plugin.cpp 2012-10-30 01:29:26.328790120 +0100
+@@ -19,6 +19,7 @@
+ **************************************************************************/
+
+ #include "version.h"
++#include "backends/security.h"
+ #include "plugin/plugin.h"
+ #include "logger.h"
+ #include "compat.h"
+@@ -28,7 +29,6 @@
+ # include <gdk/gdkwin32.h>
+ #endif
+ #include "backends/urlutils.h"
+-#include "backends/security.h"
+
+ #include "plugin/npscriptobject.h"
+
+diff -ur a/src/scripting/flash/display/flashdisplay.cpp b/src/scripting/flash/display/flashdisplay.cpp
+--- a/src/scripting/flash/display/flashdisplay.cpp 2012-10-28 16:49:04.000000000 +0100
++++ b/src/scripting/flash/display/flashdisplay.cpp 2012-10-30 01:12:42.780140945 +0100
+@@ -19,6 +19,7 @@
+
+ #include <list>
+
++#include "backends/security.h"
+ #include "scripting/abc.h"
+ #include "scripting/flash/display/flashdisplay.h"
+ #include "swf.h"
+@@ -33,7 +34,6 @@
+ #include "scripting/flash/display/BitmapData.h"
+ #include "scripting/argconv.h"
+ #include "scripting/toplevel/Vector.h"
+-#include "backends/security.h"
+
+ using namespace std;
+ using namespace lightspark;
+diff -ur a/src/scripting/flash/net/flashnet.cpp b/src/scripting/flash/net/flashnet.cpp
+--- a/src/scripting/flash/net/flashnet.cpp 2012-10-28 16:49:04.000000000 +0100
++++ b/src/scripting/flash/net/flashnet.cpp 2012-10-30 01:15:37.158273078 +0100
+@@ -18,6 +18,7 @@
+ **************************************************************************/
+
+ #include <map>
++#include "backends/security.h"
+ #include "scripting/abc.h"
+ #include "scripting/flash/net/flashnet.h"
+ #include "scripting/flash/net/URLRequestHeader.h"
+@@ -27,7 +28,6 @@
+ #include "backends/audio.h"
+ #include "backends/builtindecoder.h"
+ #include "backends/rendering.h"
+-#include "backends/security.h"
+ #include "scripting/argconv.h"
+
+ using namespace std;
+diff -ur a/src/scripting/flash/net/URLStream.cpp b/src/scripting/flash/net/URLStream.cpp
+--- a/src/scripting/flash/net/URLStream.cpp 2012-10-28 16:49:04.000000000 +0100
++++ b/src/scripting/flash/net/URLStream.cpp 2012-10-30 01:20:27.202448798 +0100
+@@ -18,10 +18,10 @@
+ **************************************************************************/
+
+ #include <map>
++#include "backends/security.h"
+ #include "scripting/abc.h"
+ #include "scripting/flash/net/URLStream.h"
+ #include "scripting/flash/net/flashnet.h"
+-#include "backends/security.h"
+ #include "scripting/argconv.h"
+
+ /**
+diff -ur a/src/scripting/flash/net/XMLSocket.cpp b/src/scripting/flash/net/XMLSocket.cpp
+--- a/src/scripting/flash/net/XMLSocket.cpp 2012-10-28 16:49:04.000000000 +0100
++++ b/src/scripting/flash/net/XMLSocket.cpp 2012-10-30 01:23:19.454574585 +0100
+@@ -18,13 +18,13 @@
+ **************************************************************************/
+
+ #include "XMLSocket.h"
++#include "backends/security.h"
+ #include "abc.h"
+ #include "toplevel/Error.h"
+ #include "class.h"
+ #include "argconv.h"
+ #include "swf.h"
+ #include "flash/errors/flasherrors.h"
+-#include "backends/security.h"
+ #include <sys/types.h>
+ #ifdef _WIN32
+ # define _WIN32_WINNT 0x0501
+diff -ur a/src/scripting/flash/sensors/flashsensors.cpp b/src/scripting/flash/sensors/flashsensors.cpp
+--- a/src/scripting/flash/sensors/flashsensors.cpp 2012-10-28 16:49:04.000000000 +0100
++++ b/src/scripting/flash/sensors/flashsensors.cpp 2012-10-30 01:20:46.299454329 +0100
+@@ -18,13 +18,13 @@
+ **************************************************************************/
+
+ #include <map>
++#include "backends/security.h"
+ #include "scripting/abc.h"
+ #include "scripting/flash/sensors/flashsensors.h"
+ #include "scripting/class.h"
+ #include "scripting/flash/system/flashsystem.h"
+ #include "compat.h"
+ #include "backends/audio.h"
+-#include "backends/security.h"
+
+ using namespace std;
+ using namespace lightspark;
+diff -ur a/src/swf.cpp b/src/swf.cpp
+--- a/src/swf.cpp 2012-10-28 16:49:04.000000000 +0100
++++ b/src/swf.cpp 2012-10-30 01:02:34.015821784 +0100
+@@ -19,6 +19,7 @@
+
+ #include <string>
+ #include <algorithm>
++#include "backends/security.h"
+ #include "scripting/abc.h"
+ #include "scripting/flash/events/flashevents.h"
+ #include "scripting/flash/utils/flashutils.h"
+@@ -31,7 +32,6 @@
+ #include "backends/config.h"
+ #include "backends/pluginmanager.h"
+ #include "backends/rendering.h"
+-#include "backends/security.h"
+ #include "backends/image.h"
+ #include "backends/extscriptobject.h"
+ #include "memory_support.h"
diff --git a/www-plugins/lightspark/lightspark-0.7.0.ebuild b/www-plugins/lightspark/lightspark-0.7.0.ebuild
index c6689757231a..0e0f00b76ad7 100644
--- a/www-plugins/lightspark/lightspark-0.7.0.ebuild
+++ b/www-plugins/lightspark/lightspark-0.7.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-plugins/lightspark/lightspark-0.7.0.ebuild,v 1.1 2012/10/29 13:36:30 chithanh Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-plugins/lightspark/lightspark-0.7.0.ebuild,v 1.2 2012/11/18 13:43:34 chithanh Exp $
EAPI=4
inherit cmake-utils nsplugins multilib
@@ -52,6 +52,10 @@ DEPEND="${RDEPEND}
S=${WORKDIR}/${P/_rc*/}
+PATCHES=(
+ "${FILESDIR}"/${P}-libxmlpp-gles.patch
+)
+
src_configure() {
local audiobackends
use pulseaudio && audiobackends+="pulse"