summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <chutzpah@gentoo.org>2011-05-24 23:08:11 +0000
committerPatrick McLean <chutzpah@gentoo.org>2011-05-24 23:08:11 +0000
commit0a5adb8797e32bd0318935422e502f0ceb892758 (patch)
tree000e71fad3620045fce01b237d068f5059c05fbf /www-plugins
parentVersion bump and remove old. (diff)
downloadgentoo-2-0a5adb8797e32bd0318935422e502f0ceb892758.tar.gz
gentoo-2-0a5adb8797e32bd0318935422e502f0ceb892758.tar.bz2
gentoo-2-0a5adb8797e32bd0318935422e502f0ceb892758.zip
Version bump, bug #365987. Clean dependency on setarch as it is no longer in the tree. Add patch to make installation work with parallel make.
(Portage version: 2.1.9.49/cvs/Linux x86_64)
Diffstat (limited to 'www-plugins')
-rw-r--r--www-plugins/nspluginwrapper/ChangeLog10
-rw-r--r--www-plugins/nspluginwrapper/files/nspluginwrapper-1.4.0-parallel-make.patch48
-rw-r--r--www-plugins/nspluginwrapper/nspluginwrapper-1.4.0.ebuild95
3 files changed, 152 insertions, 1 deletions
diff --git a/www-plugins/nspluginwrapper/ChangeLog b/www-plugins/nspluginwrapper/ChangeLog
index 5b88ca1ae843..cf1df645bdf2 100644
--- a/www-plugins/nspluginwrapper/ChangeLog
+++ b/www-plugins/nspluginwrapper/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for www-plugins/nspluginwrapper
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-plugins/nspluginwrapper/ChangeLog,v 1.9 2011/03/27 10:16:23 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-plugins/nspluginwrapper/ChangeLog,v 1.10 2011/05/24 23:08:11 chutzpah Exp $
+
+*nspluginwrapper-1.4.0 (24 May 2011)
+
+ 24 May 2011; Patrick McLean <chutzpah@gentoo.org>
+ +nspluginwrapper-1.4.0.ebuild,
+ +files/nspluginwrapper-1.4.0-parallel-make.patch:
+ Version bump, bug #365987. Clean dependency on setarch as it is no longer in
+ the tree. Add patch to make installation work with parallel make.
27 Mar 2011; Pacho Ramos <pacho@gentoo.org> nspluginwrapper-1.2.2-r2.ebuild,
nspluginwrapper-1.3.0.ebuild:
diff --git a/www-plugins/nspluginwrapper/files/nspluginwrapper-1.4.0-parallel-make.patch b/www-plugins/nspluginwrapper/files/nspluginwrapper-1.4.0-parallel-make.patch
new file mode 100644
index 000000000000..1fc423dc34c5
--- /dev/null
+++ b/www-plugins/nspluginwrapper/files/nspluginwrapper-1.4.0-parallel-make.patch
@@ -0,0 +1,48 @@
+diff -ur nspluginwrapper-1.4.0.orig//Makefile nspluginwrapper-1.4.0/Makefile
+--- nspluginwrapper-1.4.0.orig//Makefile 2011-05-15 15:35:06.000000000 -0400
++++ nspluginwrapper-1.4.0/Makefile 2011-05-24 19:03:50.704343843 -0400
+@@ -242,25 +242,25 @@
+ mkdir -p $(DESTDIR)$(nphostdir) || :
+ mkdir -p $(DESTDIR)$(nptargetdir) || :
+ ifeq ($(build_player),yes)
+-install.player: $(npplayer_PROGRAM)
++install.player: install.dirs $(npplayer_PROGRAM)
+ $(INSTALL) -m 755 $(STRIP_OPT) $(npplayer_PROGRAM) $(DESTDIR)$(nphostdir)/$(npplayer_PROGRAM)
+ mkdir -p $(DESTDIR)$(bindir)
+ $(LN_S) $(nphostdir)/$(npplayer_PROGRAM) $(DESTDIR)$(bindir)/nspluginplayer
+ else
+ install.player:
+ endif
+-install.wrapper: $(npwrapper_LIBRARY)
++install.wrapper: install.dirs $(npwrapper_LIBRARY)
+ $(INSTALL) -m 755 $(STRIP_OPT) $(npwrapper_LIBRARY) $(DESTDIR)$(nphostdir)/$(npwrapper_LIBRARY)
+ ifeq ($(build_viewer),yes)
+-install.viewer: install.viewer.bin install.viewer.glue
+-install.libnoxshm: do.install.libnoxshm
++install.viewer: install.dirs install.viewer.bin install.viewer.glue
++install.libnoxshm: install.dirs do.install.libnoxshm
+ else
+ install.viewer:
+ install.libnoxshm:
+ endif
+ install.viewer.bin: $(npviewer_PROGRAM)
+ $(INSTALL) -m 755 $(STRIP_OPT) $(npviewer_PROGRAM) $(DESTDIR)$(nptargetdir)/$(npviewer_PROGRAM)
+-install.viewer.glue::
++install.viewer.glue:: install.dirs
+ p=$(DESTDIR)$(nptargetdir)/$(npviewer_PROGRAM:%.bin=%); \
+ echo "#!/bin/sh" > $$p; \
+ echo "TARGET_OS=$(TARGET_OS)" >> $$p; \
+@@ -274,11 +274,11 @@
+ chmod 755 $$p
+ do.install.libnoxshm: $(libnoxshm_LIBRARY)
+ $(INSTALL) -m 755 $(STRIP_OPT) $(libnoxshm_LIBRARY) $(DESTDIR)$(nptargetdir)/$(libnoxshm_LIBRARY)
+-install.config: $(npconfig_PROGRAM)
++install.config: install.dirs $(npconfig_PROGRAM)
+ $(INSTALL) -m 755 $(STRIP_OPT) $(npconfig_PROGRAM) $(DESTDIR)$(nphostdir)/$(npconfig_PROGRAM)
+ mkdir -p $(DESTDIR)$(bindir)
+ $(LN_S) $(nphostdir)/$(npconfig_PROGRAM) $(DESTDIR)$(bindir)/nspluginwrapper
+-install.loader: $(nploader_PROGRAM)
++install.loader: install.dirs $(nploader_PROGRAM)
+ $(INSTALL) -m 755 $(nploader_PROGRAM) $(DESTDIR)$(npcommondir)/$(nploader_PROGRAM)
+ install.mkruntime: $(SRC_PATH)/utils/mkruntime.sh
+ $(INSTALL) -m 755 $< $(DESTDIR)$(npcommondir)/mkruntime
diff --git a/www-plugins/nspluginwrapper/nspluginwrapper-1.4.0.ebuild b/www-plugins/nspluginwrapper/nspluginwrapper-1.4.0.ebuild
new file mode 100644
index 000000000000..ea30b0da2e3c
--- /dev/null
+++ b/www-plugins/nspluginwrapper/nspluginwrapper-1.4.0.ebuild
@@ -0,0 +1,95 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-plugins/nspluginwrapper/nspluginwrapper-1.4.0.ebuild,v 1.1 2011/05/24 23:08:11 chutzpah Exp $
+
+EAPI=2
+
+inherit eutils nsplugins multilib flag-o-matic
+
+DESCRIPTION="Netscape Plugin Wrapper - Load 32bit plugins on 64bit browser"
+HOMEPAGE="http://nspluginwrapper.davidben.net/"
+SRC_URI="http://web.mit.edu/davidben/Public/nspluginwrapper/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND=">=x11-libs/gtk+-2:2
+ net-misc/curl
+ app-emulation/emul-linux-x86-xlibs
+ app-emulation/emul-linux-x86-gtklibs
+ >=sys-apps/util-linux-2.13"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+autoinstall() {
+ if [[ -x /usr/bin/${PN} ]]; then
+ einfo "Auto installing 32bit plugins..."
+ ${PN} -a -i
+ ls /usr/$(get_libdir)/nsbrowser/plugins
+
+ # Remove wrappers if equivalent 64-bit plugins exist
+ # TODO: May be better to patch nspluginwrapper so it doesn't create
+ # duplicate wrappers in the first place...
+ local DIR64="${ROOT}/usr/$(get_libdir)/nsbrowser/plugins/"
+ for f in "${DIR64}"/npwrapper.*.so; do
+ local PLUGIN=${f##*/npwrapper.}
+ if [[ -f ${DIR64}/${PLUGIN} ]]; then
+ einfo " Removing duplicate wrapper for native 64-bit ${PLUGIN}"
+ ${PN} -r "${f}"
+ fi
+ done
+ fi
+}
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-1.3.0-gdk-native-windows.patch"
+ epatch "${FILESDIR}/${P}-parallel-make.patch"
+}
+
+src_configure() {
+ replace-flags -O3 -O2
+
+ ./configure --enable-biarch \
+ --target-cpu=i386 \
+ --with-lib32=$(ABI=x86 get_libdir) \
+ --with-lib64=$(get_libdir) \
+ --pkglibdir=/usr/$(get_libdir)/${PN}
+}
+
+src_compile() {
+ emake LDFLAGS_32="-m32 ${LDFLAGS}" || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ inst_plugin "/usr/$(get_libdir)/${PN}/x86_64/linux/npwrapper.so"
+ dosym "/usr/$(get_libdir)/${PN}/x86_64/linux/npconfig" "/usr/bin/${PN}"
+
+ dodoc NEWS README TODO ChangeLog
+}
+
+pkg_postinst() {
+ autoinstall
+ elog "Any 32bit plugins you currently have installed have now been"
+ elog "configured to work in a 64bit browser. Any plugins you install in"
+ elog "the future will first need to be setup with:"
+ elog " \"nspluginwrapper -i <path-to-32bit-plugin>\""
+ elog "before they will function in a 64bit browser"
+ elog
+}
+
+# this is terribly ugly, but without a way to query portage as to whether
+# we are upgrading/reinstalling a package versus unmerging, I can't think of
+# a better way
+
+pkg_prerm() {
+ einfo "Removing wrapper plugins..."
+ ${PN} --auto --remove
+}
+
+pkg_postrm() {
+ autoinstall
+}