summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2010-05-19 14:04:48 +0000
committerChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2010-05-19 14:04:48 +0000
commit036148fa7cbce8d8540f665d040ef4a3d1e949df (patch)
tree88c1174849ef973c5fa8e505dbf361af48e8fa0a /www-plugins
parentkeyworded ~arm. Required for @kdebase-4.4.3 (diff)
downloadgentoo-2-036148fa7cbce8d8540f665d040ef4a3d1e949df.tar.gz
gentoo-2-036148fa7cbce8d8540f665d040ef4a3d1e949df.tar.bz2
gentoo-2-036148fa7cbce8d8540f665d040ef4a3d1e949df.zip
Initial commit
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'www-plugins')
-rw-r--r--www-plugins/lightspark/ChangeLog11
-rw-r--r--www-plugins/lightspark/files/lightspark-0.3.3-llvm-datatypes.patch17
-rw-r--r--www-plugins/lightspark/lightspark-0.3.3.ebuild57
-rw-r--r--www-plugins/lightspark/metadata.xml10
4 files changed, 95 insertions, 0 deletions
diff --git a/www-plugins/lightspark/ChangeLog b/www-plugins/lightspark/ChangeLog
new file mode 100644
index 000000000000..d880cb56c0ec
--- /dev/null
+++ b/www-plugins/lightspark/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for www-plugins/lightspark
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/www-plugins/lightspark/ChangeLog,v 1.1 2010/05/19 14:04:48 chithanh Exp $
+
+*lightspark-0.3.3 (19 May 2010)
+
+ 19 May 2010; Chí-Thanh Christopher Nguyễn <chithanh@gentoo.org>
+ +lightspark-0.3.3.ebuild, +files/lightspark-0.3.3-llvm-datatypes.patch,
+ +metadata.xml:
+ Initial commit, ideas taken from voyageur's live ebuild
+
diff --git a/www-plugins/lightspark/files/lightspark-0.3.3-llvm-datatypes.patch b/www-plugins/lightspark/files/lightspark-0.3.3-llvm-datatypes.patch
new file mode 100644
index 000000000000..2bf56f29f64c
--- /dev/null
+++ b/www-plugins/lightspark/files/lightspark-0.3.3-llvm-datatypes.patch
@@ -0,0 +1,17 @@
+diff -ur a/abc.h b/abc.h
+--- a/abc.h 2010-05-19 05:32:38.000000000 +0200
++++ b/abc.h 2010-05-19 15:30:13.000000000 +0200
+@@ -20,6 +20,13 @@
+ #ifndef _SWF_H
+ #define _SWF_H
+
++#ifndef INT64_C
++# define INT64_C(C) ((int64_t) C ## LL)
++#endif
++#ifndef UINT64_C
++# define UINT64_C(C) ((uint64_t) C ## ULL)
++#endif
++
+ #include "compat.h"
+ #include <llvm/Module.h>
+ #include <llvm/ExecutionEngine/ExecutionEngine.h>
diff --git a/www-plugins/lightspark/lightspark-0.3.3.ebuild b/www-plugins/lightspark/lightspark-0.3.3.ebuild
new file mode 100644
index 000000000000..a407a5a143b9
--- /dev/null
+++ b/www-plugins/lightspark/lightspark-0.3.3.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-plugins/lightspark/lightspark-0.3.3.ebuild,v 1.1 2010/05/19 14:04:48 chithanh Exp $
+
+EAPI=3
+inherit cmake-utils nsplugins multilib
+
+DESCRIPTION="High performance flash player"
+HOMEPAGE="https://launchpad.net/lightspark/"
+SRC_URI="https://launchpad.net/~sssup/+archive/sssup-ppa/+files/${P/-/_}.orig.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="nsplugin"
+
+RDEPEND="dev-libs/libpcre
+ media-video/ffmpeg
+ media-libs/ftgl
+ media-libs/glew
+ media-libs/libsdl
+ net-misc/curl
+ >=sys-devel/llvm-2.7
+ virtual/opengl
+ nsplugin? (
+ dev-libs/nspr
+ net-libs/xulrunner
+ x11-libs/gtk+:2
+ x11-libs/gtkglext
+ )
+ x11-libs/libX11"
+DEPEND="${RDEPEND}
+ dev-lang/nasm
+ dev-util/pkgconfig"
+
+src_prepare() {
+ # TODO: have to think of a less ugly solution
+ epatch "${FILESDIR}"/${P}-llvm-datatypes.patch
+
+ # Adjust plugin directory
+ sed -i "s|/usr/lib/mozilla/|/usr/$(get_libdir)/${PN}/|" plugin-dir/CMakeLists.txt || die
+
+ # Adjust plugin permissions
+ sed -i "s|FILES|PROGRAMS|" plugin-dir/CMakeLists.txt || die
+}
+
+src_configure() {
+ local mycmakeargs="$(cmake-utils_use nsplugin COMPILE_PLUGIN)"
+
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+
+ use nsplugin && inst_plugin /usr/$(get_libdir)/${PN}/plugins/liblightsparkplugin.so
+}
diff --git a/www-plugins/lightspark/metadata.xml b/www-plugins/lightspark/metadata.xml
new file mode 100644
index 000000000000..8fe9668040a6
--- /dev/null
+++ b/www-plugins/lightspark/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>no-herd</herd>
+ <maintainer>
+ <email>chithanh@gentoo.org</email>
+ <name>Chí-Thanh Christopher Nguyễn</name>
+ </maintainer>
+</pkgmetadata>
+