summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <chutzpah@gentoo.org>2011-06-17 02:25:58 +0000
committerPatrick McLean <chutzpah@gentoo.org>2011-06-17 02:25:58 +0000
commit36c492595393ddf48c63224a66c9919677492ba1 (patch)
tree00f15c25dc3949a018b153edc89a58a1e8e6922e /www-plugins/nspluginwrapper/files
parentFix RDEPEND/DEPEND again. (diff)
downloadgentoo-2-36c492595393ddf48c63224a66c9919677492ba1.tar.gz
gentoo-2-36c492595393ddf48c63224a66c9919677492ba1.tar.bz2
gentoo-2-36c492595393ddf48c63224a66c9919677492ba1.zip
Version bump (bug #371705). Forward port the parallel make patch, it appears upstream has the old version.
(Portage version: 2.1.10.3/cvs/Linux x86_64)
Diffstat (limited to 'www-plugins/nspluginwrapper/files')
-rw-r--r--www-plugins/nspluginwrapper/files/nspluginwrapper-1.4.2-parallel-make.patch67
1 files changed, 67 insertions, 0 deletions
diff --git a/www-plugins/nspluginwrapper/files/nspluginwrapper-1.4.2-parallel-make.patch b/www-plugins/nspluginwrapper/files/nspluginwrapper-1.4.2-parallel-make.patch
new file mode 100644
index 000000000000..b3280d6b2c75
--- /dev/null
+++ b/www-plugins/nspluginwrapper/files/nspluginwrapper-1.4.2-parallel-make.patch
@@ -0,0 +1,67 @@
+diff -ur nspluginwrapper-1.4.2.orig//Makefile nspluginwrapper-1.4.2/Makefile
+--- nspluginwrapper-1.4.2.orig//Makefile 2011-06-04 14:41:40.000000000 -0400
++++ nspluginwrapper-1.4.2/Makefile 2011-06-16 22:11:07.059551179 -0400
+@@ -14,7 +14,7 @@
+ endif
+
+ ifeq ($(INSTALL),)
+-INSTALL = install
++INSTALL = install -D
+ ifneq (,$(findstring $(OS),solaris))
+ INSTALL = $(SRC_PATH)/utils/install.sh
+ endif
+@@ -236,44 +236,40 @@
+ uninstall.mkruntime:
+ rm -f $(DESTDIR)$(npcommondir)/mkruntime
+
+-install: install.dirs install.player install.wrapper install.viewer install.libnoxshm install.loader install.config
+-install.dirs:
+- mkdir -p $(DESTDIR)$(npcommondir) || :
+- mkdir -p $(DESTDIR)$(nphostdir) || :
+- mkdir -p $(DESTDIR)$(nptargetdir) || :
++install: install.player install.wrapper install.viewer install.libnoxshm install.loader install.config
+ ifeq ($(build_player),yes)
+-install.player: install.dirs $(npplayer_PROGRAM)
++install.player: $(npplayer_PROGRAM)
+ $(INSTALL) -m 755 $(STRIP_OPT) $(npplayer_PROGRAM) $(DESTDIR)$(nphostdir)/$(npplayer_PROGRAM)
+ mkdir -p $(DESTDIR)$(bindir)
+ $(LN_S) $(nphostdir)/$(npplayer_PROGRAM) $(DESTDIR)$(bindir)/nspluginplayer
+ else
+ install.player:
+ endif
+-install.wrapper: install.dirs $(npwrapper_LIBRARY)
++install.wrapper: $(npwrapper_LIBRARY)
+ $(INSTALL) -m 755 $(STRIP_OPT) $(npwrapper_LIBRARY) $(DESTDIR)$(nphostdir)/$(npwrapper_LIBRARY)
+ ifeq ($(build_viewer),yes)
+-install.viewer: install.dirs install.viewer.bin install.viewer.glue
+-install.libnoxshm: install.dirs do.install.libnoxshm
++install.viewer: install.viewer.bin install.viewer.glue
++install.libnoxshm: do.install.libnoxshm
+ else
+ install.viewer:
+ install.libnoxshm:
+ endif
+-install.viewer.bin: install.dirs $(npviewer_PROGRAM)
++install.viewer.bin: $(npviewer_PROGRAM)
+ $(INSTALL) -m 755 $(STRIP_OPT) $(npviewer_PROGRAM) $(DESTDIR)$(nptargetdir)/$(npviewer_PROGRAM)
+-install.viewer.glue:: install.dirs
++install.viewer.glue:: install.viewer.bin
+ p=$(DESTDIR)$(nptargetdir)/$(npviewer_PROGRAM:%.bin=%); \
+ echo "#!/bin/sh" > $$p; \
+ echo "TARGET_OS=$(TARGET_OS)" >> $$p; \
+ echo "TARGET_ARCH=$(TARGET_ARCH)" >> $$p; \
+ echo ". $(npcommondir)/$(nploader_PROGRAM)" >> $$p; \
+ chmod 755 $$p
+-do.install.libnoxshm: install.dirs $(libnoxshm_LIBRARY)
++do.install.libnoxshm: $(libnoxshm_LIBRARY)
+ $(INSTALL) -m 755 $(STRIP_OPT) $(libnoxshm_LIBRARY) $(DESTDIR)$(nptargetdir)/$(libnoxshm_LIBRARY)
+-install.config: install.dirs $(npconfig_PROGRAM)
++install.config: $(npconfig_PROGRAM)
+ $(INSTALL) -m 755 $(STRIP_OPT) $(npconfig_PROGRAM) $(DESTDIR)$(nphostdir)/$(npconfig_PROGRAM)
+ mkdir -p $(DESTDIR)$(bindir)
+ $(LN_S) $(nphostdir)/$(npconfig_PROGRAM) $(DESTDIR)$(bindir)/nspluginwrapper
+-install.loader: install.dirs $(nploader_PROGRAM)
++install.loader: $(nploader_PROGRAM)
+ $(INSTALL) -m 755 $(nploader_PROGRAM) $(DESTDIR)$(npcommondir)/$(nploader_PROGRAM)
+ install.mkruntime: $(SRC_PATH)/utils/mkruntime.sh
+ $(INSTALL) -m 755 $< $(DESTDIR)$(npcommondir)/mkruntime