summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMounir Lamouri <volkmar@gentoo.org>2009-08-24 17:32:52 +0000
committerMounir Lamouri <volkmar@gentoo.org>2009-08-24 17:32:52 +0000
commitf304d68c60537df485a5bf7c66a1d230509465ca (patch)
tree97d567c04ea635989621624884774608644ff082 /www-plugins/mozilla-weave
parentMasking mozilla-weave testing versions (diff)
downloadgentoo-2-f304d68c60537df485a5bf7c66a1d230509465ca.tar.gz
gentoo-2-f304d68c60537df485a5bf7c66a1d230509465ca.tar.bz2
gentoo-2-f304d68c60537df485a5bf7c66a1d230509465ca.zip
Version bump to 0.6_pre2.
Fixing bug 280606. (Portage version: 14103-svn/cvs/Linux ppc)
Diffstat (limited to 'www-plugins/mozilla-weave')
-rw-r--r--www-plugins/mozilla-weave/ChangeLog8
-rw-r--r--www-plugins/mozilla-weave/mozilla-weave-0.6_pre2.ebuild106
2 files changed, 113 insertions, 1 deletions
diff --git a/www-plugins/mozilla-weave/ChangeLog b/www-plugins/mozilla-weave/ChangeLog
index 59371d2caecf..9e3ee2f570f8 100644
--- a/www-plugins/mozilla-weave/ChangeLog
+++ b/www-plugins/mozilla-weave/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for www-plugins/mozilla-weave
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-plugins/mozilla-weave/ChangeLog,v 1.11 2009/08/23 22:25:42 volkmar Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-plugins/mozilla-weave/ChangeLog,v 1.12 2009/08/24 17:32:52 volkmar Exp $
+
+*mozilla-weave-0.6_pre2 (24 Aug 2009)
+
+ 24 Aug 2009; Mounir Lamouri <volkmar@gentoo.org>
+ +mozilla-weave-0.6_pre2.ebuild:
+ Version bump to 0.6_pre2. Fix bug 280606
*mozilla-weave-0.5.1 (23 Aug 2009)
diff --git a/www-plugins/mozilla-weave/mozilla-weave-0.6_pre2.ebuild b/www-plugins/mozilla-weave/mozilla-weave-0.6_pre2.ebuild
new file mode 100644
index 000000000000..76357eef7d99
--- /dev/null
+++ b/www-plugins/mozilla-weave/mozilla-weave-0.6_pre2.ebuild
@@ -0,0 +1,106 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-plugins/mozilla-weave/mozilla-weave-0.6_pre2.ebuild,v 1.1 2009/08/24 17:32:52 volkmar Exp $
+
+EAPI="2"
+
+inherit mozextension multilib
+
+MY_PN="weave"
+MY_PV=${PV/_/}
+MY_P="${MY_PN}-${MY_PV}"
+
+DESCRIPTION="Mozilla Labs prototype for online services into Firefox"
+HOMEPAGE="http://labs.mozilla.com/projects/weave/"
+SRC_URI="http://hg.mozilla.org/labs/${MY_PN}/archive/${MY_PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="|| ( MPL-1.1 GPL-2 LGPL-2.1 )"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND="|| (
+ >=www-client/mozilla-firefox-3.5
+ >=www-client/mozilla-firefox-bin-3.5
+ >=www-client/seamonkey-2.0_alpha3
+ >=www-client/seamonkey-bin-2.0_alpha3
+ >=mail-client/mozilla-thunderbird-3.0_beta2
+ >=mail-client/mozilla-thunderbird-bin-3.0_beta2
+ )
+ >=net-libs/xulrunner-1.9.1
+ >=dev-libs/nss-3.12
+ >=dev-libs/nspr-4.7.1"
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}/${MY_P}
+
+# XXX: fennec is also listed in install.rdf but not in-tree
+
+src_prepare() {
+ # remove compiled files
+ rm -rf crypto/platform/* || die "rm -rf never dies"
+
+ # upstream bug 504022
+ epatch "${FILESDIR}"/${PN}-0.5.1-pkgconfig.patch
+}
+
+src_compile() {
+ export WEAVE_BUILDID=${PV}
+
+ emake rebuild_crypto=1 release_build=1 xpi || die "emake failed"
+}
+
+src_install() {
+ local MOZILLA_FIVE_HOME xpiname
+
+ mozillas=""
+ xpiname="${MY_P}-rel"
+ xpi_unpack "${S}/dist/xpi/${xpiname}.xpi"
+
+ # FIXME: Hard-coded MOZILLA_FIVE_HOME dirs
+ if has_version '>=www-client/mozilla-firefox-3.5'; then
+ MOZILLA_FIVE_HOME="/usr/$(get_libdir)/mozilla-firefox"
+ xpi_install "${WORKDIR}/${xpiname}"
+ mozillas="$(best_version www-client/mozilla-firefox) ${mozillas}"
+ fi
+ if has_version '>=www-client/mozilla-firefox-bin-3.5'; then
+ MOZILLA_FIVE_HOME="/opt/firefox"
+ xpi_install "${WORKDIR}/${xpiname}"
+ mozillas="$(best_version www-client/mozilla-firefox-bin) ${mozillas}"
+ fi
+ if has_version '>=www-client/seamonkey-2.0_alpha3'; then
+ MOZILLA_FIVE_HOME="/usr/$(get_libdir)/seamonkey"
+ xpi_install "${WORKDIR}/${xpiname}"
+ mozillas="$(best_version www-client/seamonkey) ${mozillas}"
+ fi
+ if has_version '>=www-client/seamonkey-bin-2.0_alpha3'; then
+ MOZILLA_FIVE_HOME="/opt/seamonkey"
+ xpi_install "${WORKDIR}/${xpiname}"
+ mozillas="$(best_version www-client/seamonkey-bin) ${mozillas}"
+ fi
+ if has_version '>=mail-client/mozilla-thunderbird-3.0_beta2'; then
+ MOZILLA_FIVE_HOME="/usr/$(get_libdir)/mozilla-thunderbird"
+ xpi_install "${WORKDIR}/${xpiname}"
+ mozillas="$(best_version mail-client/mozilla-thunderbird) ${mozillas}"
+ fi
+ if has_version '>=mail-client/mozilla-thunderbird-bin-3.0_beta2'; then
+ MOZILLA_FIVE_HOME="/opt/thunderbird"
+ xpi_install "${WORKDIR}/${xpiname}"
+ mozillas="$(best_version mail-client/mozilla-thunderbird-bin) ${mozillas}"
+ fi
+}
+
+pkg_postinst() {
+ elog "To use Weave, you have to get an account at https://services.mozilla.com/"
+ elog "Otherwise, you can setup your own server, see:"
+ elog "https://wiki.mozilla.org/Labs/Weave/0.3/Setup/Server"
+ elog
+ elog "Weave has been installed for the following packages:"
+ for i in ${mozillas}; do
+ elog " $i"
+ done
+ elog
+ elog "After installing other mozilla ebuilds, if you want to use weave with them,"
+ elog "reinstall www-plugins/mozilla-weave"
+}