summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNirbheek Chauhan <nirbheek@gentoo.org>2009-07-13 07:52:14 +0000
committerNirbheek Chauhan <nirbheek@gentoo.org>2009-07-13 07:52:14 +0000
commit5a3023052bc46946d57ee8cb68dab58fe84dd108 (patch)
tree0fe37cf1c3a1f5279b9d40d9e3fb32a607018420 /www-plugins/mozilla-weave
parentAutomated update of use.local.desc (diff)
downloadgentoo-2-5a3023052bc46946d57ee8cb68dab58fe84dd108.tar.gz
gentoo-2-5a3023052bc46946d57ee8cb68dab58fe84dd108.tar.bz2
gentoo-2-5a3023052bc46946d57ee8cb68dab58fe84dd108.zip
Bump to 0.4.0, clean up old versions, and add mozilla as herd.
Add support for seamonkey, mozilla-thunderbird{,-bin}, and mozilla-firefox (Portage version: 2.2_rc33/cvs/Linux i686)
Diffstat (limited to 'www-plugins/mozilla-weave')
-rw-r--r--www-plugins/mozilla-weave/ChangeLog9
-rw-r--r--www-plugins/mozilla-weave/metadata.xml2
-rw-r--r--www-plugins/mozilla-weave/mozilla-weave-0.3.0.ebuild83
-rw-r--r--www-plugins/mozilla-weave/mozilla-weave-0.3.2.ebuild94
-rw-r--r--www-plugins/mozilla-weave/mozilla-weave-0.4.0.ebuild117
5 files changed, 126 insertions, 179 deletions
diff --git a/www-plugins/mozilla-weave/ChangeLog b/www-plugins/mozilla-weave/ChangeLog
index 3b2b9e5282ac..9b59623fa69a 100644
--- a/www-plugins/mozilla-weave/ChangeLog
+++ b/www-plugins/mozilla-weave/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for www-plugins/mozilla-weave
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-plugins/mozilla-weave/ChangeLog,v 1.7 2009/07/06 20:33:27 volkmar Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-plugins/mozilla-weave/ChangeLog,v 1.8 2009/07/13 07:52:14 nirbheek Exp $
+
+*mozilla-weave-0.4.0 (13 Jul 2009)
+
+ 13 Jul 2009; <nirbheek@gentoo.org> -mozilla-weave-0.3.0.ebuild,
+ -mozilla-weave-0.3.2.ebuild, +mozilla-weave-0.4.0.ebuild, metadata.xml:
+ Bump to 0.4.0, clean up old versions, and add mozilla as herd.
+ Add support for seamonkey, mozilla-thunderbird{,-bin}, and mozilla-firefox
06 Jul 2009; Mounir Lamouri <volkmar@gentoo.org>
mozilla-weave-0.2.104.ebuild, mozilla-weave-0.3.0.ebuild,
diff --git a/www-plugins/mozilla-weave/metadata.xml b/www-plugins/mozilla-weave/metadata.xml
index d44dc8ef07cc..7ad0ba3b8bc7 100644
--- a/www-plugins/mozilla-weave/metadata.xml
+++ b/www-plugins/mozilla-weave/metadata.xml
@@ -1,7 +1,7 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <herd>no-herd</herd>
+ <herd>mozilla</herd>
<maintainer>
<email>volkmar@gentoo.org</email>
<name>Mounir Lamouri</name>
diff --git a/www-plugins/mozilla-weave/mozilla-weave-0.3.0.ebuild b/www-plugins/mozilla-weave/mozilla-weave-0.3.0.ebuild
deleted file mode 100644
index d6de7f9a6a20..000000000000
--- a/www-plugins/mozilla-weave/mozilla-weave-0.3.0.ebuild
+++ /dev/null
@@ -1,83 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-plugins/mozilla-weave/mozilla-weave-0.3.0.ebuild,v 1.6 2009/07/06 20:33:27 volkmar Exp $
-
-EAPI="2"
-
-inherit mozextension multilib
-
-MY_PN="weave"
-MY_P=${MY_PN}-${PV}
-
-DESCRIPTION="Mozilla Labs prototype for online services into Firefox"
-HOMEPAGE="http://labs.mozilla.com/projects/weave/"
-SRC_URI="http://hg.mozilla.org/labs/${MY_PN}/index.cgi/archive/${PV}.tar.gz
- -> ${P}.tar.gz"
-
-LICENSE="|| ( MPL-1.1 GPL-2 LGPL-2.1 )"
-SLOT="0"
-KEYWORDS="~x86"
-IUSE=""
-
-RDEPEND=">=www-client/mozilla-firefox-bin-3.1_beta3
- net-libs/xulrunner:1.9
- >=dev-libs/nss-3.12
- >=dev-libs/nspr-4.7.1"
-DEPEND="${RDEPEND}"
-
-S=${WORKDIR}/${MY_P}
-
-RESTRICT="test"
-
-# NOTES:
-# weave is still in heavy development and tests are known to fail so disabled
-# thunderbird and fennec are listed in install.rdf
-# mozilla-firefox-3.{1,5} (not -bin) is not in the tree atm
-
-src_prepare() {
- # we want to use system nss and nspr
- sed -i -e 's@-I\$(sdkdir)\(/include/ns\(s\|pr\)\)@-I/usr\1@' \
- src/Makefile || die "patching Makefile failed"
- sed -i -e 's@^\(libdirs\s*:=\s*.*\)$@\1 /usr/lib/nspr /usr/lib/nss@' \
- src/Makefile || die "patching Makefile failed"
-
- # remove compiled files
- rm -fr platform/* || die "rm -rf never dies"
- rm -f components/WeaveCrypto.so || die "rm -f never dies"
-
- # ppc arch is not recognized on Linux
- # upstream has been contacted w/patch, see bug 486797 in upstream bugtracker
- sed -i -e "s/Power Macintosh/ppc/" src/Makefile \
- || die "patching src/Makefile failed"
-}
-
-src_compile() {
- export XULRUNNER_BIN=/usr/bin/xulrunner-1.9
- export WEAVE_BUILDID=${PV}
- export MOZSDKDIR=/usr/$(get_libdir)/xulrunner-1.9
-
- emake release_build=1 xpi || die "emake failed"
-}
-
-src_install() {
- local MOZILLA_FIVE_HOME
-
- # recommanded usage is to launch firefox with xpi as a parameter
- # so, we unzip the file and intsall it with mozextension tools
- unzip -qo "${MY_P}-rel.xpi" -d "${MY_P}"
-
- if has_version '>=www-client/mozilla-firefox-3.1_beta'; then
- MOZILLA_FIVE_HOME="/usr/$(get_libdir)/mozilla-firefox"
- xpi_install "${S}/${MY_P}"
- fi
- if has_version '>=www-client/mozilla-firefox-bin-3.1_beta'; then
- MOZILLA_FIVE_HOME="/opt/firefox"
- xpi_install "${S}/${MY_P}"
- fi
-}
-
-pkg_postinst() {
- einfo "To use Weave, you have to get an account at https://services.mozilla.com/"
- einfo "Otherwise, you can setup your own server, see:"
- einfo "https://wiki.mozilla.org/Labs/Weave/0.3/Setup/Server"
-}
diff --git a/www-plugins/mozilla-weave/mozilla-weave-0.3.2.ebuild b/www-plugins/mozilla-weave/mozilla-weave-0.3.2.ebuild
deleted file mode 100644
index 88677049cb30..000000000000
--- a/www-plugins/mozilla-weave/mozilla-weave-0.3.2.ebuild
+++ /dev/null
@@ -1,94 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-plugins/mozilla-weave/mozilla-weave-0.3.2.ebuild,v 1.4 2009/07/06 20:33:27 volkmar Exp $
-
-EAPI="2"
-
-inherit mozextension multilib
-
-MY_PN="weave"
-MY_P=${MY_PN}-${PV}
-
-DESCRIPTION="Mozilla Labs prototype for online services into Firefox"
-HOMEPAGE="http://labs.mozilla.com/projects/weave/"
-SRC_URI="http://hg.mozilla.org/labs/${MY_PN}/index.cgi/archive/${PV}.tar.gz
- -> ${P}.tar.gz"
-
-LICENSE="|| ( MPL-1.1 GPL-2 LGPL-2.1 )"
-SLOT="0"
-KEYWORDS="~x86"
-IUSE=""
-
-RDEPEND="|| (
- >=www-client/mozilla-firefox-bin-3.1_beta3
- >=www-client/seamonkey-bin-2.0_alpha3
- )
- net-libs/xulrunner:1.9
- >=dev-libs/nss-3.12
- >=dev-libs/nspr-4.7.1"
-DEPEND="${RDEPEND}"
-
-S=${WORKDIR}/${MY_P}
-
-RESTRICT="test"
-
-# NOTES:
-# weave is still in heavy development and tests are known to fail so disabled
-# thunderbird and fennec are listed in install.rdf
-# mozilla-firefox-3.{1,5} (not -bin) is not in the tree atm
-# seamonkey-2 (not -bin) is not in the tree atm
-
-src_prepare() {
- # we want to use system nss and nspr
- sed -i -e 's@-I\$(sdkdir)\(/include/ns\(s\|pr\)\)@-I/usr\1@' \
- src/Makefile || die "patching Makefile failed"
- sed -i -e 's@^\(libdirs\s*:=\s*.*\)$@\1 /usr/lib/nspr /usr/lib/nss@' \
- src/Makefile || die "patching Makefile failed"
-
- # remove compiled files
- rm -fr platform/* || die "rm -rf never dies"
- rm -f components/WeaveCrypto.so || die "rm -f never dies"
-
- # ppc arch is not recognized on Linux
- # upstream has been contacted w/patch, see bug 486797 in upstream bugtracker
- sed -i -e "s/Power Macintosh/ppc/" src/Makefile \
- || die "patching src/Makefile failed"
-
- # stupid mistake in a var in Makefile
- sed -i -e "s/0.3.1/0.3.2/" Makefile || die "sed failed"
-}
-
-src_compile() {
- export XULRUNNER_BIN=/usr/bin/xulrunner-1.9
- export WEAVE_BUILDID=${PV}
- export MOZSDKDIR=/usr/$(get_libdir)/xulrunner-1.9
-
- emake release_build=1 xpi || die "emake failed"
-}
-
-src_install() {
- local MOZILLA_FIVE_HOME
-
- # recommanded usage is to launch firefox with xpi as a parameter
- # so, we unzip the file and intsall it with mozextension tools
- unzip -qo "${MY_P}-rel.xpi" -d "${MY_P}"
-
- if has_version '>=www-client/mozilla-firefox-3.1_beta3'; then
- MOZILLA_FIVE_HOME="/usr/$(get_libdir)/mozilla-firefox"
- xpi_install "${S}/${MY_P}"
- fi
- if has_version '>=www-client/mozilla-firefox-bin-3.1_beta3'; then
- MOZILLA_FIVE_HOME="/opt/firefox"
- xpi_install "${S}/${MY_P}"
- fi
- if has_version '>=www-client/seamonkey-bin-2.0_alpha3'; then
- MOZILLA_FIVE_HOME="/opt/seamonkey"
- xpi_install "${S}/${MY_P}"
- fi
-}
-
-pkg_postinst() {
- einfo "To use Weave, you have to get an account at https://services.mozilla.com/"
- einfo "Otherwise, you can setup your own server, see:"
- einfo "https://wiki.mozilla.org/Labs/Weave/0.3/Setup/Server"
-}
diff --git a/www-plugins/mozilla-weave/mozilla-weave-0.4.0.ebuild b/www-plugins/mozilla-weave/mozilla-weave-0.4.0.ebuild
new file mode 100644
index 000000000000..04dcdb4bcc76
--- /dev/null
+++ b/www-plugins/mozilla-weave/mozilla-weave-0.4.0.ebuild
@@ -0,0 +1,117 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-plugins/mozilla-weave/mozilla-weave-0.4.0.ebuild,v 1.1 2009/07/13 07:52:14 nirbheek Exp $
+
+EAPI="2"
+
+inherit mozextension multilib
+
+MY_PN="weave"
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="Mozilla Labs prototype for online services into Firefox"
+HOMEPAGE="http://labs.mozilla.com/projects/weave/"
+SRC_URI="http://hg.mozilla.org/labs/${MY_PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="|| ( MPL-1.1 GPL-2 LGPL-2.1 )"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND="|| (
+ >=www-client/mozilla-firefox-3.5
+ >=www-client/mozilla-firefox-bin-3.5
+ >=www-client/seamonkey-bin-2.0_alpha3
+ >=www-client/seamonkey-2.0_alpha3
+ >=mail-client/mozilla-thunderbird-bin-3.0_beta2
+ >=mail-client/mozilla-thunderbird-3.0_beta2
+ )
+ >=net-libs/xulrunner-1.9.1
+ >=dev-libs/nss-3.12
+ >=dev-libs/nspr-4.7.1"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+#RESTRICT="test"
+
+# NOTES:
+# weave is still in heavy development and tests are known to fail so disabled
+# fennec is also listed in install.rdf
+
+src_prepare() {
+ # We want to use system nss and nspr
+ sed -i -e 's@-I\$(sdkdir)\(/include/ns\(s\|pr\)\)@-I/usr\1@' \
+ src/Makefile || die "patching Makefile failed"
+ # XXX: this seds only that libdir which starts the line (ie, ^)
+ sed -i -e 's@^\(libdirs\s*:=\s*.*\)$@\1 /usr/lib/nspr /usr/lib/nss@' \
+ src/Makefile || die "patching Makefile failed"
+
+ # remove compiled files
+ rm -fr platform/* || die "rm -rf never dies"
+}
+
+src_compile() {
+ if has_version '=net-libs/xulrunner-1.9.0*'; then
+ XULRUNNER_BIN=/usr/bin/xulrunner-1.9
+ MOZSDKDIR=/usr/$(get_libdir)/xulrunner-1.9
+ elif has_version '=net-libs/xulrunner-1.9.1*'; then
+ XULRUNNER_BIN=/usr/bin/xulrunner-1.9.1
+ MOZSDKDIR=/usr/$(get_libdir)/xulrunner-1.9.1
+ fi
+ WEAVE_BUILDID=${PV}
+
+ emake release_build=1 xpi || die "emake failed"
+}
+
+src_install() {
+ local MOZILLA_FIVE_HOME xpiname mozillas
+
+ xpiname="${MY_P}-rel.xpi"
+ xpi_unpack "${xpiname}"
+
+ if has_version '>=www-client/mozilla-firefox-3.5'; then
+ MOZILLA_FIVE_HOME="/usr/$(get_libdir)/mozilla-firefox"
+ xpi_install "${S}/${xpiname}"
+ mozillas="$(best_version www-client/mozilla-firefox) ${mozillas}"
+ fi
+ if has_version '>=www-client/mozilla-firefox-bin-3.5'; then
+ MOZILLA_FIVE_HOME="/opt/firefox"
+ xpi_install "${S}/${xpiname}"
+ mozillas="$(best_version www-client/mozilla-firefox-bin) ${mozillas}"
+ fi
+ if has_version '>=www-client/seamonkey-2.0_alpha3'; then
+ MOZILLA_FIVE_HOME="/usr/$(get_libdir)/seamonkey"
+ xpi_install "${S}/${xpiname}"
+ mozillas="$(best_version www-client/seamonkey) ${mozillas}"
+ fi
+ if has_version '>=www-client/seamonkey-bin-2.0_alpha3'; then
+ MOZILLA_FIVE_HOME="/opt/seamonkey"
+ xpi_install "${S}/${xpiname}"
+ mozillas="$(best_version www-client/seamonkey-bin) ${mozillas}"
+ fi
+ if has_version '>=mail-client/mozilla-thunderbird-3.0_beta2'; then
+ MOZILLA_FIVE_HOME="/usr/$(get_libdir)/mozilla-thunderbird"
+ xpi_install "${S}/${xpiname}"
+ mozillas="$(best_version mail-client/mozilla-thunderbird) ${mozillas}"
+ fi
+ if has_version '>=mail-client/mozilla-thunderbird-bin-3.0_beta2'; then
+ MOZILLA_FIVE_HOME="/opt/thunderbird"
+ xpi_install "${S}/${xpiname}"
+ mozillas="$(best_version mail-client/mozilla-thunderbird-bin) ${mozillas}"
+ fi
+}
+
+pkg_postinst() {
+ elog "To use Weave, you have to get an account at https://services.mozilla.com/"
+ elog "Otherwise, you can setup your own server, see:"
+ elog "https://wiki.mozilla.org/Labs/Weave/0.3/Setup/Server"
+ elog
+ elog "Weave has been installed for the following packages:"
+ for i in ${mozillas}; do
+ elog " $i"
+ done
+ elog "After installing other mozilla products, if you want to use weave with them"
+ elog "Reinstall www-plugins/mozilla-weave"
+}