summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMounir Lamouri <volkmar@gentoo.org>2009-04-15 21:32:06 +0000
committerMounir Lamouri <volkmar@gentoo.org>2009-04-15 21:32:06 +0000
commit14ed29777bce1f067d1e9c1da67307d8de755b3d (patch)
treeeb366a93d91c19fd53a1facd0dc9dea775a3e3f0 /www-plugins/mozilla-weave
parentamd64/x86 stable, bug #264505 (diff)
downloadgentoo-2-14ed29777bce1f067d1e9c1da67307d8de755b3d.tar.gz
gentoo-2-14ed29777bce1f067d1e9c1da67307d8de755b3d.tar.bz2
gentoo-2-14ed29777bce1f067d1e9c1da67307d8de755b3d.zip
initial commit, see bug 235397
(Portage version: 2.1.6.7/cvs/Linux ppc)
Diffstat (limited to 'www-plugins/mozilla-weave')
-rw-r--r--www-plugins/mozilla-weave/ChangeLog10
-rw-r--r--www-plugins/mozilla-weave/metadata.xml10
-rw-r--r--www-plugins/mozilla-weave/mozilla-weave-0.2.104.ebuild82
3 files changed, 102 insertions, 0 deletions
diff --git a/www-plugins/mozilla-weave/ChangeLog b/www-plugins/mozilla-weave/ChangeLog
new file mode 100644
index 000000000000..8b0babbd4246
--- /dev/null
+++ b/www-plugins/mozilla-weave/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for www-plugins/mozilla-weave
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/www-plugins/mozilla-weave/ChangeLog,v 1.1 2009/04/15 21:32:06 volkmar Exp $
+
+*mozilla-weave-0.2.104 (15 Apr 2009)
+
+ 15 Apr 2009; Mounir Lamouri <volkmar@gentoo.org> +metadata.xml,
+ +mozilla-weave-0.2.104.ebuild:
+ Initial commit. See bug 235397.
+
diff --git a/www-plugins/mozilla-weave/metadata.xml b/www-plugins/mozilla-weave/metadata.xml
new file mode 100644
index 000000000000..d44dc8ef07cc
--- /dev/null
+++ b/www-plugins/mozilla-weave/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>no-herd</herd>
+ <maintainer>
+ <email>volkmar@gentoo.org</email>
+ <name>Mounir Lamouri</name>
+ </maintainer>
+</pkgmetadata>
+
diff --git a/www-plugins/mozilla-weave/mozilla-weave-0.2.104.ebuild b/www-plugins/mozilla-weave/mozilla-weave-0.2.104.ebuild
new file mode 100644
index 000000000000..c254edb83270
--- /dev/null
+++ b/www-plugins/mozilla-weave/mozilla-weave-0.2.104.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-plugins/mozilla-weave/mozilla-weave-0.2.104.ebuild,v 1.1 2009/04/15 21:32:06 volkmar Exp $
+
+EAPI="2"
+
+inherit mozextension multilib
+
+MY_PN="weave"
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="Mozilla Labs prototype for online services into Firefox"
+HOMEPAGE="http://labs.mozilla.com/projects/weave/"
+SRC_URI="http://hg.mozilla.org/labs/${MY_PN}/index.cgi/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="|| ( MPL-1.1 GPL-2 LGPL-2.1 )"
+SLOT="0"
+KEYWORDS="~ppc"
+IUSE=""
+
+RDEPEND="|| (
+ >=www-client/mozilla-firefox-3
+ >=www-client/mozilla-firefox-bin-3
+ )
+ net-libs/xulrunner:1.9
+ >=dev-libs/nss-3.12
+ >=dev-libs/nspr-4.7.1"
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}/${MY_P}
+
+# NOTES:
+# there are tests but they don't break the build if not working
+# thunderbird and fennec are in install.rdf
+
+src_prepare() {
+ # we want to use system nss and nspr
+ sed -i -e 's@-I\$(sdkdir)\(/include/ns\(s\|pr\)\)@-I/usr\1@' \
+ src/Makefile || die "patching Makefile failed"
+ sed -i -e 's@^\(libdirs\s*:=\s*.*\)$@\1 /usr/lib/nspr /usr/lib/nss@' \
+ src/Makefile || die "patching Makefile failed"
+
+ # remove useless platforms
+ rm -fr platform/* || die "rm -rf never dies"
+
+ # ppc arch is not recognized on Linux
+ # upstream has been contacted w/patch, see bug 486797 in upstream bugtracker
+ sed -i -e "s/Power Macintosh/ppc/" src/Makefile \
+ || die "patching src/Makefile failed"
+}
+
+src_compile() {
+ export XULRUNNER_BIN=/usr/bin/xulrunner-1.9
+ export WEAVE_BUILDID=${PV}
+ export MOZSDKDIR=/usr/$(get_libdir)/xulrunner-1.9
+
+ emake release_build=1 xpi || "emake failed"
+}
+
+src_install() {
+ local MOZILLA_FIVE_HOME
+
+ # recommanded usage is to launch firefox with xpi as a parameter
+ # so, we unzip the file and intsall it with mozextension tools
+ unzip -qo "${MY_P}-rel.xpi" -d "${MY_P}"
+
+ if has_version '>=www-client/mozilla-firefox-3.0'; then
+ MOZILLA_FIVE_HOME="/usr/$(get_libdir)/mozilla-firefox"
+ xpi_install "${S}/${MY_P}"
+ fi
+ if has_version '>=www-client/mozilla-firefox-bin-3.0'; then
+ MOZILLA_FIVE_HOME="/opt/firefox"
+ xpi_install "${S}/${MY_P}"
+ fi
+}
+
+pkg_postinst() {
+ einfo "To use Weave, you have to get an account at https://services.mozilla.com/"
+ einfo "Otherwise, you can setup your own server, see:"
+ einfo "https://wiki.mozilla.org/Labs/Weave/0.3/Setup/Server"
+}