summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMounir Lamouri <volkmar@gentoo.org>2009-08-30 10:36:50 +0000
committerMounir Lamouri <volkmar@gentoo.org>2009-08-30 10:36:50 +0000
commit0f075bc1aaa9610841955e05bc4d2696b119ec76 (patch)
tree7f4acec339949c6fef0b63662d0b3aaace633608 /www-plugins/mozilla-weave
parentCall egamesconf in src_configure, not src_compile (diff)
downloadgentoo-2-0f075bc1aaa9610841955e05bc4d2696b119ec76.tar.gz
gentoo-2-0f075bc1aaa9610841955e05bc4d2696b119ec76.tar.bz2
gentoo-2-0f075bc1aaa9610841955e05bc4d2696b119ec76.zip
Workaround for parallel compilation issues.
(Portage version: 14103-svn/cvs/Linux ppc)
Diffstat (limited to 'www-plugins/mozilla-weave')
-rw-r--r--www-plugins/mozilla-weave/ChangeLog5
-rw-r--r--www-plugins/mozilla-weave/mozilla-weave-0.6.ebuild9
2 files changed, 10 insertions, 4 deletions
diff --git a/www-plugins/mozilla-weave/ChangeLog b/www-plugins/mozilla-weave/ChangeLog
index 94fc44149333..b1d5adc0b3bb 100644
--- a/www-plugins/mozilla-weave/ChangeLog
+++ b/www-plugins/mozilla-weave/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for www-plugins/mozilla-weave
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-plugins/mozilla-weave/ChangeLog,v 1.13 2009/08/28 20:19:45 volkmar Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-plugins/mozilla-weave/ChangeLog,v 1.14 2009/08/30 10:36:50 volkmar Exp $
+
+ 30 Aug 2009; Mounir Lamouri <volkmar@gentoo.org> mozilla-weave-0.6.ebuild:
+ Workaround for parallel compilation issues
*mozilla-weave-0.6 (28 Aug 2009)
diff --git a/www-plugins/mozilla-weave/mozilla-weave-0.6.ebuild b/www-plugins/mozilla-weave/mozilla-weave-0.6.ebuild
index ece5cdbf5a05..6dc1014d2e80 100644
--- a/www-plugins/mozilla-weave/mozilla-weave-0.6.ebuild
+++ b/www-plugins/mozilla-weave/mozilla-weave-0.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-plugins/mozilla-weave/mozilla-weave-0.6.ebuild,v 1.1 2009/08/28 20:19:45 volkmar Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-plugins/mozilla-weave/mozilla-weave-0.6.ebuild,v 1.2 2009/08/30 10:36:50 volkmar Exp $
EAPI="2"
@@ -36,9 +36,12 @@ S=${WORKDIR}/${MY_P}
RESTRICT="test"
-# NOTES: i was not able to get tests running but don't know why... :-/
# XXX: fennec is also listed in install.rdf but not in-tree
+# TODO:
+# make tests working
+# parallel compilation isssues
+
src_prepare() {
# remove compiled files
rm -rf crypto/platform/* || die "rm -rf never dies"
@@ -50,7 +53,7 @@ src_prepare() {
src_compile() {
export WEAVE_BUILDID=${PV}
- emake rebuild_crypto=1 build || die "emake failed"
+ emake -j1 rebuild_crypto=1 build || die "emake failed"
}
#src_test() {