summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2010-09-29 00:29:45 +0000
committerChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2010-09-29 00:29:45 +0000
commite352751335d72645e6f4ed696d11ebaf19bd47af (patch)
tree8f9344a4688e16de122a5bab516e7b41041b3ec7 /www-plugins/gnash
parentMarking nokogiri-1.4.3.1 ~ppc for bug 330283 (diff)
downloadgentoo-2-e352751335d72645e6f4ed696d11ebaf19bd47af.tar.gz
gentoo-2-e352751335d72645e6f4ed696d11ebaf19bd47af.tar.bz2
gentoo-2-e352751335d72645e6f4ed696d11ebaf19bd47af.zip
Fix building of tests, bug #321017
(Portage version: 2.2_rc85/cvs/Linux x86_64)
Diffstat (limited to 'www-plugins/gnash')
-rw-r--r--www-plugins/gnash/ChangeLog6
-rw-r--r--www-plugins/gnash/files/gnash-0.8.8-external-dejagnu.patch24
-rw-r--r--www-plugins/gnash/gnash-0.8.8.ebuild12
3 files changed, 38 insertions, 4 deletions
diff --git a/www-plugins/gnash/ChangeLog b/www-plugins/gnash/ChangeLog
index bee2a71e2bd2..c2f4cb6d21c4 100644
--- a/www-plugins/gnash/ChangeLog
+++ b/www-plugins/gnash/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for www-plugins/gnash
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-plugins/gnash/ChangeLog,v 1.46 2010/09/28 17:37:58 chithanh Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-plugins/gnash/ChangeLog,v 1.47 2010/09/29 00:29:45 chithanh Exp $
+
+ 29 Sep 2010; Chí-Thanh Christopher Nguyễn <chithanh@gentoo.org>
+ gnash-0.8.8.ebuild, +files/gnash-0.8.8-external-dejagnu.patch:
+ Fix building of tests, bug #321017
28 Sep 2010; Chí-Thanh Christopher Nguyễn <chithanh@gentoo.org>
gnash-0.8.8.ebuild, +files/gnash-0.8.8-documentation-paths.patch:
diff --git a/www-plugins/gnash/files/gnash-0.8.8-external-dejagnu.patch b/www-plugins/gnash/files/gnash-0.8.8-external-dejagnu.patch
new file mode 100644
index 000000000000..1453b6df3894
--- /dev/null
+++ b/www-plugins/gnash/files/gnash-0.8.8-external-dejagnu.patch
@@ -0,0 +1,24 @@
+diff -ur a/plugin/npapi/test.cpp b/plugin/npapi/test.cpp
+--- a/plugin/npapi/test.cpp 2010-08-07 17:50:01.000000000 +0200
++++ b/plugin/npapi/test.cpp 2010-09-29 00:08:15.735999998 +0200
+@@ -27,7 +27,7 @@
+ #include "npruntime.h"
+ #include "pluginbase.h"
+ #include "npfunctions.h"
+-#include "dejagnu.h"
++#include <dejagnu.h>
+ #include <regex.h>
+
+ #include "external.h"
+diff -ur a/testsuite/check.h b/testsuite/check.h
+--- a/testsuite/check.h 2010-08-07 17:50:01.000000000 +0200
++++ b/testsuite/check.h 2010-09-29 00:08:33.032999999 +0200
+@@ -11,7 +11,7 @@
+
+ #define HAVE_DEJAGNU_H 1 // we ship our own now...
+ #ifdef HAVE_DEJAGNU_H
+-#include "dejagnu.h"
++#include <dejagnu.h>
+
+ #define info(x) note x
+
diff --git a/www-plugins/gnash/gnash-0.8.8.ebuild b/www-plugins/gnash/gnash-0.8.8.ebuild
index 29104dc1b328..bebafa2e7ef3 100644
--- a/www-plugins/gnash/gnash-0.8.8.ebuild
+++ b/www-plugins/gnash/gnash-0.8.8.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-plugins/gnash/gnash-0.8.8.ebuild,v 1.7 2010/09/28 17:37:58 chithanh Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-plugins/gnash/gnash-0.8.8.ebuild,v 1.8 2010/09/29 00:29:45 chithanh Exp $
EAPI=3
CMAKE_REQUIRED="never"
@@ -80,7 +80,10 @@ RDEPEND=">=dev-libs/boost-1.41.0
DEPEND="${RDEPEND}
dev-util/pkgconfig
nls? ( sys-devel/gettext )
- gnome? ( app-text/rarian )"
+ gnome? ( app-text/rarian )
+ test? ( dev-util/dejagnu )"
+# Tests hang with sandbox, bug #321017
+RESTRICT="test"
pkg_setup() {
if use !ffmpeg && use !gstreamer; then
@@ -143,9 +146,12 @@ src_prepare() {
# gentoo bug #283905
epatch "${FILESDIR}"/${PN}-0.8.7-moc-qt4.patch
- # Install documentation into the proper directories, bug #321017
+ # Install documentation into the proper directories, bug #296110
epatch "${FILESDIR}"/${PN}-0.8.8-documentation-paths.patch
+ # Use external dejagnu for tests, bug #321017
+ epatch "${FILESDIR}"/${PN}-0.8.8-external-dejagnu.patch
+
eautoreconf
}
src_configure() {