summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2011-04-09 09:42:36 +0000
committerChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2011-04-09 09:42:36 +0000
commit645a7da70b7c86265db8801c0783caf9be4ba456 (patch)
treeb5a598278ad81473a9fb5613bc9fa455886244a5 /www-plugins/gnash
parentFinally fix v4l1 automagic and inability to be built with linux-headers-2.6.3... (diff)
downloadgentoo-2-645a7da70b7c86265db8801c0783caf9be4ba456.tar.gz
gentoo-2-645a7da70b7c86265db8801c0783caf9be4ba456.tar.bz2
gentoo-2-645a7da70b7c86265db8801c0783caf9be4ba456.zip
One more patch for recent ffmpeg build failure, bug #362683
(Portage version: 2.2.0_alpha29/cvs/Linux x86_64)
Diffstat (limited to 'www-plugins/gnash')
-rw-r--r--www-plugins/gnash/ChangeLog6
-rw-r--r--www-plugins/gnash/files/gnash-0.8.9-libavcodec-version.patch78
-rw-r--r--www-plugins/gnash/gnash-0.8.9.ebuild5
3 files changed, 86 insertions, 3 deletions
diff --git a/www-plugins/gnash/ChangeLog b/www-plugins/gnash/ChangeLog
index bdd1fc780c2d..f9bf6333432b 100644
--- a/www-plugins/gnash/ChangeLog
+++ b/www-plugins/gnash/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for www-plugins/gnash
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-plugins/gnash/ChangeLog,v 1.58 2011/04/07 23:53:30 chithanh Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-plugins/gnash/ChangeLog,v 1.59 2011/04/09 09:42:36 chithanh Exp $
+
+ 09 Apr 2011; Chí-Thanh Christopher Nguyễn <chithanh@gentoo.org>
+ gnash-0.8.9.ebuild, +files/gnash-0.8.9-libavcodec-version.patch:
+ One more patch for recent ffmpeg build failure, bug #362683
07 Apr 2011; Chí-Thanh Christopher Nguyễn <chithanh@gentoo.org>
gnash-0.8.9.ebuild, +files/gnash-0.8.9-ffmpeg-detection.patch:
diff --git a/www-plugins/gnash/files/gnash-0.8.9-libavcodec-version.patch b/www-plugins/gnash/files/gnash-0.8.9-libavcodec-version.patch
new file mode 100644
index 000000000000..323913e296f6
--- /dev/null
+++ b/www-plugins/gnash/files/gnash-0.8.9-libavcodec-version.patch
@@ -0,0 +1,78 @@
+From 27a4e1f6a5b50e35af8fa29f9cd9fabf5ee777bd Mon Sep 17 00:00:00 2001
+From: Benjamin Wolsey <bwy@benjaminwolsey.de>
+Date: Fri, 01 Apr 2011 11:15:47 +0000
+Subject: FFmpeg trunk uses libavcodec/version.h to store the version.
+
+---
+diff --git a/macros/ffmpeg.m4 b/macros/ffmpeg.m4
+index 4eb68c2..85f11b8 100644
+--- a/macros/ffmpeg.m4
++++ b/macros/ffmpeg.m4
+@@ -22,6 +22,7 @@ AC_DEFUN([GNASH_PATH_FFMPEG],
+ backupLIBS="$LIBS"
+ backupCFLAGS="$CFLAGS"
+ avcodec_h=""
++ avcodec_version_h=""
+ ffmpeg_top_incl=""
+
+ dnl If the user specify an path to include headers from, we assume it's the full
+@@ -46,6 +47,9 @@ AC_DEFUN([GNASH_PATH_FFMPEG],
+ else
+ AC_MSG_ERROR([${with_ffmpeg_incl} directory does not contain the avcodec.h header])
+ fi
++ if test -f ${with_ffmpeg_incl}/version.h; then
++ avcodec_version_h=${with_ffmpeg_incl}/version.h
++ fi
+ fi
+ ])
+
+@@ -182,14 +186,24 @@ AC_DEFUN([GNASH_PATH_FFMPEG],
+ dnl a modified form of grepping may be better, making sure all old kinds of
+ dnl version numbering fail gracefully.
+
++ versionfile=""
++
+ dnl Check avcodec version number, if it was found
+- if test x"${avcodec_h}" != x; then
++ if test x"${avcodec_version_h}" != x; then
++ versionfile=${avcodec_version_h}
++ else
++ if test x"${avcodec_h}" != x; then
++ versionfile=${avcodec_h}
++ fi
++ fi
++
++ if test x"${versionfile}" != x; then
+
+ AC_MSG_CHECKING([ffmpeg version])
+
+- ffmpeg_major_version=`$EGREP "define LIBAVCODEC_VERSION_MAJOR " ${avcodec_h} | sed -e "s%[[^0-9]]%%g"`
+- ffmpeg_minor_version=`$EGREP "define LIBAVCODEC_VERSION_MINOR " ${avcodec_h} | sed -e "s%[[^0-9]]%%g"`
+- ffmpeg_micro_version=`$EGREP "define LIBAVCODEC_VERSION_MICRO " ${avcodec_h} | sed -e "s%[[^0-9]]%%g"`
++ ffmpeg_major_version=`$EGREP "define LIBAVCODEC_VERSION_MAJOR " ${versionfile} | sed -e "s%[[^0-9]]%%g"`
++ ffmpeg_minor_version=`$EGREP "define LIBAVCODEC_VERSION_MINOR " ${versionfile} | sed -e "s%[[^0-9]]%%g"`
++ ffmpeg_micro_version=`$EGREP "define LIBAVCODEC_VERSION_MICRO " ${versionfile} | sed -e "s%[[^0-9]]%%g"`
+
+ if test x"${ffmpeg_major_version}" != x ; then
+
+@@ -198,15 +212,15 @@ AC_DEFUN([GNASH_PATH_FFMPEG],
+ else
+
+ dnl #define LIBAVCODEC_VERSION_TRIPLET 51,50,1
+- ffmpeg_version=`$EGREP "define LIBAVCODEC_VERSION_TRIPLET " ${avcodec_h} | awk '{print $'3'}' | sed -e "s%,%.%g"`
++ ffmpeg_version=`$EGREP "define LIBAVCODEC_VERSION_TRIPLET " ${versionfile} | awk '{print $'3'}' | sed -e "s%,%.%g"`
+
+ if test x"${ffmpeg_version}" = x ; then
+
+ dnl NOTE: the [0-9]*d. pattern discards deb-heads rubbish prefix
+- ffmpeg_version=`$EGREP "define LIBAVCODEC_VERSION " ${avcodec_h} | awk '{print $'3'}' | sed -e "s%^[[0-9]]d\.%%"`
++ ffmpeg_version=`$EGREP "define LIBAVCODEC_VERSION " ${versionfile} | awk '{print $'3'}' | sed -e "s%^[[0-9]]d\.%%"`
+
+ if test x"${ffmpeg_version}" = x ; then
+- ffmpeg_version=`$EGREP "define LIBAVCODEC_BUILD " ${avcodec_h} | awk '{print $'3'}'`
++ ffmpeg_version=`$EGREP "define LIBAVCODEC_BUILD " ${versionfile} | awk '{print $'3'}'`
+ fi
+ fi
+
+--
+cgit v0.8.3.4
diff --git a/www-plugins/gnash/gnash-0.8.9.ebuild b/www-plugins/gnash/gnash-0.8.9.ebuild
index ea6ae0cfff4d..dab8206b2f81 100644
--- a/www-plugins/gnash/gnash-0.8.9.ebuild
+++ b/www-plugins/gnash/gnash-0.8.9.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-plugins/gnash/gnash-0.8.9.ebuild,v 1.3 2011/04/07 23:53:30 chithanh Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-plugins/gnash/gnash-0.8.9.ebuild,v 1.4 2011/04/09 09:42:36 chithanh Exp $
EAPI=3
CMAKE_REQUIRED="never"
@@ -147,8 +147,9 @@ src_prepare() {
# Use external dejagnu for tests, bug #321017
epatch "${FILESDIR}"/${PN}-0.8.9-external-dejagnu.patch
- # Fix detection of recent ffmpeg
+ # Fix detection of recent ffmpeg, bug #362683
epatch "${FILESDIR}"/${PN}-0.8.9-ffmpeg-detection.patch
+ epatch "${FILESDIR}"/${PN}-0.8.9-libavcodec-version.patch
# Fix building on ppc64, bug #342535
use ppc64 && append-flags -mminimal-toc