summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2011-04-10 22:26:46 +0000
committerChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2011-04-10 22:26:46 +0000
commit4f2a51f647cf0a0b6e33db0b309540e232868b8b (patch)
tree1983d2dd721b701f176424005ef1d9a661a2bc3d /www-plugins/gnash
parentFix deprecation warning. (diff)
downloadgentoo-2-4f2a51f647cf0a0b6e33db0b309540e232868b8b.tar.gz
gentoo-2-4f2a51f647cf0a0b6e33db0b309540e232868b8b.tar.bz2
gentoo-2-4f2a51f647cf0a0b6e33db0b309540e232868b8b.zip
Fix bug 362683, attempt to fix bug 362949.
(Portage version: 2.2.0_alpha29/cvs/Linux x86_64)
Diffstat (limited to 'www-plugins/gnash')
-rw-r--r--www-plugins/gnash/ChangeLog7
-rw-r--r--www-plugins/gnash/files/gnash-0.8.9-look-harder-for-version_h.patch13
-rw-r--r--www-plugins/gnash/files/gnash-0.8.9-no-deprecated-avcodec-parser.patch19
-rw-r--r--www-plugins/gnash/gnash-0.8.9.ebuild6
4 files changed, 43 insertions, 2 deletions
diff --git a/www-plugins/gnash/ChangeLog b/www-plugins/gnash/ChangeLog
index f9bf6333432b..72786ec0340f 100644
--- a/www-plugins/gnash/ChangeLog
+++ b/www-plugins/gnash/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for www-plugins/gnash
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-plugins/gnash/ChangeLog,v 1.59 2011/04/09 09:42:36 chithanh Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-plugins/gnash/ChangeLog,v 1.60 2011/04/10 22:26:46 chithanh Exp $
+
+ 10 Apr 2011; Chí-Thanh Christopher Nguyễn <chithanh@gentoo.org>
+ gnash-0.8.9.ebuild, +files/gnash-0.8.9-look-harder-for-version_h.patch,
+ +files/gnash-0.8.9-no-deprecated-avcodec-parser.patch:
+ Fix bug 362683, attempt to fix bug 362949.
09 Apr 2011; Chí-Thanh Christopher Nguyễn <chithanh@gentoo.org>
gnash-0.8.9.ebuild, +files/gnash-0.8.9-libavcodec-version.patch:
diff --git a/www-plugins/gnash/files/gnash-0.8.9-look-harder-for-version_h.patch b/www-plugins/gnash/files/gnash-0.8.9-look-harder-for-version_h.patch
new file mode 100644
index 000000000000..71fc9b58793a
--- /dev/null
+++ b/www-plugins/gnash/files/gnash-0.8.9-look-harder-for-version_h.patch
@@ -0,0 +1,13 @@
+diff -ur a/macros/ffmpeg.m4 b/macros/ffmpeg.m4
+--- a/macros/ffmpeg.m4 2011-04-09 17:26:26.817016067 +0200
++++ b/macros/ffmpeg.m4 2011-04-09 17:51:04.142016943 +0200
+@@ -96,6 +96,9 @@
+ if test -f ${ffmpeg_top_incl}/${i}/avcodec.h; then
+ ac_cv_path_ffmpeg_incl="-I`(cd ${ffmpeg_top_incl}/${i}; pwd)`"
+ avcodec_h=${ffmpeg_top_incl}/${i}/avcodec.h
++ if test -f ${ffmpeg_top_incl}/${i}/version.h; then
++ avcodec_version_h=${ffmpeg_top_incl}/${i}/version.h
++ fi
+ break
+ fi
+ done
diff --git a/www-plugins/gnash/files/gnash-0.8.9-no-deprecated-avcodec-parser.patch b/www-plugins/gnash/files/gnash-0.8.9-no-deprecated-avcodec-parser.patch
new file mode 100644
index 000000000000..9a46b521b755
--- /dev/null
+++ b/www-plugins/gnash/files/gnash-0.8.9-no-deprecated-avcodec-parser.patch
@@ -0,0 +1,19 @@
+diff -ur a/libmedia/ffmpeg/AudioDecoderFfmpeg.cpp b/libmedia/ffmpeg/AudioDecoderFfmpeg.cpp
+--- a/libmedia/ffmpeg/AudioDecoderFfmpeg.cpp 2011-02-26 19:11:08.000000000 +0100
++++ b/libmedia/ffmpeg/AudioDecoderFfmpeg.cpp 2011-04-10 23:59:17.170781787 +0200
+@@ -658,13 +658,13 @@
+ {
+ if ( _needsParsing )
+ {
+- return av_parser_parse(_parser, _audioCodecCtx,
++ return av_parser_parse2(_parser, _audioCodecCtx,
+ // as of 2008-10-28 SVN, ffmpeg doesn't
+ // accept a pointer to pointer to const..
+ const_cast<boost::uint8_t**>(outFrame),
+ outFrameSize,
+ input, inputSize,
+- 0, 0); // pts & dts
++ 0, 0, AV_NOPTS_VALUE); // pts & dts
+ }
+ else
+ {
diff --git a/www-plugins/gnash/gnash-0.8.9.ebuild b/www-plugins/gnash/gnash-0.8.9.ebuild
index dab8206b2f81..668eb90f32ca 100644
--- a/www-plugins/gnash/gnash-0.8.9.ebuild
+++ b/www-plugins/gnash/gnash-0.8.9.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-plugins/gnash/gnash-0.8.9.ebuild,v 1.4 2011/04/09 09:42:36 chithanh Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-plugins/gnash/gnash-0.8.9.ebuild,v 1.5 2011/04/10 22:26:46 chithanh Exp $
EAPI=3
CMAKE_REQUIRED="never"
@@ -150,6 +150,10 @@ src_prepare() {
# Fix detection of recent ffmpeg, bug #362683
epatch "${FILESDIR}"/${PN}-0.8.9-ffmpeg-detection.patch
epatch "${FILESDIR}"/${PN}-0.8.9-libavcodec-version.patch
+ epatch "${FILESDIR}"/${PN}-0.8.9-look-harder-for-version_h.patch
+
+ # Fix linking against recent ffmpeg, bug #362949, upstream #107657
+ epatch "${FILESDIR}"/${PN}-0.8.9-no-deprecated-avcodec-parser.patch
# Fix building on ppc64, bug #342535
use ppc64 && append-flags -mminimal-toc