summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2011-04-07 23:53:30 +0000
committerChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2011-04-07 23:53:30 +0000
commit2426c7f8c3a67a4eaa08615f4436b7f173424e32 (patch)
treeccc6520c6a2e06f4d72cce8c9c15723f32c04b63 /www-plugins/gnash
parentold (diff)
downloadgentoo-2-2426c7f8c3a67a4eaa08615f4436b7f173424e32.tar.gz
gentoo-2-2426c7f8c3a67a4eaa08615f4436b7f173424e32.tar.bz2
gentoo-2-2426c7f8c3a67a4eaa08615f4436b7f173424e32.zip
Fix building against recent ffmpeg, drop useless video_cards_intel.
(Portage version: 2.2.0_alpha29/cvs/Linux x86_64)
Diffstat (limited to 'www-plugins/gnash')
-rw-r--r--www-plugins/gnash/ChangeLog6
-rw-r--r--www-plugins/gnash/files/gnash-0.8.9-ffmpeg-detection.patch22
-rw-r--r--www-plugins/gnash/gnash-0.8.9.ebuild8
3 files changed, 32 insertions, 4 deletions
diff --git a/www-plugins/gnash/ChangeLog b/www-plugins/gnash/ChangeLog
index 2d1ace0e29fc..bdd1fc780c2d 100644
--- a/www-plugins/gnash/ChangeLog
+++ b/www-plugins/gnash/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for www-plugins/gnash
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-plugins/gnash/ChangeLog,v 1.57 2011/03/27 12:03:45 chithanh Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-plugins/gnash/ChangeLog,v 1.58 2011/04/07 23:53:30 chithanh Exp $
+
+ 07 Apr 2011; Chí-Thanh Christopher Nguyễn <chithanh@gentoo.org>
+ gnash-0.8.9.ebuild, +files/gnash-0.8.9-ffmpeg-detection.patch:
+ Fix building against recent ffmpeg, drop useless video_cards_intel.
27 Mar 2011; Chí-Thanh Christopher Nguyễn <chithanh@gentoo.org>
gnash-0.8.8.ebuild, gnash-0.8.9.ebuild:
diff --git a/www-plugins/gnash/files/gnash-0.8.9-ffmpeg-detection.patch b/www-plugins/gnash/files/gnash-0.8.9-ffmpeg-detection.patch
new file mode 100644
index 000000000000..73e478f40ed9
--- /dev/null
+++ b/www-plugins/gnash/files/gnash-0.8.9-ffmpeg-detection.patch
@@ -0,0 +1,22 @@
+From f05022aca2c14022a942d36a22764fae4b8f00c0 Mon Sep 17 00:00:00 2001
+From: Brad Smith <brad@comstyle.com>
+Date: Sun, 03 Apr 2011 10:56:27 +0000
+Subject: Fix newer FFmpeg detection with pkg-config.
+
+---
+diff --git a/macros/ffmpeg.m4 b/macros/ffmpeg.m4
+index 2a3d3fb..42c7555 100644
+--- a/macros/ffmpeg.m4
++++ b/macros/ffmpeg.m4
+@@ -70,6 +70,9 @@ AC_DEFUN([GNASH_PATH_FFMPEG],
+ if test -f ${ffmpeg_top_incl}/${i}/avcodec.h; then
+ ac_cv_path_ffmpeg_incl="-I`(cd ${ffmpeg_top_incl}; pwd)`"
+ avcodec_h="${ffmpeg_top_incl}/${i}/avcodec.h"
++ if test -f ${ffmpeg_top_incl}/${i}/version.h; then
++ avcodec_version_h=${ffmpeg_top_incl}/${i}/version.h
++ fi
+ break
+ fi
+ done
+--
+cgit v0.8.3.4
diff --git a/www-plugins/gnash/gnash-0.8.9.ebuild b/www-plugins/gnash/gnash-0.8.9.ebuild
index 94dc3bde3063..ea6ae0cfff4d 100644
--- a/www-plugins/gnash/gnash-0.8.9.ebuild
+++ b/www-plugins/gnash/gnash-0.8.9.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-plugins/gnash/gnash-0.8.9.ebuild,v 1.2 2011/03/27 12:03:45 chithanh Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-plugins/gnash/gnash-0.8.9.ebuild,v 1.3 2011/04/07 23:53:30 chithanh Exp $
EAPI=3
CMAKE_REQUIRED="never"
@@ -23,7 +23,7 @@ fi
LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
-IUSE="+agg cairo cygnal dbus doc fbcon +ffmpeg gnome gstreamer gtk kde lirc mysql +nls nsplugin opengl openvg python sdl +sdl-sound ssh ssl test vaapi video_cards_intel"
+IUSE="+agg cairo cygnal dbus doc fbcon +ffmpeg gnome gstreamer gtk kde lirc mysql +nls nsplugin opengl openvg python sdl +sdl-sound ssh ssl test vaapi"
# gnash fails if obsolete boost is installed, bug #334259
RDEPEND=">=dev-libs/boost-1.41.0
@@ -147,6 +147,9 @@ src_prepare() {
# Use external dejagnu for tests, bug #321017
epatch "${FILESDIR}"/${PN}-0.8.9-external-dejagnu.patch
+ # Fix detection of recent ffmpeg
+ epatch "${FILESDIR}"/${PN}-0.8.9-ffmpeg-detection.patch
+
# Fix building on ppc64, bug #342535
use ppc64 && append-flags -mminimal-toc
@@ -229,7 +232,6 @@ src_configure() {
$(use_enable ssh) \
$(use_enable ssl) \
$(use_enable test testsuite) \
- $(use_enable video_cards_intel i810-lod-bias) \
--enable-gui=${gui} \
--enable-extensions=${myext} \
--enable-renderer=${renderers} \