summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRenat Lumpau <rl03@gentoo.org>2007-01-03 19:08:48 +0000
committerRenat Lumpau <rl03@gentoo.org>2007-01-03 19:08:48 +0000
commitcd53852dfab94245dd7848555695bccdd87f48a5 (patch)
treee49a3391ab7d79cbf3a56692d4a2325c007ff1b1 /www-misc
parentVersion bump (diff)
downloadgentoo-2-cd53852dfab94245dd7848555695bccdd87f48a5.tar.gz
gentoo-2-cd53852dfab94245dd7848555695bccdd87f48a5.tar.bz2
gentoo-2-cd53852dfab94245dd7848555695bccdd87f48a5.zip
Add ssl support, bug #156003.
(Portage version: 2.1.2_rc4-r4)
Diffstat (limited to 'www-misc')
-rw-r--r--www-misc/htdig/ChangeLog8
-rw-r--r--www-misc/htdig/files/digest-htdig-3.2.0_beta6-r23
-rw-r--r--www-misc/htdig/htdig-3.2.0_beta6-r2.ebuild58
3 files changed, 68 insertions, 1 deletions
diff --git a/www-misc/htdig/ChangeLog b/www-misc/htdig/ChangeLog
index f0a3f20fbe8b..cc184c7a9a44 100644
--- a/www-misc/htdig/ChangeLog
+++ b/www-misc/htdig/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for www-misc/htdig
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-misc/htdig/ChangeLog,v 1.19 2007/01/03 18:28:40 rl03 Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-misc/htdig/ChangeLog,v 1.20 2007/01/03 19:08:47 rl03 Exp $
+
+*htdig-3.2.0_beta6-r2 (03 Jan 2007)
+
+ 03 Jan 2007; Renat Lumpau <rl03@gentoo.org> -htdig-3.2.0_beta6-r1.ebuild,
+ +htdig-3.2.0_beta6-r2.ebuild:
+ Add ssl support, bug #156003.
03 Jan 2007; Renat Lumpau <rl03@gentoo.org> -htdig-3.2.0_beta6.ebuild:
Housekeeping
diff --git a/www-misc/htdig/files/digest-htdig-3.2.0_beta6-r2 b/www-misc/htdig/files/digest-htdig-3.2.0_beta6-r2
new file mode 100644
index 000000000000..71d425d06977
--- /dev/null
+++ b/www-misc/htdig/files/digest-htdig-3.2.0_beta6-r2
@@ -0,0 +1,3 @@
+MD5 8a6952f5b97e305dbb7489045bad220f htdig-3.2.0b6.tar.gz 3104936
+RMD160 621e85920f3452bc1a28a61cf7f8b3e08808bc55 htdig-3.2.0b6.tar.gz 3104936
+SHA256 6da9e0ee8627d5302f5685a1b3e5de5f1e6e8df4c0a92c0ca00796bca9e546c8 htdig-3.2.0b6.tar.gz 3104936
diff --git a/www-misc/htdig/htdig-3.2.0_beta6-r2.ebuild b/www-misc/htdig/htdig-3.2.0_beta6-r2.ebuild
new file mode 100644
index 000000000000..bc5d45a4adea
--- /dev/null
+++ b/www-misc/htdig/htdig-3.2.0_beta6-r2.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-misc/htdig/htdig-3.2.0_beta6-r2.ebuild,v 1.1 2007/01/03 19:08:47 rl03 Exp $
+
+inherit eutils autotools
+
+MY_PV=${PV/_beta/b}
+S=${WORKDIR}/${PN}-${MY_PV}
+
+DESCRIPTION="HTTP/HTML indexing and searching system"
+SRC_URI="http://www.htdig.org/files/${PN}-${MY_PV}.tar.gz"
+HOMEPAGE="http://www.htdig.org"
+KEYWORDS="amd64 ~mips ~ppc ~sparc ~x86"
+LICENSE="GPL-2"
+
+DEPEND=">=sys-libs/zlib-1.1.3
+ app-arch/unzip
+ ssl? ( dev-libs/openssl )"
+
+IUSE="ssl"
+SLOT="0"
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}
+ epatch ${FILESDIR}/${P}-gcc4.patch
+ epatch ${FILESDIR}/${P}-as-needed.patch
+ eautoreconf
+}
+
+src_compile() {
+ econf $(use_with ssl) \
+ --with-config-dir=/etc/${PN} \
+ --with-default-config-file=/etc/${PN}/${PN}.conf \
+ --with-database-dir=/var/lib/${PN}/db \
+ --with-cgi-bin-dir=/var/www/localhost/cgi-bin \
+ --with-search-dir=/var/www/localhost/htdocs/${PN} \
+ --with-image-dir=/var/www/localhost/htdocs/${PN} \
+ || die "configure failed"
+
+# --with-image-url-prefix=file:///var/www/localhost/htdocs/${PN} \
+
+ emake || die "emake failed"
+}
+
+src_install () {
+ emake DESTDIR=${D} install || die "make install failed"
+
+ dodoc ChangeLog COPYING README
+ dohtml -r htdoc
+
+ dosed /etc/${PN}/${PN}.conf
+ dosed /usr/bin/rundig
+
+ # symlink htsearch so it can be easily found. see bug #62087
+ dosym /var/www/localhost/cgi-bin/htsearch /usr/bin/htsearch
+}