summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTiziano Müller <dev-zero@gentoo.org>2013-05-14 21:39:22 +0000
committerTiziano Müller <dev-zero@gentoo.org>2013-05-14 21:39:22 +0000
commit3494e9436ee76fcf81067590ad5f9cf853558a73 (patch)
treea1a173e92e71b29e0c71d32eeca4bb4d3a11658a /www-misc
parentVersion bump, drop old (diff)
downloadgentoo-2-3494e9436ee76fcf81067590ad5f9cf853558a73.tar.gz
gentoo-2-3494e9436ee76fcf81067590ad5f9cf853558a73.tar.bz2
gentoo-2-3494e9436ee76fcf81067590ad5f9cf853558a73.zip
Initial commit, ebuild written by me.
(Portage version: 2.1.11.63/cvs/Linux x86_64, signed Manifest commit with key 0x1E0CA85F!)
Diffstat (limited to 'www-misc')
-rw-r--r--www-misc/nx_util/ChangeLog9
-rw-r--r--www-misc/nx_util/files/0.3-fix-install-paths.patch47
-rw-r--r--www-misc/nx_util/metadata.xml11
-rw-r--r--www-misc/nx_util/nx_util-0.3.ebuild30
4 files changed, 97 insertions, 0 deletions
diff --git a/www-misc/nx_util/ChangeLog b/www-misc/nx_util/ChangeLog
new file mode 100644
index 000000000000..9530361b890e
--- /dev/null
+++ b/www-misc/nx_util/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for www-misc/nx_util
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/www-misc/nx_util/ChangeLog,v 1.1 2013/05/14 21:39:22 dev-zero Exp $
+
+*nx_util-0.3 (14 May 2013)
+
+ 14 May 2013; Tiziano Müller <dev-zero@gentoo.org>
+ +files/0.3-fix-install-paths.patch, +metadata.xml, +nx_util-0.3.ebuild:
+ Initial commit, ebuild written by me.
diff --git a/www-misc/nx_util/files/0.3-fix-install-paths.patch b/www-misc/nx_util/files/0.3-fix-install-paths.patch
new file mode 100644
index 000000000000..919c94ac4ed4
--- /dev/null
+++ b/www-misc/nx_util/files/0.3-fix-install-paths.patch
@@ -0,0 +1,47 @@
+diff --git a/nx_util.conf b/nx_util.conf
+index cd2a591..818daaf 100644
+--- a/nx_util.conf
++++ b/nx_util.conf
+@@ -1,4 +1,4 @@
+ [nx_util]
+-data_dir=/usr/local/nx_datas
++data_dir=/usr/share/nx_datas
+ database_dir=
+ naxsi_core_rules=/etc/nginx/naxsi_core.rules
+diff --git a/nx_util.py b/nx_util.py
+index 81c5030..eb7e888 100755
+--- a/nx_util.py
++++ b/nx_util.py
+@@ -61,8 +61,8 @@ nginx/naxsi log parser, whitelist and report generator.
+
+ # Configuration
+ parser.add_option("-c", "--config", dest="conf_path",
+- help="Path to configuration (defaults to /usr/local/etc/nx_util.conf)",
+- type="string", default="/usr/local/etc/nx_util.conf")
++ help="Path to configuration (defaults to /etc/nx_util.conf)",
++ type="string", default="/etc/nx_util.conf")
+
+ # Filtering options should go here :)
+ parser.add_option("-f", "--filters", dest="usr_filter",
+diff --git a/setup.py b/setup.py
+index c08f4e6..7b15fd8 100644
+--- a/setup.py
++++ b/setup.py
+@@ -8,14 +8,14 @@ setup(name='nx_util',
+ author='Naxsi Dev Team',
+ author_email='thibault.koechlin@nbs-system.com',
+ url='naxsi.googlecode.com',
+- scripts=['nx_util.py'],
++ scripts=['nx_util'],
+ packages=['nx_lib'],
+- data_files=[('nx_datas', ['nx_datas/bootstrap.min.css',
++ data_files=[('/usr/share/nx_datas', ['nx_datas/bootstrap.min.css',
+ 'nx_datas/bootstrap-responsive.min.css',
+ 'nx_datas/highcharts.js',
+ 'nx_datas/map.tpl',
+ 'nx_datas/bootstrap.min.js',
+ 'nx_datas/country2coords.txt']),
+ ('/usr/share/man/man1', ['nx_util.1.gz']),
+- ('/usr/local/etc/', ['nx_util.conf'])]
++ ('/etc/', ['nx_util.conf'])]
+ )
diff --git a/www-misc/nx_util/metadata.xml b/www-misc/nx_util/metadata.xml
new file mode 100644
index 000000000000..c8a6a20d555f
--- /dev/null
+++ b/www-misc/nx_util/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>dev-zero@gentoo.org</email>
+ <name>Tiziano Müller</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="google-code">naxsi</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/www-misc/nx_util/nx_util-0.3.ebuild b/www-misc/nx_util/nx_util-0.3.ebuild
new file mode 100644
index 000000000000..7d7e683932bd
--- /dev/null
+++ b/www-misc/nx_util/nx_util-0.3.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-misc/nx_util/nx_util-0.3.ebuild,v 1.1 2013/05/14 21:39:22 dev-zero Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE="sqlite"
+DISTUTILS_SINGLE_IMPL=true
+
+inherit distutils-r1
+
+DESCRIPTION="Whitelist & Reports generation for Naxsi (Web Application Firewall module for Nginx)."
+HOMEPAGE="https://code.google.com/p/naxsi/"
+SRC_URI="https://naxsi.googlecode.com/files/${P}.tgz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND=""
+RDEPEND="www-servers/nginx[nginx_modules_http_naxsi]"
+
+PATCHES=( "${FILESDIR}/${PV}-fix-install-paths.patch" )
+
+src_prepare() {
+ distutils-r1_src_prepare
+ mv nx_util{.py,} || die "renaming script failed"
+}