summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRenat Lumpau <rl03@gentoo.org>2007-01-03 15:51:57 +0000
committerRenat Lumpau <rl03@gentoo.org>2007-01-03 15:51:57 +0000
commit2ce65decd59f5eba32d8db431ac94c926d9074d2 (patch)
tree7be4ee3d2dd406e80959bb448bf9adc44aa8b8fb /www-misc
parentVersion bump. (diff)
downloadgentoo-2-2ce65decd59f5eba32d8db431ac94c926d9074d2.tar.gz
gentoo-2-2ce65decd59f5eba32d8db431ac94c926d9074d2.tar.bz2
gentoo-2-2ce65decd59f5eba32d8db431ac94c926d9074d2.zip
fix for --as-needed, bug #155727.
(Portage version: 2.1.2_rc4-r4)
Diffstat (limited to 'www-misc')
-rw-r--r--www-misc/htdig/ChangeLog8
-rw-r--r--www-misc/htdig/files/htdig-3.2.0_beta6-as-needed.patch61
-rw-r--r--www-misc/htdig/htdig-3.2.0_beta6-r1.ebuild10
3 files changed, 73 insertions, 6 deletions
diff --git a/www-misc/htdig/ChangeLog b/www-misc/htdig/ChangeLog
index fe590d02e355..e7917cac3cfa 100644
--- a/www-misc/htdig/ChangeLog
+++ b/www-misc/htdig/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for www-misc/htdig
-# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-misc/htdig/ChangeLog,v 1.17 2006/05/05 17:16:53 squinky86 Exp $
+# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/www-misc/htdig/ChangeLog,v 1.18 2007/01/03 15:51:57 rl03 Exp $
+
+ 03 Jan 2007; Renat Lumpau <rl03@gentoo.org>
+ +files/htdig-3.2.0_beta6-as-needed.patch, htdig-3.2.0_beta6-r1.ebuild:
+ fix for --as-needed, bug #155727.
05 May 2006; Jon Hood <squinky86@gentoo.org> htdig-3.2.0_beta6-r1.ebuild:
Stable on amd64, bug #107062.
diff --git a/www-misc/htdig/files/htdig-3.2.0_beta6-as-needed.patch b/www-misc/htdig/files/htdig-3.2.0_beta6-as-needed.patch
new file mode 100644
index 000000000000..bf455ea8b637
--- /dev/null
+++ b/www-misc/htdig/files/htdig-3.2.0_beta6-as-needed.patch
@@ -0,0 +1,61 @@
+--- htdig-3.2.0b6/Makefile.config.orig 2006-11-19 08:49:57.000000000 -0800
++++ htdig-3.2.0b6/Makefile.config 2006-11-19 08:51:19.000000000 -0800
+@@ -22,10 +22,7 @@
+ $(LOCAL_DEFINES) $(PROFILING)
+
+ HTLIBS= $(top_builddir)/htnet/libhtnet.la \
+- $(top_builddir)/htcommon/libcommon.la \
+- $(top_builddir)/htword/libhtword.la \
+ $(top_builddir)/htlib/libht.la \
+ $(top_builddir)/htcommon/libcommon.la \
+ $(top_builddir)/htword/libhtword.la \
+- $(top_builddir)/db/libhtdb.la \
+- $(top_builddir)/htlib/libht.la
++ $(top_builddir)/db/libhtdb.la
+--- htdig-3.2.0b6/htlib/Makefile.am.orig 2006-11-19 09:13:47.000000000 -0800
++++ htdig-3.2.0b6/htlib/Makefile.am 2006-11-19 09:17:50.000000000 -0800
+@@ -1,7 +1,8 @@
+ include $(top_srcdir)/Makefile.config
+
+ pkglib_LTLIBRARIES = libht.la
+-
++libht_la_DEPENDENCIES = $(top_builddir)/db/libhtdb.la
++libht_la_LIBADD= $(top_builddir)/db/libhtdb.la
+ libht_la_SOURCES = Configuration.cc Database.cc Dictionary.cc \
+ DB2_db.cc IntObject.cc List.cc Object.cc \
+ ParsedString.cc Queue.cc QuotedStringList.cc Stack.cc \
+@@ -17,9 +18,6 @@
+ myqsort.c \
+ md5.cc mhash_md5.c
+
+-libht_la_LIBADD=@LTLIBOBJS@
+-# this includes regex.c
+-
+ libht_la_LDFLAGS = -release $(HTDIG_MAJOR_VERSION).$(HTDIG_MINOR_VERSION).$(HTDIG_MICRO_VERSION) ${extra_ldflags}
+
+ pkginclude_HEADERS = \
+--- htdig-3.2.0b6/htword/Makefile.am.orig 2006-11-19 08:55:08.000000000 -0800
++++ htdig-3.2.0b6/htword/Makefile.am 2006-11-19 08:56:51.000000000 -0800
+@@ -10,7 +10,8 @@
+ LOCAL_DEFINES =
+
+ pkglib_LTLIBRARIES = libhtword.la
+-
++libhtword_la_DEPENDENCIES = $(top_builddir)/htlib/libht.la
++libhtword_la_LIBADD = $(top_builddir)/htlib/libht.la
+ libhtword_la_SOURCES = \
+ WordBitCompress.cc \
+ WordContext.cc \
+
+--- htdig-3.2.0b6/htcommon/Makefile.am.orig 2006-11-19 09:32:39.000000000 -0800
++++ htdig-3.2.0b6/htcommon/Makefile.am 2006-11-19 09:33:42.000000000 -0800
+@@ -12,7 +12,8 @@
+ EXTRA_DIST=conf_lexer.cxx conf_parser.cxx
+
+ pkglib_LTLIBRARIES = libcommon.la
+-
++libcommon_la_DEPENDENCIES = $(top_builddir)/htword/libhtword.la
++libcommon_la_LIBADD = $(top_builddir)/htword/libhtword.la
+ libcommon_la_SOURCES = DocumentDB.cc DocumentRef.cc \
+ HtWordReference.cc HtWordList.cc defaults.cc \
+ HtURLCodec.cc URL.cc URLTrans.cc \
diff --git a/www-misc/htdig/htdig-3.2.0_beta6-r1.ebuild b/www-misc/htdig/htdig-3.2.0_beta6-r1.ebuild
index 0f9b85eeb782..6fac07a2b10d 100644
--- a/www-misc/htdig/htdig-3.2.0_beta6-r1.ebuild
+++ b/www-misc/htdig/htdig-3.2.0_beta6-r1.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-misc/htdig/htdig-3.2.0_beta6-r1.ebuild,v 1.2 2006/05/05 17:16:53 squinky86 Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-misc/htdig/htdig-3.2.0_beta6-r1.ebuild,v 1.3 2007/01/03 15:51:57 rl03 Exp $
-inherit eutils flag-o-matic
+inherit eutils autotools
MY_PV=${PV/_beta/b}
S=${WORKDIR}/${PN}-${MY_PV}
@@ -23,6 +23,8 @@ src_unpack() {
cd ${S}
epatch ${FILESDIR}/${P}-gcc4.patch
+ epatch ${FILESDIR}/${P}-as-needed.patch
+ eautoreconf
}
src_compile() {
@@ -40,7 +42,7 @@ src_compile() {
}
src_install () {
- make DESTDIR=${D} install || die "make install failed"
+ emake DESTDIR=${D} install || die "make install failed"
dodoc ChangeLog COPYING README
dohtml -r htdoc