summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2012-09-03 19:10:43 +0000
committerTim Harder <radhermit@gentoo.org>2012-09-03 19:10:43 +0000
commit851dea12c322794f91b6f3c4b1e37190422a461d (patch)
tree686d79182facc576133cd68f78e6d539a8122955 /www-misc/urlwatch
parentVersion bump to 2.9.0 (diff)
downloadgentoo-2-851dea12c322794f91b6f3c4b1e37190422a461d.tar.gz
gentoo-2-851dea12c322794f91b6f3c4b1e37190422a461d.tar.bz2
gentoo-2-851dea12c322794f91b6f3c4b1e37190422a461d.zip
Version bump.
(Portage version: 2.2.0_alpha124/cvs/Linux x86_64)
Diffstat (limited to 'www-misc/urlwatch')
-rw-r--r--www-misc/urlwatch/ChangeLog7
-rw-r--r--www-misc/urlwatch/urlwatch-1.15.ebuild38
2 files changed, 44 insertions, 1 deletions
diff --git a/www-misc/urlwatch/ChangeLog b/www-misc/urlwatch/ChangeLog
index bd667ca65f13..197530117980 100644
--- a/www-misc/urlwatch/ChangeLog
+++ b/www-misc/urlwatch/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for www-misc/urlwatch
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-misc/urlwatch/ChangeLog,v 1.2 2012/03/23 19:43:52 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-misc/urlwatch/ChangeLog,v 1.3 2012/09/03 19:10:43 radhermit Exp $
+
+*urlwatch-1.15 (03 Sep 2012)
+
+ 03 Sep 2012; Tim Harder <radhermit@gentoo.org> +urlwatch-1.15.ebuild:
+ Version bump.
23 Mar 2012; Tim Harder <radhermit@gentoo.org> urlwatch-1.14.ebuild:
Drop conditional dependency until there's a way to specify them correctly
diff --git a/www-misc/urlwatch/urlwatch-1.15.ebuild b/www-misc/urlwatch/urlwatch-1.15.ebuild
new file mode 100644
index 000000000000..5b8df4c5bf10
--- /dev/null
+++ b/www-misc/urlwatch/urlwatch-1.15.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-misc/urlwatch/urlwatch-1.15.ebuild,v 1.1 2012/09/03 19:10:43 radhermit Exp $
+
+EAPI="4"
+PYTHON_DEPEND="2:2.5 3:3.2"
+SUPPORT_PYTHON_ABIS="1"
+DISTUTILS_USE_SEPARATE_SOURCE_DIRECTORIES="1"
+
+inherit distutils eutils
+
+DESCRIPTION="A tool for monitoring webpages for updates"
+HOMEPAGE="http://thp.io/2008/urlwatch/ http://pypi.python.org/pypi/urlwatch"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="xmpp"
+
+DEPEND="dev-python/futures"
+RDEPEND="${DEPEND}
+ xmpp? ( dev-python/xmpppy )
+ || ( www-client/lynx app-text/html2text )"
+
+src_prepare() {
+ use xmpp && epatch "${FILESDIR}"/${PN}-xmpp.patch
+ sed -i "s/^os.unlink/#\0/" setup.py || die
+
+ distutils_src_prepare
+
+ 2to3_conversion() {
+ [[ "${PYTHON_ABI}" == 2.* ]] && return
+ 2to3-${PYTHON_ABI} -nw --no-diffs urlwatch lib/urlwatch/*.py \
+ examples/hooks.py.example setup.py || die "2to3 failed"
+ }
+ python_execute_function -s 2to3_conversion
+}