summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Huddleston <eradicator@gentoo.org>2006-03-22 19:45:58 +0000
committerJeremy Huddleston <eradicator@gentoo.org>2006-03-22 19:45:58 +0000
commit2da109e25bd22e20c5b40f6d3687ba0a6a3f23ee (patch)
tree11bb02fcf97c580847a3a9c981df2dcd6edaefef /www-misc/htdig
parentBump to 0.11 (diff)
downloadgentoo-2-2da109e25bd22e20c5b40f6d3687ba0a6a3f23ee.tar.gz
gentoo-2-2da109e25bd22e20c5b40f6d3687ba0a6a3f23ee.tar.bz2
gentoo-2-2da109e25bd22e20c5b40f6d3687ba0a6a3f23ee.zip
Fixed compilation with gcc4. Closes bug #126509.
(Portage version: 2.1_pre6-r5)
Diffstat (limited to 'www-misc/htdig')
-rw-r--r--www-misc/htdig/ChangeLog8
-rw-r--r--www-misc/htdig/files/htdig-3.2.0_beta6-gcc4.patch15
-rw-r--r--www-misc/htdig/htdig-3.2.0_beta6.ebuild11
3 files changed, 30 insertions, 4 deletions
diff --git a/www-misc/htdig/ChangeLog b/www-misc/htdig/ChangeLog
index 07bb1d15dc3e..3f8ae272cb61 100644
--- a/www-misc/htdig/ChangeLog
+++ b/www-misc/htdig/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for www-misc/htdig
-# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-misc/htdig/ChangeLog,v 1.14 2005/12/06 14:40:15 rl03 Exp $
+# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/www-misc/htdig/ChangeLog,v 1.15 2006/03/22 19:45:58 eradicator Exp $
+
+ 22 Mar 2006; Jeremy Huddleston <eradicator@gentoo.org>
+ +files/htdig-3.2.0_beta6-gcc4.patch, htdig-3.2.0_beta6.ebuild:
+ Fixed compilation with gcc4. Closes bug #126509.
06 Dec 2005; Renat Lumpau <rl03@gentoo.org> -files/reconfig,
htdig-3.2.0_beta6.ebuild:
diff --git a/www-misc/htdig/files/htdig-3.2.0_beta6-gcc4.patch b/www-misc/htdig/files/htdig-3.2.0_beta6-gcc4.patch
new file mode 100644
index 000000000000..58dec13957e2
--- /dev/null
+++ b/www-misc/htdig/files/htdig-3.2.0_beta6-gcc4.patch
@@ -0,0 +1,15 @@
+diff -Naurp htdig-3.2.0b6.orig/htsearch/Collection.h htdig-3.2.0b6/htsearch/Collection.h
+--- htdig-3.2.0b6.orig/htsearch/Collection.h 2004-05-28 06:15:24.000000000 -0700
++++ htdig-3.2.0b6/htsearch/Collection.h 2006-03-22 11:35:40.000000000 -0800
+@@ -36,9 +36,9 @@ public:
+ const char *docExcerpt);
+ ~Collection();
+
+- void Collection::Open();
++ void Open();
+
+- void Collection::Close();
++ void Close();
+
+ char *getWordFile() { return wordFile.get(); }
+ DocumentRef *getDocumentRef(int id);
diff --git a/www-misc/htdig/htdig-3.2.0_beta6.ebuild b/www-misc/htdig/htdig-3.2.0_beta6.ebuild
index e531505d7d34..c34b34ec198a 100644
--- a/www-misc/htdig/htdig-3.2.0_beta6.ebuild
+++ b/www-misc/htdig/htdig-3.2.0_beta6.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-misc/htdig/htdig-3.2.0_beta6.ebuild,v 1.5 2005/12/06 14:40:15 rl03 Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-misc/htdig/htdig-3.2.0_beta6.ebuild,v 1.6 2006/03/22 19:45:58 eradicator Exp $
inherit webapp eutils flag-o-matic
@@ -20,6 +20,13 @@ DEPEND="${RDEPEND}"
SLOT="0"
WEBAPP_MANUAL_SLOT="yes"
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}
+ epatch ${FILESDIR}/${P}-gcc4.patch
+}
+
src_compile() {
./configure \
--prefix=/usr \