summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRenat Lumpau <rl03@gentoo.org>2005-07-06 21:40:24 +0000
committerRenat Lumpau <rl03@gentoo.org>2005-07-06 21:40:24 +0000
commit2243bd3ca301e9dd03a214f84302dd8d5bdd0b92 (patch)
tree102e033b124f4234f3b0410b452a75b97aeb5a0f /www-misc/htdig/htdig-3.2.0_beta6.ebuild
parentsync IUSE (-pic) (diff)
downloadgentoo-2-2243bd3ca301e9dd03a214f84302dd8d5bdd0b92.tar.gz
gentoo-2-2243bd3ca301e9dd03a214f84302dd8d5bdd0b92.tar.bz2
gentoo-2-2243bd3ca301e9dd03a214f84302dd8d5bdd0b92.zip
Added version
(Portage version: 2.0.51.22-r1)
Diffstat (limited to 'www-misc/htdig/htdig-3.2.0_beta6.ebuild')
-rw-r--r--www-misc/htdig/htdig-3.2.0_beta6.ebuild58
1 files changed, 58 insertions, 0 deletions
diff --git a/www-misc/htdig/htdig-3.2.0_beta6.ebuild b/www-misc/htdig/htdig-3.2.0_beta6.ebuild
new file mode 100644
index 000000000000..0bbfd2e29ec2
--- /dev/null
+++ b/www-misc/htdig/htdig-3.2.0_beta6.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-misc/htdig/htdig-3.2.0_beta6.ebuild,v 1.1 2005/07/06 21:40:24 rl03 Exp $
+
+inherit webapp eutils flag-o-matic
+
+MY_PV=${PV/_beta/b}
+S=${WORKDIR}/${PN}-${MY_PV}
+
+DESCRIPTION="HTTP/HTML indexing and searching system"
+SRC_URI="http://www.htdig.org/files/${PN}-${MY_PV}.tar.gz"
+HOMEPAGE="http://www.htdig.org"
+KEYWORDS="~x86 ~sparc ~ppc ~mips ~amd64"
+LICENSE="GPL-2"
+
+RDEPEND=">=sys-libs/zlib-1.1.3
+ app-arch/unzip"
+DEPEND="${RDEPEND}"
+
+export CPPFLAGS="${CPPFLAGS} -Wno-deprecated"
+
+src_compile() {
+ append-flags -Wno-deprecated
+
+ ./configure \
+ --prefix=/usr \
+ --with-config-dir=/${MY_HOSTROOTDIR}/${PN} \
+ --with-default-config-file=${MY_HOSTROOTDIR}/${PN}/${PN}.conf \
+ --with-common-dir=/usr/share/${PN} \
+ --with-database-dir=${MY_HOSTROOTDIR}/${PN}/db \
+ --with-cgi-bin-dir=${MY_CGIBINDIR} \
+ --with-image-dir=${MY_HTDOCSDIR} \
+ --with-search-dir=${MY_HOSTROOTDIR} \
+ || die "configure failed"
+
+ emake || die "emake failed"
+}
+
+src_install () {
+ webapp_src_preinst
+ dodir ${MY_HOSTROOTDIR}/${PN}
+
+ make DESTDIR=${D} install || die "make install failed"
+
+ dodoc ChangeLog COPYING README
+ dohtml -r htdoc
+
+ dosed ${MY_HOSTROOTDIR}/${PN}/${PN}.conf
+ dosed /usr/bin/rundig
+
+ # symlink htsearch so it can be easily found. see bug #62087.
+ dosym ${MY_CGIBINDIR}/htsearch /usr/bin/htsearch
+
+ webapp_configfile ${MY_HOSTROOTDIR}/${PN}/${PN}.conf
+ webapp_hook_script ${FILESDIR}/reconfig
+
+ webapp_src_install
+}