summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2011-06-04 17:54:09 +0000
committerJeroen Roovers <jer@gentoo.org>2011-06-04 17:54:09 +0000
commitfbaf248c846d085d1e51a91ce9441e48e1ad0427 (patch)
treea7e19007311b06592ec0dc1f2d0de309b58ebd75 /www-client
parentRemoved deprecated policies (diff)
downloadgentoo-2-fbaf248c846d085d1e51a91ce9441e48e1ad0427.tar.gz
gentoo-2-fbaf248c846d085d1e51a91ce9441e48e1ad0427.tar.bz2
gentoo-2-fbaf248c846d085d1e51a91ce9441e48e1ad0427.zip
Add a simple linguas counter.
(Portage version: 2.2.0_alpha37/cvs/Linux x86_64)
Diffstat (limited to 'www-client')
-rw-r--r--www-client/opera-next/ChangeLog5
-rw-r--r--www-client/opera-next/opera-next-11.50.1031.ebuild15
2 files changed, 16 insertions, 4 deletions
diff --git a/www-client/opera-next/ChangeLog b/www-client/opera-next/ChangeLog
index 68c18992d838..b75a77a9fb3d 100644
--- a/www-client/opera-next/ChangeLog
+++ b/www-client/opera-next/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for www-client/opera-next
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/opera-next/ChangeLog,v 1.13 2011/06/01 14:43:49 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/opera-next/ChangeLog,v 1.14 2011/06/04 17:54:09 jer Exp $
+
+ 04 Jun 2011; Jeroen Roovers <jer@gentoo.org> opera-next-11.50.1031.ebuild:
+ Add a simple linguas counter.
*opera-next-11.50.1031 (01 Jun 2011)
diff --git a/www-client/opera-next/opera-next-11.50.1031.ebuild b/www-client/opera-next/opera-next-11.50.1031.ebuild
index de59d2f32372..c02c3f4afe0a 100644
--- a/www-client/opera-next/opera-next-11.50.1031.ebuild
+++ b/www-client/opera-next/opera-next-11.50.1031.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/opera-next/opera-next-11.50.1031.ebuild,v 1.1 2011/06/01 14:43:49 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/opera-next/opera-next-11.50.1031.ebuild,v 1.2 2011/06/04 17:54:09 jer Exp $
EAPI="3"
@@ -99,8 +99,17 @@ src_unpack() {
}
src_prepare() {
+ local LNGDIR="share/${PN}/locale"
+
+ # Count linguas
+ count() { echo ${#}; }
+ local lingua_count=$(count ${O_LINGUAS} en)
+ local locale_count=$(count ${LNGDIR}/*)
+ [[ ${lingua_count} = ${locale_count} ]] \
+ || die "Number of LINGUAS does not match number of locales"
+ unset count
+
# Remove unwanted linguas
- LNGDIR="share/${PN}/locale"
einfo "Keeping these locales (linguas): ${LINGUAS}."
for LINGUA in ${O_LINGUAS}; do
if ! use linguas_${LINGUA/-/_}; then
@@ -178,7 +187,7 @@ src_prepare() {
src_install() {
# We install into usr instead of opt as Opera does not support the latter
dodir /usr
- mv lib/ "${D}/${OPREFIX}" || die "mv lib/ failed"
+ mv lib/ "${D}/${OPREFIX}" || die "mv lib/ failed"
mv share/ "${D}/usr/" || die "mv share/ failed"
# Install startup scripts