summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRaúl Porcel <armin76@gentoo.org>2009-04-09 17:11:20 +0000
committerRaúl Porcel <armin76@gentoo.org>2009-04-09 17:11:20 +0000
commiteb6a3625753691d3960f81becede1a4da498e325 (patch)
tree6068a86d068571cb25165bd26efaa0a60979db46 /www-client
parentAdd www-plugins category. (diff)
downloadgentoo-2-eb6a3625753691d3960f81becede1a4da498e325.tar.gz
gentoo-2-eb6a3625753691d3960f81becede1a4da498e325.tar.bz2
gentoo-2-eb6a3625753691d3960f81becede1a4da498e325.zip
Version bump
(Portage version: 2.1.6.7/cvs/Linux ia64)
Diffstat (limited to 'www-client')
-rw-r--r--www-client/seamonkey-bin/ChangeLog8
-rw-r--r--www-client/seamonkey-bin/seamonkey-bin-1.1.16.ebuild72
2 files changed, 79 insertions, 1 deletions
diff --git a/www-client/seamonkey-bin/ChangeLog b/www-client/seamonkey-bin/ChangeLog
index 9a9fac1ed538..381254e62140 100644
--- a/www-client/seamonkey-bin/ChangeLog
+++ b/www-client/seamonkey-bin/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for www-client/seamonkey-bin
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/seamonkey-bin/ChangeLog,v 1.63 2009/03/21 00:16:25 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/seamonkey-bin/ChangeLog,v 1.64 2009/04/09 17:11:20 armin76 Exp $
+
+*seamonkey-bin-1.1.16 (09 Apr 2009)
+
+ 09 Apr 2009; Raúl Porcel <armin76@gentoo.org>
+ +seamonkey-bin-1.1.16.ebuild:
+ Version bump
21 Mar 2009; Markus Meier <maekke@gentoo.org> seamonkey-bin-1.1.15.ebuild:
x86 stable, bug #261386
diff --git a/www-client/seamonkey-bin/seamonkey-bin-1.1.16.ebuild b/www-client/seamonkey-bin/seamonkey-bin-1.1.16.ebuild
new file mode 100644
index 000000000000..176646423e88
--- /dev/null
+++ b/www-client/seamonkey-bin/seamonkey-bin-1.1.16.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-client/seamonkey-bin/seamonkey-bin-1.1.16.ebuild,v 1.1 2009/04/09 17:11:20 armin76 Exp $
+
+inherit eutils mozilla-launcher multilib
+
+DESCRIPTION="Mozilla Application Suite - web browser, email, HTML editor, IRC"
+SRC_URI="http://releases.mozilla.org/pub/mozilla.org/seamonkey/releases/${PV}/seamonkey-${PV}.en-US.linux-i686.tar.gz"
+HOMEPAGE="http://www.seamonkey-project.org/"
+RESTRICT="strip"
+QA_EXECSTACK="opt/seamonkey/*"
+
+KEYWORDS="-* ~amd64 ~x86"
+SLOT="0"
+LICENSE="|| ( MPL-1.1 GPL-2 LGPL-2.1 )"
+IUSE=""
+
+DEPEND="app-arch/unzip"
+RDEPEND="x11-libs/libXrender
+ x11-libs/libXt
+ x11-libs/libXmu
+ x86? (
+ >=x11-libs/gtk+-2.2
+ =virtual/libstdc++-3.3
+ )
+ amd64? (
+ >=app-emulation/emul-linux-x86-baselibs-1.0
+ >=app-emulation/emul-linux-x86-gtklibs-1.0
+ app-emulation/emul-linux-x86-compat
+ )
+ >=www-client/mozilla-launcher-1.56"
+
+S="${WORKDIR}/seamonkey"
+
+pkg_setup() {
+ # This is a binary x86 package => ABI=x86
+ # Please keep this in future versions
+ # Danny van Dyk <kugelfang@gentoo.org> 2005/03/26
+ has_multilib_profile && ABI="x86"
+}
+
+src_install() {
+ declare MOZILLA_FIVE_HOME=/opt/seamonkey
+
+ # Install seamonkey in /opt
+ dodir ${MOZILLA_FIVE_HOME%/*}
+ mv "${S}" "${D}${MOZILLA_FIVE_HOME}"
+
+ # Install /usr/bin/seamonkey-bin
+ install_mozilla_launcher_stub seamonkey-bin ${MOZILLA_FIVE_HOME}
+
+ # Install icon and .desktop for menu entry
+ doicon "${FILESDIR}/icon/${PN}.png"
+ domenu "${FILESDIR}/icon/${PN}.desktop"
+}
+
+pkg_preinst() {
+ declare MOZILLA_FIVE_HOME=/opt/seamonkey
+
+ # Remove entire installed instance to prevent all kinds of
+ # problems... see bug 44772 for example
+ rm -rf "${ROOT}${MOZILLA_FIVE_HOME}"
+}
+
+pkg_postinst() {
+ use amd64 && einfo "NB: You just installed a 32-bit seamonkey"
+ update_mozilla_launcher_symlinks
+}
+
+pkg_postrm() {
+ update_mozilla_launcher_symlinks
+}