summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2008-12-16 17:11:18 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2008-12-16 17:11:18 +0000
commite4481ae667172ccf30b5b818418c9086b392d5ac (patch)
tree0aa876eb18b4f9c6660add832750542b278355ce /www-client
parentMarked ~hppa (bug #250390). (diff)
downloadgentoo-2-e4481ae667172ccf30b5b818418c9086b392d5ac.tar.gz
gentoo-2-e4481ae667172ccf30b5b818418c9086b392d5ac.tar.bz2
gentoo-2-e4481ae667172ccf30b5b818418c9086b392d5ac.zip
Version bumped.
(Portage version: 2.1.6/cvs/Linux 2.6.27-gentoo-r4 x86_64)
Diffstat (limited to 'www-client')
-rw-r--r--www-client/jd/ChangeLog8
-rw-r--r--www-client/jd/jd-2.1.0_beta081216.ebuild77
2 files changed, 84 insertions, 1 deletions
diff --git a/www-client/jd/ChangeLog b/www-client/jd/ChangeLog
index d9ffd129b7bd..4a315eade35c 100644
--- a/www-client/jd/ChangeLog
+++ b/www-client/jd/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for www-client/jd
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/jd/ChangeLog,v 1.4 2008/11/28 16:53:38 matsuu Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/jd/ChangeLog,v 1.5 2008/12/16 17:11:18 matsuu Exp $
+
+*jd-2.1.0_beta081216 (16 Dec 2008)
+
+ 16 Dec 2008; MATSUU Takuto <matsuu@gentoo.org>
+ +jd-2.1.0_beta081216.ebuild:
+ Version bumped.
*jd-2.0.3_p081124 (28 Nov 2008)
diff --git a/www-client/jd/jd-2.1.0_beta081216.ebuild b/www-client/jd/jd-2.1.0_beta081216.ebuild
new file mode 100644
index 000000000000..47e2e0eddd84
--- /dev/null
+++ b/www-client/jd/jd-2.1.0_beta081216.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-client/jd/jd-2.1.0_beta081216.ebuild,v 1.1 2008/12/16 17:11:18 matsuu Exp $
+
+inherit eutils autotools
+
+MY_P="${P/_p/-}"
+MY_P="${MY_P/_beta/-beta}"
+
+DESCRIPTION="gtk2 based 2ch browser written in C++"
+HOMEPAGE="http://jd4linux.sourceforge.jp/"
+SRC_URI="mirror://sourceforge.jp/jd4linux/36586/${MY_P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="alsa gnome gnutls"
+#IUSE="alsa gnome gnutls migemo"
+
+RDEPEND=">=dev-cpp/gtkmm-2.8
+ >=dev-libs/glib-2
+ x11-misc/xdg-utils
+ alsa? ( >=media-libs/alsa-lib-1 )
+ gnome? ( >=gnome-base/libgnomeui-2 )
+ !gnome? (
+ x11-libs/libSM
+ x11-libs/libICE
+ )
+ gnutls? ( >=net-libs/gnutls-1.2 )
+ !gnutls? ( >=dev-libs/openssl-0.9 )"
+# migemo? ( app-text/cmigemo )
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+S="${WORKDIR}/${MY_P}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ eautoreconf
+}
+
+src_compile() {
+ local myconf="--with-xdgopen"
+
+ # use gnomeui sm instead of Xorg SM/ICE
+ if use gnome ; then
+ myconf="${myconf} --with-sessionlib=gnomeui"
+ else
+ myconf="${myconf} --with-sessionlib=xsmp"
+ fi
+
+ if use gnutls ; then
+ myconf="${myconf} --without-openssl"
+ else
+ myconf="${myconf} --with-openssl"
+ fi
+
+ #if use migemo ; then
+ # myconf="${myconf} --with-migemo --with-migemodict=/usr/share/migemo/migemo-dict"
+ #else
+ # myconf="${myconf} --without-migemo"
+ #fi
+
+ econf \
+ $(use_with alsa) \
+ ${myconf} || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ doicon ${PN}.png
+ domenu ${PN}.desktop
+ dodoc AUTHORS ChangeLog NEWS README
+}