summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2011-12-12 00:31:59 +0000
committerJeroen Roovers <jer@gentoo.org>2011-12-12 00:31:59 +0000
commite26500c89bc7caf2b91b1d43489e5956eb224bf6 (patch)
treef43ab855c1bfdd68a2a6625ccda56fa9afec4acd /www-client
parentStable for HPPA (bug #393435). (diff)
downloadgentoo-2-e26500c89bc7caf2b91b1d43489e5956eb224bf6.tar.gz
gentoo-2-e26500c89bc7caf2b91b1d43489e5956eb224bf6.tar.bz2
gentoo-2-e26500c89bc7caf2b91b1d43489e5956eb224bf6.zip
Version bump by teidakankan (bug #394189).
(Portage version: 2.2.0_alpha80/cvs/Linux x86_64)
Diffstat (limited to 'www-client')
-rw-r--r--www-client/dillo/ChangeLog7
-rw-r--r--www-client/dillo/dillo-3.0.2.ebuild66
2 files changed, 72 insertions, 1 deletions
diff --git a/www-client/dillo/ChangeLog b/www-client/dillo/ChangeLog
index 9f6f19027b88..d74bee065c0b 100644
--- a/www-client/dillo/ChangeLog
+++ b/www-client/dillo/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for www-client/dillo
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/dillo/ChangeLog,v 1.99 2011/10/12 15:47:41 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/dillo/ChangeLog,v 1.100 2011/12/12 00:31:59 jer Exp $
+
+*dillo-3.0.2 (12 Dec 2011)
+
+ 12 Dec 2011; Jeroen Roovers <jer@gentoo.org> +dillo-3.0.2.ebuild:
+ Version bump by teidakankan (bug #394189).
12 Oct 2011; Jeroen Roovers <jer@gentoo.org> dillo-3.0.1.ebuild:
Fix fltk dependency thanks to ulm (bug #386867).
diff --git a/www-client/dillo/dillo-3.0.2.ebuild b/www-client/dillo/dillo-3.0.2.ebuild
new file mode 100644
index 000000000000..5ccb76994fb2
--- /dev/null
+++ b/www-client/dillo/dillo-3.0.2.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-client/dillo/dillo-3.0.2.ebuild,v 1.1 2011/12/12 00:31:59 jer Exp $
+
+EAPI="4"
+
+inherit eutils flag-o-matic multilib
+
+DESCRIPTION="Lean FLTK based web browser"
+HOMEPAGE="http://www.dillo.org/"
+SRC_URI="http://www.dillo.org/download/${P}.tar.bz2
+ mirror://gentoo/dillo.png"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE="doc +gif ipv6 +jpeg +png ssl"
+
+RDEPEND="=x11-libs/fltk-1.3*[-cairo]
+ sys-libs/zlib
+ jpeg? ( virtual/jpeg )
+ png? ( media-libs/libpng )
+ ssl? ( dev-libs/openssl )"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )"
+
+src_prepare() {
+ epatch "${FILESDIR}"/dillo2-inbuf.patch
+}
+
+src_configure() {
+ append-ldflags "-L/usr/$(get_libdir)/fltk"
+ econf \
+ $(use_enable gif) \
+ $(use_enable ipv6) \
+ $(use_enable jpeg) \
+ $(use_enable png) \
+ $(use_enable ssl)
+}
+
+src_compile() {
+ default
+ if use doc ; then
+ doxygen Doxyfile || die "doxygen failed"
+ fi
+}
+
+src_install() {
+ dodir /etc
+ default
+
+ if use doc; then
+ dohtml html/*
+ fi
+ dodoc AUTHORS ChangeLog README NEWS
+ docinto doc
+ dodoc doc/*.txt doc/README
+
+ doicon "${DISTDIR}"/dillo.png
+ make_desktop_entry dillo Dillo dillo
+}
+
+pkg_postinst() {
+ elog "Dillo has installed a default configuration into /etc/dillo/dillorc"
+ elog "You can copy this to ~/.dillo/ and customize it"
+}