summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNaohiro Aota <naota@gentoo.org>2011-07-17 05:34:33 +0000
committerNaohiro Aota <naota@gentoo.org>2011-07-17 05:34:33 +0000
commite26421313e7a52a928c565dc82cc1373f8fec714 (patch)
tree5bdbdba5e78833b4972c8c20487e6c0854f383e7 /www-client
parentMarking amd64 stable (Bug #375239) (diff)
downloadgentoo-2-e26421313e7a52a928c565dc82cc1373f8fec714.tar.gz
gentoo-2-e26421313e7a52a928c565dc82cc1373f8fec714.tar.bz2
gentoo-2-e26421313e7a52a928c565dc82cc1373f8fec714.zip
Add patch to deal with glibc-2.14 change. Fix bug #370435
(Portage version: 2.2.0_alpha45/cvs/Linux x86_64)
Diffstat (limited to 'www-client')
-rw-r--r--www-client/w3mmee/ChangeLog8
-rw-r--r--www-client/w3mmee/files/w3mmee-0.3.2_p24-glibc214.patch35
-rw-r--r--www-client/w3mmee/w3mmee-0.3.2_p24-r7.ebuild151
3 files changed, 193 insertions, 1 deletions
diff --git a/www-client/w3mmee/ChangeLog b/www-client/w3mmee/ChangeLog
index 850825e65d89..56f6f04e1ba7 100644
--- a/www-client/w3mmee/ChangeLog
+++ b/www-client/w3mmee/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for www-client/w3mmee
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/w3mmee/ChangeLog,v 1.14 2011/04/13 15:12:45 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/w3mmee/ChangeLog,v 1.15 2011/07/17 05:34:33 naota Exp $
+
+*w3mmee-0.3.2_p24-r7 (17 Jul 2011)
+
+ 17 Jul 2011; Naohiro Aota <naota@gentoo.org> +w3mmee-0.3.2_p24-r7.ebuild,
+ +files/w3mmee-0.3.2_p24-glibc214.patch:
+ Add patch to deal with glibc-2.14 change. Fix bug #370435
13 Apr 2011; Ulrich Mueller <ulm@gentoo.org> w3mmee-0.3.2_p24-r6.ebuild:
Don't PROVIDE virtual/w3m, it is a new-style virtual now. Bug 358855.
diff --git a/www-client/w3mmee/files/w3mmee-0.3.2_p24-glibc214.patch b/www-client/w3mmee/files/w3mmee-0.3.2_p24-glibc214.patch
new file mode 100644
index 000000000000..dc9be94732c6
--- /dev/null
+++ b/www-client/w3mmee/files/w3mmee-0.3.2_p24-glibc214.patch
@@ -0,0 +1,35 @@
+diff --git a/istream.c b/istream.c
+index de5fbd3..6718b41 100644
+--- a/istream.c
++++ b/istream.c
+@@ -132,7 +132,7 @@ newFileStream(FILE *f, void (*closep)())
+ stream = New(struct input_stream);
+ init_base_stream(stream, STREAM_BUF_SIZE);
+ stream->type = IST_FILE;
+- stream->handle.file = New(struct file_handle);
++ stream->handle.file = New(struct afile_handle);
+ stream->handle.file->f = f;
+
+ if (closep)
+diff --git a/istream.h b/istream.h
+index 168882f..3e7132f 100644
+--- a/istream.h
++++ b/istream.h
+@@ -20,7 +20,7 @@ struct stream_buffer {
+
+ typedef struct stream_buffer *StreamBuffer;
+
+-struct file_handle {
++struct afile_handle {
+ FILE *f;
+ void (*close)(FILE *);
+ };
+@@ -121,7 +121,7 @@ struct tee_handle {
+ union input_handle {
+ void *gen;
+ int fd;
+- struct file_handle *file;
++ struct afile_handle *file;
+ struct delimited_handle *delimited;
+ Str str;
+ #ifdef USE_SSL
diff --git a/www-client/w3mmee/w3mmee-0.3.2_p24-r7.ebuild b/www-client/w3mmee/w3mmee-0.3.2_p24-r7.ebuild
new file mode 100644
index 000000000000..230caeb2b566
--- /dev/null
+++ b/www-client/w3mmee/w3mmee-0.3.2_p24-r7.ebuild
@@ -0,0 +1,151 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-client/w3mmee/w3mmee-0.3.2_p24-r7.ebuild,v 1.1 2011/07/17 05:34:33 naota Exp $
+
+inherit alternatives eutils
+
+IUSE="gpm imlib nls ssl xface"
+
+MY_PV=${PV##*_}-22
+MY_P=${PN}-${MY_PV}
+
+DESCRIPTION="A variant of w3m with support for multiple character encodings"
+SRC_URI="http://pub.ks-and-ks.ne.jp/prog/pub/${MY_P}.tar.gz"
+HOMEPAGE="http://pub.ks-and-ks.ne.jp/prog/w3mmee/"
+
+SLOT="0"
+LICENSE="public-domain"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+
+DEPEND=">=sys-libs/ncurses-5.2-r3
+ >=sys-libs/zlib-1.1.3-r2
+ >=dev-libs/boehm-gc-6.2
+ dev-lang/perl
+ >=dev-libs/libmoe-1.5.3
+ imlib? ( >=media-libs/imlib-1.9.8
+ xface? ( media-libs/compface ) )
+ gpm? ( >=sys-libs/gpm-1.19.3-r5 )
+ nls? ( sys-devel/gettext )
+ ssl? ( >=dev-libs/openssl-0.9.6b )"
+
+S=${WORKDIR}/${MY_P}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${PN}-w3mman-gentoo.diff \
+ "${FILESDIR}"/${PN}-gcc4{4,5}.patch \
+ "${FILESDIR}"/${P}-glibc214.patch
+}
+
+src_compile() {
+
+ local myconf myuse
+ myuse="use_cookie=y use_ansi_color=y use_history=y
+ display_code=E system_code=E"
+
+ if use ssl ; then
+ myconf="${myconf} --ssl-includedir=/usr/include/openssl
+ --ssl-libdir=/usr/$(get_libdir)"
+ myuse="${myuse} use_ssl=y use_ssl_verify=y use_digest_auth=y"
+ else
+ myuse="${myuse} use_ssl=n"
+ fi
+
+ if use gpm ; then
+ myuse="${myuse} use_mouse=y"
+ else
+ myuse="${myuse} use_mouse=n"
+ fi
+
+ if use nls ; then
+ myconf="${myconf} -locale_dir=/usr/share/locale"
+ else
+ myconf="${myconf} -locale_dir='(NONE)'"
+ fi
+
+ if use imlib ; then
+ myuse="${myuse} use_image=y use_w3mimg_x11=y
+ use_w3mimg_fb=n w3mimgdisplay_setuid=n"
+ if use xface ; then
+ myuse="${myuse} use_xface=y"
+ else
+ myuse="${myuse} use_xface=n"
+ fi
+ else
+ myuse="${myuse} use_image=n"
+ fi
+
+ cat >>config.param<<-EOF
+ lang=MANY
+ accept_lang=en
+ EOF
+
+ env ${myuse} ./configure -nonstop \
+ -prefix=/usr \
+ -suffix=mee \
+ -auxbindir=/usr/$(get_libdir)/w3mmee \
+ -libdir=/usr/$(get_libdir)/w3mmee/cgi-bin \
+ -helpdir=/usr/share/w3mmee \
+ -mandir=/usr/share/man \
+ -sysconfdir=/etc/w3mmee \
+ -model=custom \
+ -libmoe=/usr/$(get_libdir) \
+ -mb_h=/usr/include/moe \
+ -mk_btri=/usr/libexec/moe \
+ -cflags=${CFLAGS} -ldflags=${LDFLAGS} \
+ ${myconf} || die
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die
+
+ # w3mman and manpages conflict with those from w3m
+ mv "${D}"/usr/share/man/ja/man1/w3m{,mee}.1 || die
+ mv "${D}"/usr/share/man/man1/w3m{,mee}.1 || die
+
+ dodoc ChangeLog NEWS* README
+ dohtml 00INCOMPATIBLE.html
+
+ docinto en
+ dodoc doc/HISTORY doc/README* doc/keymap.* doc/menu.*
+ dohtml doc/*
+
+ docinto jp
+ dodoc doc-jp/HISTORY doc-jp/README* doc-jp/keymap* doc-jp/menu.*
+ dohtml doc-jp/*
+}
+
+pkg_postinst() {
+
+ w3m_alternatives
+ einfo
+ einfo "If you want to render multilingual text, please refer to"
+ einfo "/usr/share/doc/${PF}/en/README.mee or"
+ einfo "/usr/share/doc/${PF}/jp/README.mee"
+ einfo "and set W3MLANG variable respectively."
+ einfo
+}
+
+pkg_postrm() {
+
+ w3m_alternatives
+}
+
+w3m_alternatives() {
+
+ if [ ! -f /usr/bin/w3m ] ; then
+ alternatives_makesym /usr/bin/w3m \
+ /usr/bin/w3m{m17n,mee}
+ alternatives_makesym /usr/bin/w3mman \
+ /usr/bin/w3m{man-m17n,meeman}
+ alternatives_makesym /usr/share/man/ja/man1/w3m.1.gz \
+ /usr/share/man/ja/man1/w3m{m17n,mee}.1.gz
+ alternatives_makesym /usr/share/man/man1/w3m.1.gz \
+ /usr/share/man/man1/w3m{m17n,mee}.1.gz
+ alternatives_makesym /usr/share/man/man1/w3mman.1.gz \
+ /usr/share/man/man1/w3m{man-m17n,meeman}.1.gz
+ fi
+}