summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2010-02-09 00:07:16 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2010-02-09 00:07:16 +0000
commitdc5aa4f38ce8d046d38e8edcbfe5a8ffed634ffb (patch)
tree17e7ac752b2c644270e7fecad677fd63e08a1d0d /www-client
parentVersion bump, and work around parallel make issue, and respect LDFLAGS (bug #... (diff)
downloadgentoo-2-dc5aa4f38ce8d046d38e8edcbfe5a8ffed634ffb.tar.gz
gentoo-2-dc5aa4f38ce8d046d38e8edcbfe5a8ffed634ffb.tar.bz2
gentoo-2-dc5aa4f38ce8d046d38e8edcbfe5a8ffed634ffb.zip
Version bumped.
(Portage version: 2.1.7.17/cvs/Linux x86_64)
Diffstat (limited to 'www-client')
-rw-r--r--www-client/jd/ChangeLog9
-rw-r--r--www-client/jd/jd-2.6.0_p100208.ebuild67
2 files changed, 74 insertions, 2 deletions
diff --git a/www-client/jd/ChangeLog b/www-client/jd/ChangeLog
index db2a840a0f20..56a4a5c00949 100644
--- a/www-client/jd/ChangeLog
+++ b/www-client/jd/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for www-client/jd
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/jd/ChangeLog,v 1.19 2009/12/31 06:02:30 matsuu Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/www-client/jd/ChangeLog,v 1.20 2010/02/09 00:07:16 matsuu Exp $
+
+*jd-2.6.0_p100208 (09 Feb 2010)
+
+ 09 Feb 2010; MATSUU Takuto <matsuu@gentoo.org> +jd-2.6.0_p100208.ebuild:
+ Version bumped.
*jd-2.5.5_p091228 (31 Dec 2009)
diff --git a/www-client/jd/jd-2.6.0_p100208.ebuild b/www-client/jd/jd-2.6.0_p100208.ebuild
new file mode 100644
index 000000000000..b665f3e0ac85
--- /dev/null
+++ b/www-client/jd/jd-2.6.0_p100208.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-client/jd/jd-2.6.0_p100208.ebuild,v 1.1 2010/02/09 00:07:16 matsuu Exp $
+
+inherit eutils autotools
+
+MY_P="${P/_p/-}"
+MY_P="${MY_P/_/-}"
+
+DESCRIPTION="gtk2 based 2ch browser written in C++"
+HOMEPAGE="http://jd4linux.sourceforge.jp/"
+SRC_URI="mirror://sourceforge.jp/jd4linux/45878/${MY_P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="alsa gnome gnutls migemo"
+
+RDEPEND=">=dev-cpp/gtkmm-2.8
+ >=dev-libs/glib-2
+ x11-misc/xdg-utils
+ alsa? ( >=media-libs/alsa-lib-1 )
+ gnome? ( >=gnome-base/libgnomeui-2 )
+ !gnome? (
+ x11-libs/libSM
+ x11-libs/libICE
+ )
+ gnutls? ( >=net-libs/gnutls-1.2 )
+ !gnutls? ( >=dev-libs/openssl-0.9 )
+ migemo? ( app-text/cmigemo )"
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+S="${WORKDIR}/${MY_P}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ eautoreconf
+}
+
+src_compile() {
+ local myconf="--with-xdgopen"
+
+ # use gnomeui sm instead of Xorg SM/ICE
+ if use gnome ; then
+ myconf="${myconf} --with-sessionlib=gnomeui"
+ else
+ myconf="${myconf} --with-sessionlib=xsmp"
+ fi
+
+ econf \
+ $(use_with alsa) \
+ $(use_with !gnutls openssl) \
+ $(use_with migemo) \
+ $(use_with migemo migemodict /usr/share/migemo/migemo-dict) \
+ ${myconf} || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ doicon ${PN}.png
+ domenu ${PN}.desktop
+ dodoc AUTHORS ChangeLog NEWS README
+}