summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2013-10-20 02:47:13 +0000
committerMike Gilbert <floppym@gentoo.org>2013-10-20 02:47:13 +0000
commitd2f172f7f3da64c1f1f3741abde63b871ca403e7 (patch)
tree0eaba8cd11953bb14c40e1dda8a4c4a0f7032f97 /www-client
parentBump hamlet to 1.1.7.3 (diff)
downloadgentoo-2-d2f172f7f3da64c1f1f3741abde63b871ca403e7.tar.gz
gentoo-2-d2f172f7f3da64c1f1f3741abde63b871ca403e7.tar.bz2
gentoo-2-d2f172f7f3da64c1f1f3741abde63b871ca403e7.zip
Re-enable V8 snapshot on PaX systems.
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 0BBEEA1FEA4843A4)
Diffstat (limited to 'www-client')
-rw-r--r--www-client/chromium/ChangeLog5
-rw-r--r--www-client/chromium/chromium-32.0.1671.3.ebuild20
2 files changed, 14 insertions, 11 deletions
diff --git a/www-client/chromium/ChangeLog b/www-client/chromium/ChangeLog
index 9314cec2e496..7b501a0773b9 100644
--- a/www-client/chromium/ChangeLog
+++ b/www-client/chromium/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for www-client/chromium
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/chromium/ChangeLog,v 1.968 2013/10/20 02:13:51 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/chromium/ChangeLog,v 1.969 2013/10/20 02:47:13 floppym Exp $
+
+ 20 Oct 2013; Mike Gilbert <floppym@gentoo.org> chromium-32.0.1671.3.ebuild:
+ Re-enable V8 snapshot on PaX systems.
*chromium-31.0.1650.26 (20 Oct 2013)
diff --git a/www-client/chromium/chromium-32.0.1671.3.ebuild b/www-client/chromium/chromium-32.0.1671.3.ebuild
index d6fce7e2536d..2fb6846de035 100644
--- a/www-client/chromium/chromium-32.0.1671.3.ebuild
+++ b/www-client/chromium/chromium-32.0.1671.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/chromium/chromium-32.0.1671.3.ebuild,v 1.2 2013/10/18 03:30:36 phajdan.jr Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/chromium/chromium-32.0.1671.3.ebuild,v 1.3 2013/10/20 02:47:13 floppym Exp $
EAPI="5"
PYTHON_COMPAT=( python{2_6,2_7} )
@@ -316,10 +316,11 @@ src_configure() {
local myarch="$(tc-arch)"
if [[ $myarch = amd64 ]] ; then
- myconf+=" -Dtarget_arch=x64"
+ target_arch=x64
elif [[ $myarch = x86 ]] ; then
- myconf+=" -Dtarget_arch=ia32"
+ target_arch=ia32
elif [[ $myarch = arm ]] ; then
+ target_arch=arm
# TODO: re-enable NaCl (NativeClient).
local CTARGET=${CTARGET:-${CHOST}}
if [[ $(tc-is-softfloat) == "no" ]]; then
@@ -334,19 +335,14 @@ src_configure() {
else
myconf+=" -Darmv7=0"
fi
- myconf+=" -Dtarget_arch=arm
- -Dsysroot=
+ myconf+=" -Dsysroot=
$(gyp_use neon arm_neon)
-Ddisable_nacl=1"
else
die "Failed to determine target arch, got '$myarch'."
fi
- if host-is-pax; then
- # Prevent the build from failing (bug #301880, bug #487144). The performance
- # difference is very small.
- myconf+=" -Dv8_use_snapshot=0"
- fi
+ myconf+=" -Dtarget_arch=${target_arch}"
# Make sure that -Werror doesn't get added to CFLAGS by the build system.
# Depending on GCC version the warnings are different and we don't want
@@ -390,6 +386,10 @@ src_compile() {
ninja_targets+=" $test_targets"
fi
+ # Build mksnapshot and pax-mark it.
+ ninja -C out/Release -v -j $(makeopts_jobs) mksnapshot.${target_arch} || die
+ pax-mark m out/Release/mksnapshot.${target_arch}
+
# Even though ninja autodetects number of CPUs, we respect
# user's options, for debugging with -j 1 or any other reason.
ninja -C out/Release -v -j $(makeopts_jobs) ${ninja_targets} || die