summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaweł Hajdan <phajdan.jr@gentoo.org>2010-04-14 18:47:37 +0000
committerPaweł Hajdan <phajdan.jr@gentoo.org>2010-04-14 18:47:37 +0000
commitcdb719b7e7f19f7408d5f05a42a3d2723a81d86e (patch)
tree8877fc9c8b393604b0601ca488ff10ffd5b8dc9b /www-client
parentStable for PPC (bug #305793). (diff)
downloadgentoo-2-cdb719b7e7f19f7408d5f05a42a3d2723a81d86e.tar.gz
gentoo-2-cdb719b7e7f19f7408d5f05a42a3d2723a81d86e.tar.bz2
gentoo-2-cdb719b7e7f19f7408d5f05a42a3d2723a81d86e.zip
Version bump for dev channel release. Add USE flags for mp3 and x264
support, depending on the system ffmpeg. (Portage version: 2.1.7.17/cvs/Linux i686)
Diffstat (limited to 'www-client')
-rw-r--r--www-client/chromium/ChangeLog10
-rw-r--r--www-client/chromium/chromium-5.0.375.3.ebuild206
-rw-r--r--www-client/chromium/chromium-9999.ebuild35
-rw-r--r--www-client/chromium/files/chromium-supported-media-mime-types.patch38
4 files changed, 269 insertions, 20 deletions
diff --git a/www-client/chromium/ChangeLog b/www-client/chromium/ChangeLog
index ddd051e0a5ef..9450c25cdcb1 100644
--- a/www-client/chromium/ChangeLog
+++ b/www-client/chromium/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for www-client/chromium
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/chromium/ChangeLog,v 1.84 2010/04/14 13:05:53 phajdan.jr Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/chromium/ChangeLog,v 1.85 2010/04/14 18:47:37 phajdan.jr Exp $
+
+*chromium-5.0.375.3 (14 Apr 2010)
+
+ 14 Apr 2010; Pawel Hajdan jr <phajdan.jr@gentoo.org>
+ +chromium-5.0.375.3.ebuild, chromium-9999.ebuild,
+ +files/chromium-supported-media-mime-types.patch:
+ Version bump for dev channel release. Add USE flags for mp3 and x264
+ support, depending on the system ffmpeg.
14 Apr 2010; Pawel Hajdan jr <phajdan.jr@gentoo.org>
-chromium-5.0.342.7.ebuild, chromium-5.0.342.9.ebuild,
diff --git a/www-client/chromium/chromium-5.0.375.3.ebuild b/www-client/chromium/chromium-5.0.375.3.ebuild
new file mode 100644
index 000000000000..fa85d13cc643
--- /dev/null
+++ b/www-client/chromium/chromium-5.0.375.3.ebuild
@@ -0,0 +1,206 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-client/chromium/chromium-5.0.375.3.ebuild,v 1.1 2010/04/14 18:47:37 phajdan.jr Exp $
+
+EAPI="2"
+inherit eutils flag-o-matic multilib portability toolchain-funcs
+
+DESCRIPTION="Open-source version of Google Chrome web browser"
+HOMEPAGE="http://chromium.org/"
+SRC_URI="http://build.chromium.org/buildbot/official/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="mp3 +plugins-symlink x264"
+
+RDEPEND="app-arch/bzip2
+ >=dev-libs/libevent-1.4.13
+ dev-libs/libxml2
+ dev-libs/libxslt
+ >=dev-libs/nss-3.12.3
+ >=gnome-base/gconf-2.24.0
+ >=media-libs/alsa-lib-1.0.19
+ media-libs/jpeg:0
+ media-libs/libpng
+ >=media-video/ffmpeg-0.5_p21602[mp3=,threads,x264=]
+ sys-libs/zlib
+ >=x11-libs/gtk+-2.14.7
+ x11-libs/libXScrnSaver"
+# dev-db/sqlite:3
+DEPEND="${RDEPEND}
+ >=dev-util/gperf-3.0.3
+ >=dev-util/pkgconfig-0.23
+ sys-devel/flex"
+RDEPEND+="
+ || (
+ x11-themes/gnome-icon-theme
+ x11-themes/tango-icon-theme
+ x11-themes/xfce4-icon-theme
+ )
+ x11-misc/xdg-utils
+ virtual/ttf-fonts"
+
+# Incompatible system plugins:
+# www-plugins/gecko-mediaplayer, bug #309231.
+RDEPEND+="
+ plugins-symlink? (
+ !www-plugins/gecko-mediaplayer[gnome]
+ )"
+
+pkg_setup() {
+ if [[ "${ROOT}" == "/" ]]; then
+ # Prevent user problems like bug 299777.
+ if ! grep -q /dev/shm <<< $(get_mounts); then
+ eerror "You don't have tmpfs mounted at /dev/shm."
+ eerror "${PN} isn't going to work in that configuration."
+ eerror "Please uncomment the /dev/shm entry in /etc/fstab,"
+ eerror "run 'mount /dev/shm' and try again."
+ die "/dev/shm is not mounted"
+ fi
+ if [ `stat -c %a /dev/shm` -ne 1777 ]; then
+ eerror "/dev/shm does not have correct permissions."
+ eerror "${PN} isn't going to work in that configuration."
+ eerror "Please run chmod 1777 /dev/shm and try again."
+ die "/dev/shm has incorrect permissions"
+ fi
+ fi
+
+ elog "${PN} might crash occasionally. To get more useful backtraces"
+ elog "and submit better bug reports, please read"
+ elog "http://www.gentoo.org/proj/en/qa/backtraces.xml"
+}
+
+src_prepare() {
+ # Changing this in ~/include.gypi does not work
+ sed -i "s/'-Werror'/''/" build/common.gypi || die "Werror sed failed"
+
+ # Prevent automatic -march=pentium4 -msse2 enabling on x86, http://crbug.com/9007
+ epatch "${FILESDIR}"/${PN}-drop_sse2.patch
+
+ # Allow supporting more media types provided system ffmpeg supports them.
+ epatch "${FILESDIR}"/${PN}-supported-media-mime-types.patch
+
+ # Fix build failure with libpng-1.4, bug 310959.
+ epatch "${FILESDIR}"/${PN}-libpng-1.4.patch
+
+ # Disable prefixing to allow linking against system zlib
+ sed -e '/^#include "mozzconf.h"$/d' \
+ -i third_party/zlib/zconf.h \
+ || die "zlib sed failed"
+}
+
+src_configure() {
+ export CHROMIUM_HOME=/usr/$(get_libdir)/chromium-browser
+
+ # Fails to build on arm if we don't do this
+ use arm && append-flags -fno-tree-sink
+
+ if use mp3 ; then
+ append-cflags -DGENTOO_CHROMIUM_MP3_ENABLED
+ fi
+
+ if use x264 ; then
+ append-cflags -DGENTOO_CHROMIUM_H264_ENABLED
+ fi
+
+ # CFLAGS/LDFLAGS
+ mkdir -p "${S}"/.gyp
+ cat << EOF > "${S}"/.gyp/include.gypi
+{
+ 'target_defaults': {
+ 'cflags': [ '${CFLAGS// /','}' ],
+ 'ldflags': [ '${LDFLAGS// /','}' ],
+ },
+}
+EOF
+ export HOME="${S}"
+
+ # Configuration options (system libraries)
+ local myconf="-Duse_system_zlib=1 -Duse_system_bzip2=1 -Duse_system_ffmpeg=1 -Duse_system_libevent=1 -Duse_system_libjpeg=1 -Duse_system_libpng=1 -Duse_system_libxml=1 -Duse_system_libxslt=1"
+ # -Duse_system_sqlite=1 : http://crbug.com/22208
+ # Others still bundled: icu (not possible?), hunspell (changes required for sandbox support)
+
+ # Sandbox paths
+ myconf="${myconf} -Dlinux_sandbox_path=${CHROMIUM_HOME}/chrome_sandbox -Dlinux_sandbox_chrome_path=${CHROMIUM_HOME}/chrome"
+
+ # Disable the V8 snapshot. It breaks the build on hardened (bug #301880),
+ # and the performance gain isn't worth it.
+ myconf="${myconf} -Dv8_use_snapshot=0"
+
+ # Use target arch detection logic from bug #296917.
+ local myarch="$ABI"
+ [[ $myarch = "" ]] && myarch="$ARCH"
+
+ if [[ $myarch = amd64 ]] ; then
+ myconf="${myconf} -Dtarget_arch=x64"
+ elif [[ $myarch = x86 ]] ; then
+ myconf="${myconf} -Dtarget_arch=ia32"
+ elif [[ $myarch = arm ]] ; then
+ myconf="${myconf} -Dtarget_arch=arm -Ddisable_nacl=1 -Dlinux_use_tcmalloc=0"
+ else
+ die "Failed to determine target arch, got '$myarch'."
+ fi
+
+ if [[ "$(gcc-major-version)$(gcc-minor-version)" == "44" ]]; then
+ myconf="${myconf} -Dno_strict_aliasing=1 -Dgcc_version=44"
+ fi
+
+ build/gyp_chromium -f make build/all.gyp ${myconf} --depth=. || die "gyp failed"
+}
+
+src_compile() {
+ emake -r V=1 chrome chrome_sandbox BUILDTYPE=Release \
+ rootdir="${S}" \
+ CC=$(tc-getCC) \
+ CXX=$(tc-getCXX) \
+ AR=$(tc-getAR) \
+ RANLIB=$(tc-getRANLIB) \
+ || die "compilation failed"
+}
+
+src_install() {
+ # Chromium does not have "install" target in the build system.
+ export CHROMIUM_HOME=/usr/$(get_libdir)/chromium-browser
+
+ dodir ${CHROMIUM_HOME}
+
+ exeinto ${CHROMIUM_HOME}
+ doexe out/Release/chrome
+ doexe out/Release/chrome_sandbox
+ fperms 4755 ${CHROMIUM_HOME}/chrome_sandbox
+ doexe out/Release/xdg-settings
+ doexe "${FILESDIR}"/chromium-launcher.sh
+
+ insinto ${CHROMIUM_HOME}
+ doins out/Release/chrome.pak
+
+ doins -r out/Release/locales
+ doins -r out/Release/resources
+
+ # chrome.1 is for chromium --help
+ newman out/Release/chrome.1 chrome.1
+ newman out/Release/chrome.1 chromium.1
+
+ # Chromium looks for these in its folder
+ # See media_posix.cc and base_paths_linux.cc
+ dosym /usr/$(get_libdir)/libavcodec.so.52 ${CHROMIUM_HOME}
+ dosym /usr/$(get_libdir)/libavformat.so.52 ${CHROMIUM_HOME}
+ dosym /usr/$(get_libdir)/libavutil.so.50 ${CHROMIUM_HOME}
+
+ # Plugins symlink, optional wrt bug #301911
+ if use plugins-symlink; then
+ dosym /usr/$(get_libdir)/nsbrowser/plugins ${CHROMIUM_HOME}/plugins
+ fi
+
+ # Icon and desktop entry
+ newicon out/Release/product_logo_48.png ${PN}-browser.png
+ dosym ${CHROMIUM_HOME}/chromium-launcher.sh /usr/bin/chromium
+ make_desktop_entry chromium "Chromium" ${PN}-browser "Network;WebBrowser"
+ sed -e "/^Exec/s/$/ %U/" -i "${D}"/usr/share/applications/*.desktop \
+ || die "desktop file sed failed"
+ # Gnome default application entry
+ dodir /usr/share/gnome-control-center/default-apps
+ insinto /usr/share/gnome-control-center/default-apps
+ doins "${FILESDIR}"/chromium.xml
+}
diff --git a/www-client/chromium/chromium-9999.ebuild b/www-client/chromium/chromium-9999.ebuild
index 2207fa8d828a..b6df6704871b 100644
--- a/www-client/chromium/chromium-9999.ebuild
+++ b/www-client/chromium/chromium-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/chromium/chromium-9999.ebuild,v 1.42 2010/04/13 18:03:30 phajdan.jr Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/chromium/chromium-9999.ebuild,v 1.43 2010/04/14 18:47:37 phajdan.jr Exp $
EAPI="2"
inherit eutils flag-o-matic multilib portability subversion toolchain-funcs
@@ -14,7 +14,7 @@ EGCLIENT_REPO_URI="http://src.chromium.org/svn/trunk/src/"
LICENSE="BSD"
SLOT="0"
KEYWORDS=""
-IUSE="bindist +plugins-symlink"
+IUSE="mp3 +plugins-symlink x264"
RDEPEND="app-arch/bzip2
>=dev-libs/libevent-1.4.13
@@ -25,7 +25,7 @@ RDEPEND="app-arch/bzip2
>=media-libs/alsa-lib-1.0.19
media-libs/jpeg:0
media-libs/libpng
- >=media-video/ffmpeg-0.5_p21602[threads]
+ >=media-video/ffmpeg-0.5_p21602[mp3=,threads,x264=]
sys-libs/zlib
>=x11-libs/gtk+-2.14.7
x11-libs/libXScrnSaver"
@@ -71,13 +71,6 @@ pkg_setup() {
elog "${PN} might crash occasionally. To get more useful backtraces"
elog "and submit better bug reports, please read"
elog "http://www.gentoo.org/proj/en/qa/backtraces.xml"
-
- if ! use bindist; then
- einfo
- elog "You may not redistribute this build to any users on your network"
- elog "or the internet."
- elog "You can disable it by emerging ${PN} _with_ the bindist USE-flag"
- fi
}
src_unpack() {
@@ -124,19 +117,15 @@ src_unpack() {
}
src_prepare() {
- # Gentoo uses .kde4, not .kde
- # TODO: this does not work with kdeprefix, fixing http:/crbug.com/29927
- # would be better
- sed -e 's/\.kde/.kde4/' -i net/proxy/proxy_config_service_linux.cc \
- || die "kde proxy sed failed"
# Changing this in ~/include.gypi does not work
sed -i "s/'-Werror'/''/" build/common.gypi || die "Werror sed failed"
+
# Prevent automatic -march=pentium4 -msse2 enabling on x86, http://crbug.com/9007
epatch "${FILESDIR}"/${PN}-drop_sse2.patch
- if ! use bindist; then
- # Allow use of MP3/MPEG-4 audio/video tags with our system ffmpeg
- epatch "${FILESDIR}"/${PN}-20100122-ubuntu-html5-video-mimetypes.patch
- fi
+
+ # Allow supporting more media types provided system ffmpeg supports them.
+ epatch "${FILESDIR}"/${PN}-supported-media-mime-types.patch
+
# Fix build failure with libpng-1.4, bug 310959.
epatch "${FILESDIR}"/${PN}-libpng-1.4.patch
@@ -151,6 +140,14 @@ src_configure() {
# Fails to build on arm if we don't do this
use arm && append-flags -fno-tree-sink
+ if use mp3 ; then
+ append-cflags -DGENTOO_CHROMIUM_MP3_ENABLED
+ fi
+
+ if use x264 ; then
+ append-cflags -DGENTOO_CHROMIUM_H264_ENABLED
+ fi
+
# CFLAGS/LDFLAGS
mkdir -p "${S}"/.gyp
cat << EOF > "${S}"/.gyp/include.gypi
diff --git a/www-client/chromium/files/chromium-supported-media-mime-types.patch b/www-client/chromium/files/chromium-supported-media-mime-types.patch
new file mode 100644
index 000000000000..793de3d29847
--- /dev/null
+++ b/www-client/chromium/files/chromium-supported-media-mime-types.patch
@@ -0,0 +1,38 @@
+--- src/net/base/mime_util.cc.orig 2010-04-14 17:22:50.000000000 +0200
++++ src/net/base/mime_util.cc 2010-04-14 17:25:13.000000000 +0200
+@@ -189,18 +189,20 @@
+ "audio/ogg",
+ "application/ogg",
+
+-#if defined(GOOGLE_CHROME_BUILD)
++#if defined(GENTOO_CHROMIUM_H264_ENABLED)
+ // MPEG-4.
+ "video/mp4",
+ "video/x-m4v",
+ "audio/mp4",
+ "audio/x-m4a",
++#endif // defined(GENTOO_CHROMIUM_H264_ENABLED)
+
++#if defined(GENTOO_CHROMIUM_MP3_ENABLED)
+ // MP3.
+ "audio/mp3",
+ "audio/x-mp3",
+ "audio/mpeg",
+-#endif
++#endif // defined(GENTOO_CHROMIUM_MP3_ENABLED)
+ };
+
+ // List of supported codecs when passed in with <source type="...">.
+@@ -208,10 +210,10 @@
+ // Refer to http://wiki.whatwg.org/wiki/Video_type_parameters#Browser_Support
+ // for more information.
+ static const char* const supported_media_codecs[] = {
+-#if defined(GOOGLE_CHROME_BUILD)
++#if defined(GENTOO_CHROMIUM_H264_ENABLED)
+ "avc1",
+ "mp4a",
+-#endif
++#endif // defined(GENTOO_CHROMIUM_H264_ENABLED)
+ "theora",
+ "vorbis",
+ };