summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Olexa <darkside@gentoo.org>2010-08-17 16:22:18 +0000
committerJeremy Olexa <darkside@gentoo.org>2010-08-17 16:22:18 +0000
commitc5cc1f6e0f611b0f50ce484f781f4884f9cdb549 (patch)
tree3cedc2f6c1897664e51cbd2906047941b7949b56 /www-client
parentPatch 0.19 to bring up to version in RedHat (includes "-D" option in btrfsctl... (diff)
downloadgentoo-2-c5cc1f6e0f611b0f50ce484f781f4884f9cdb549.tar.gz
gentoo-2-c5cc1f6e0f611b0f50ce484f781f4884f9cdb549.tar.bz2
gentoo-2-c5cc1f6e0f611b0f50ce484f781f4884f9cdb549.zip
Version bump. sqlite is now a a mandatory dep for the bookmarks, USE=html is defaulted to enabled for midori's help page, optional vala support added. See full ChangeLog for other features here: http://releases.xfce.org/feeds/project/midori
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'www-client')
-rw-r--r--www-client/midori/ChangeLog11
-rw-r--r--www-client/midori/metadata.xml4
-rw-r--r--www-client/midori/midori-0.2.7.ebuild78
3 files changed, 91 insertions, 2 deletions
diff --git a/www-client/midori/ChangeLog b/www-client/midori/ChangeLog
index f97eafc57bc8..841f85ee418f 100644
--- a/www-client/midori/ChangeLog
+++ b/www-client/midori/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for www-client/midori
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/midori/ChangeLog,v 1.33 2010/08/01 13:56:18 fauli Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/midori/ChangeLog,v 1.34 2010/08/17 16:22:18 darkside Exp $
+
+*midori-0.2.7 (17 Aug 2010)
+
+ 17 Aug 2010; Jeremy Olexa <darkside@gentoo.org> +midori-0.2.7.ebuild,
+ metadata.xml:
+ Version bump. sqlite is now a a mandatory dep for the bookmarks, USE=html
+ is defaulted to enabled for midori's help page, optional vala support
+ added. See full ChangeLog for other features here:
+ http://releases.xfce.org/feeds/project/midori
01 Aug 2010; Christian Faulhammer <fauli@gentoo.org> midori-0.2.6.ebuild:
stable x86, bug 324227
diff --git a/www-client/midori/metadata.xml b/www-client/midori/metadata.xml
index 1df7eda12c07..a0ed1515572b 100644
--- a/www-client/midori/metadata.xml
+++ b/www-client/midori/metadata.xml
@@ -3,7 +3,9 @@
<pkgmetadata>
<herd>xfce</herd>
<use>
- <flag name="html">Install HTML documentation</flag>
+ <flag name="html">Install HTML documentation, requires
+ <pkg>dev-python/docutils</pkg></flag>
<flag name="unique">Optional libunique support</flag>
+ <flag name="vala">Optional vala support</flag>
</use>
</pkgmetadata>
diff --git a/www-client/midori/midori-0.2.7.ebuild b/www-client/midori/midori-0.2.7.ebuild
new file mode 100644
index 000000000000..47c96f833ebd
--- /dev/null
+++ b/www-client/midori/midori-0.2.7.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-client/midori/midori-0.2.7.ebuild,v 1.1 2010/08/17 16:22:18 darkside Exp $
+
+EAPI=2
+
+PYTHON_DEPEND="2:2.6"
+
+inherit eutils multilib python xfconf
+
+DESCRIPTION="A lightweight web browser based on WebKitGTK+"
+HOMEPAGE="http://www.twotoasts.de/index.php?/pages/midori_summary.html"
+SRC_URI="mirror://xfce/src/apps/${PN}/0.2/${P}.tar.bz2"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~x86 ~x86-fbsd"
+IUSE="doc gnome +html idn libnotify nls +unique vala"
+
+RDEPEND="libnotify? ( x11-libs/libnotify )
+ >=net-libs/libsoup-2.25.2
+ >=net-libs/webkit-gtk-1.1.1
+ >=dev-db/sqlite-3.0
+ dev-libs/libxml2
+ >=x11-libs/gtk+-2.10:2
+ gnome? ( net-libs/libsoup[gnome] )
+ idn? ( net-dns/libidn )
+ unique? ( dev-libs/libunique )"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ dev-util/pkgconfig
+ doc? ( dev-util/gtk-doc )
+ html? ( dev-python/docutils )
+ nls? ( sys-devel/gettext )"
+
+pkg_setup() {
+ python_set_active_version 2
+}
+
+src_prepare() {
+ # moving docs to version-specific directory
+ sed -i -e "s:\${DOCDIR}/${PN}:\${DOCDIR}/${PF}/:g" wscript || die
+ sed -i -e "s:/${PN}/user/midori.html:/${PF}/user/midori.html:g" midori/midori-browser.c || die
+}
+
+src_configure() {
+ strip-linguas -i po
+
+ CCFLAGS="${CFLAGS}" LINKFLAGS="${LDFLAGS}" ./waf \
+ --prefix="/usr/" \
+ --libdir="/usr/$(get_libdir)" \
+ --disable-docs \
+ --enable-addons \
+ $(use_enable doc apidocs) \
+ $(use_enable html userdocs) \
+ $(use_enable idn libidn) \
+ $(use_enable libnotify) \
+ $(use_enable nls nls) \
+ $(use_enable unique) \
+ $(use_enable vala) \
+ configure || die "configure failed"
+}
+
+src_compile() {
+ NUMJOBS=$(sed -e 's/.*\(\-j[ 0-9]\+\) .*/\1/; s/--jobs=\?/-j/' <<< ${MAKEOPTS})
+ ./waf build ${NUMJOBS} || die "build failed"
+}
+
+src_install() {
+ DESTDIR=${D} ./waf install || die "install failed"
+ dodoc AUTHORS ChangeLog INSTALL TODO || die "dodoc failed"
+}
+
+pkg_postinst() {
+ xfconf_pkg_postinst
+ ewarn "Midori tends to crash due to bugs in WebKit."
+ ewarn "Report bugs at http://www.twotoasts.de/bugs"
+}