summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn N. Laliberte <allanonjl@gentoo.org>2006-06-30 18:41:49 +0000
committerJohn N. Laliberte <allanonjl@gentoo.org>2006-06-30 18:41:49 +0000
commit9d2ed91644dc88440e33c1f92b9e58354152bb09 (patch)
treec55f33d05c13b66dcda3f1d05beecc4e2b7ee071 /www-client
parentFix digest. (diff)
downloadgentoo-2-9d2ed91644dc88440e33c1f92b9e58354152bb09.tar.gz
gentoo-2-9d2ed91644dc88440e33c1f92b9e58354152bb09.tar.bz2
gentoo-2-9d2ed91644dc88440e33c1f92b9e58354152bb09.zip
new version, remove as-needed patch since it was applied in this version. remove old versions
(Portage version: 2.1.1_pre1-r2)
Diffstat (limited to 'www-client')
-rw-r--r--www-client/epiphany/ChangeLog11
-rw-r--r--www-client/epiphany/epiphany-2.14.2.1.ebuild82
-rw-r--r--www-client/epiphany/files/digest-epiphany-1.6.42
-rw-r--r--www-client/epiphany/files/digest-epiphany-2.14.2.13
4 files changed, 97 insertions, 1 deletions
diff --git a/www-client/epiphany/ChangeLog b/www-client/epiphany/ChangeLog
index 2a25eb3da5f4..0e9d93afd339 100644
--- a/www-client/epiphany/ChangeLog
+++ b/www-client/epiphany/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for www-client/epiphany
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/epiphany/ChangeLog,v 1.70 2006/05/11 00:32:24 allanonjl Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/epiphany/ChangeLog,v 1.71 2006/06/30 18:41:49 allanonjl Exp $
+
+*epiphany-2.14.2.1 (30 Jun 2006)
+
+ 30 Jun 2006; John N. Laliberte <allanonjl@gentoo.org>
+ -files/epiphany-2.14.1-as-needed.patch, -epiphany-1.8.2.ebuild,
+ -epiphany-1.8.3.ebuild, -epiphany-2.14.1-r1.ebuild,
+ +epiphany-2.14.2.1.ebuild:
+ new version, remove as-needed patch since it was applied in this version.
+ remove old versions
*epiphany-2.14.1-r1 (11 May 2006)
diff --git a/www-client/epiphany/epiphany-2.14.2.1.ebuild b/www-client/epiphany/epiphany-2.14.2.1.ebuild
new file mode 100644
index 000000000000..3d8a90e0185a
--- /dev/null
+++ b/www-client/epiphany/epiphany-2.14.2.1.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-client/epiphany/epiphany-2.14.2.1.ebuild,v 1.1 2006/06/30 18:41:49 allanonjl Exp $
+
+inherit eutils gnome2 multilib autotools
+
+DESCRIPTION="GNOME webbrowser based on the mozilla rendering engine"
+HOMEPAGE="http://www.gnome.org/projects/epiphany/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="doc firefox python"
+
+# Note that there is no libgnomeprint dep, while it is
+# specified in configure.in . This could in some rare
+# situations break portage dep resolution.
+#
+# Marinus <foser@gentoo.org> 14-9-2005
+
+RDEPEND=">=dev-libs/glib-2.8
+ >=x11-libs/gtk+-2.8.3
+ >=dev-libs/libxml2-2.6.12
+ >=dev-libs/libxslt-1.1.7
+ >=gnome-base/libglade-2.3.1
+ >=gnome-base/gnome-vfs-2.9.2
+ >=gnome-base/libgnomeui-2.6
+ >=gnome-base/gnome-desktop-2.9.91
+ >=x11-libs/startup-notification-0.5
+ >=gnome-base/libgnomeprintui-2.4
+ >=gnome-base/libbonobo-2
+ >=gnome-base/orbit-2
+ >=gnome-base/gconf-2
+ >=app-text/iso-codes-0.35
+ !firefox? ( >=www-client/mozilla-1.7.9 )
+ firefox? ( >=www-client/mozilla-firefox-1.0.5 )
+ >=sys-apps/dbus-0.35
+ python? (
+ >=dev-lang/python-2.3
+ >=dev-python/pygtk-2.7.1
+ >=dev-python/gnome-python-2.6 )
+ x11-themes/gnome-icon-theme"
+
+DEPEND="${RDEPEND}
+ app-text/scrollkeeper
+ >=dev-util/pkgconfig-0.9
+ >=dev-util/intltool-0.29
+ app-text/gnome-doc-utils
+ doc? ( >=dev-util/gtk-doc-1 )"
+
+DOCS="AUTHORS ChangeLog* HACKING MAINTAINERS NEWS README TODO"
+
+MAKEOPTS="${MAKEOPTS} -j1"
+
+pkg_setup() {
+ G2CONF="--disable-scrollkeeper \
+ $(use_enable python)"
+
+ if use firefox; then
+ G2CONF="${G2CONF} --with-mozilla=firefox"
+ else
+ G2CONF="${G2CONF} --with-mozilla=mozilla"
+ fi
+}
+
+src_unpack() {
+ gnome2_src_unpack
+
+ epatch ${FILESDIR}/${PN}-1.9.2-broken-firefox.patch
+
+ cp aclocal.m4 old_macros.m4
+ AT_M4DIR=". ${S}/m4" WANT_AUTOCONF="2.59" \
+ eautoreconf || die "Failed to reconfigure"
+}
+
+src_compile() {
+ addpredict /usr/$(get_libdir)/mozilla-firefox/components/xpti.dat
+ addpredict /usr/$(get_libdir)/mozilla-firefox/components/compreg.dat.tmp
+ addpredict /usr/$(get_libdir)/mozilla/components/xpti.dat.tmp
+ addpredict /usr/$(get_libdir)/mozilla/components/xpti.dat
+ gnome2_src_compile
+}
diff --git a/www-client/epiphany/files/digest-epiphany-1.6.4 b/www-client/epiphany/files/digest-epiphany-1.6.4
index dd7bb0faaf22..e0e76c44e159 100644
--- a/www-client/epiphany/files/digest-epiphany-1.6.4
+++ b/www-client/epiphany/files/digest-epiphany-1.6.4
@@ -1 +1,3 @@
MD5 fbe9925593968c2f78abfa1e3a08e6d4 epiphany-1.6.4.tar.bz2 3036153
+RMD160 a37e7d2f3ea606fbf114afe25ad690fbd71249c7 epiphany-1.6.4.tar.bz2 3036153
+SHA256 ac122a7c8a3f4916b58f2b3f7d2c44cbdd7070680c06548b5affe2af5501303d epiphany-1.6.4.tar.bz2 3036153
diff --git a/www-client/epiphany/files/digest-epiphany-2.14.2.1 b/www-client/epiphany/files/digest-epiphany-2.14.2.1
new file mode 100644
index 000000000000..75cea701965f
--- /dev/null
+++ b/www-client/epiphany/files/digest-epiphany-2.14.2.1
@@ -0,0 +1,3 @@
+MD5 872ef8d5e95cdc359f93b5ded501d98d epiphany-2.14.2.1.tar.bz2 3599395
+RMD160 c25bc2d22fee0eeaa32ce1e1f71b6d5f3de06cbb epiphany-2.14.2.1.tar.bz2 3599395
+SHA256 f5cc3aa382fb9b0eec4117dcbfb5a7744943602d1a76bf260c7e5c66741ee6d0 epiphany-2.14.2.1.tar.bz2 3599395