summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRaúl Porcel <armin76@gentoo.org>2010-01-07 16:01:24 +0000
committerRaúl Porcel <armin76@gentoo.org>2010-01-07 16:01:24 +0000
commit999c793c44e5424dba5676d156c9f507bef68064 (patch)
tree3dfc24203f76c315a75819d5d278fded11ad872c /www-client
parentTransfer Prefix keywords (diff)
downloadgentoo-2-999c793c44e5424dba5676d156c9f507bef68064.tar.gz
gentoo-2-999c793c44e5424dba5676d156c9f507bef68064.tar.bz2
gentoo-2-999c793c44e5424dba5676d156c9f507bef68064.zip
Add patch to fix build on ARM, enable v8 build on ARM
(Portage version: 2.1.6.13/cvs/Linux ia64)
Diffstat (limited to 'www-client')
-rw-r--r--www-client/chromium/ChangeLog8
-rw-r--r--www-client/chromium/chromium-9999.ebuild8
-rw-r--r--www-client/chromium/files/chromium-drop_armel_m32.patch71
3 files changed, 82 insertions, 5 deletions
diff --git a/www-client/chromium/ChangeLog b/www-client/chromium/ChangeLog
index 3a5c8dcbfc7c..e472463e1fc6 100644
--- a/www-client/chromium/ChangeLog
+++ b/www-client/chromium/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for www-client/chromium
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/chromium/ChangeLog,v 1.33 2009/12/25 18:10:23 armin76 Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/www-client/chromium/ChangeLog,v 1.34 2010/01/07 16:01:23 armin76 Exp $
+
+ 07 Jan 2010; Raúl Porcel <armin76@gentoo.org>
+ +files/chromium-drop_armel_m32.patch, chromium-9999.ebuild:
+ Add patch to fix build on ARM, enable v8 build on ARM
25 Dec 2009; Raúl Porcel <armin76@gentoo.org> chromium-4.0.266.0.ebuild,
chromium-9999.ebuild:
diff --git a/www-client/chromium/chromium-9999.ebuild b/www-client/chromium/chromium-9999.ebuild
index de2392a0c58c..c76851d89632 100644
--- a/www-client/chromium/chromium-9999.ebuild
+++ b/www-client/chromium/chromium-9999.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/chromium/chromium-9999.ebuild,v 1.14 2009/12/25 18:10:23 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/chromium/chromium-9999.ebuild,v 1.15 2010/01/07 16:01:23 armin76 Exp $
EAPI="2"
inherit eutils multilib toolchain-funcs subversion
@@ -92,6 +92,8 @@ src_prepare() {
epatch "${FILESDIR}"/${PN}-drop_sse2.patch
# Add configuration flag to use system libevent
epatch "${FILESDIR}"/${PN}-use_system_libevent-1.4.13.patch
+ # Fix native build on ARM, http://crbug.com/31274
+ epatch "${FILESDIR}"/${PN}-drop_armel_m32.patch
# Disable prefixing to allow linking against system zlib
sed -e '/^#include "mozzconf.h"$/d' \
@@ -131,7 +133,7 @@ EOF
fi
if use arm; then
- myconf="${myconf} -Dtarget_arch=arm -Ddisable_nacl=1 -Dv8_use_snapshot=false -Dlinux_use_tcmalloc=0"
+ myconf="${myconf} -Dtarget_arch=arm -Ddisable_nacl=1 -Dlinux_use_tcmalloc=0"
fi
if [[ "$(gcc-major-version)$(gcc-minor-version)" == "44" ]]; then
diff --git a/www-client/chromium/files/chromium-drop_armel_m32.patch b/www-client/chromium/files/chromium-drop_armel_m32.patch
new file mode 100644
index 000000000000..0282b65490cc
--- /dev/null
+++ b/www-client/chromium/files/chromium-drop_armel_m32.patch
@@ -0,0 +1,71 @@
+---
+ v8/tools/gyp/v8.gyp | 12 ------------
+ 1 file changed, 12 deletions(-)
+
+Index: src/v8/tools/gyp/v8.gyp
+===================================================================
+--- src.orig/v8/tools/gyp/v8.gyp
++++ src/v8/tools/gyp/v8.gyp
+@@ -196,20 +196,16 @@
+ '<(SHARED_INTERMEDIATE_DIR)/libraries.cc',
+ '../../src/snapshot-empty.cc',
+ ],
+ 'conditions': [
+ # The ARM assembler assumes the host is 32 bits, so force building
+ # 32-bit host tools.
+ # TODO(piman): This assumes that the host is ia32 or amd64. Fixing the
+ # code would be better
+- ['target_arch=="arm" and _toolset=="host"', {
+- 'cflags': ['-m32'],
+- 'ldflags': ['-m32'],
+- }]
+ ]
+ },
+ {
+ 'target_name': 'v8_base',
+ 'type': '<(library)',
+ 'toolsets': ['host', 'target'],
+ 'include_dirs+': [
+ '../../src',
+@@ -425,20 +421,16 @@
+ '../../src/arm/virtual-frame-arm.cc',
+ '../../src/arm/virtual-frame-arm.h',
+ ],
+ 'conditions': [
+ # The ARM assembler assumes the host is 32 bits, so force building
+ # 32-bit host tools.
+ # TODO(piman): This assumes that the host is ia32 or amd64. Fixing
+ # the code would be better
+- ['_toolset=="host"', {
+- 'cflags': ['-m32'],
+- 'ldflags': ['-m32'],
+- }]
+ ]
+ }],
+ ['target_arch=="ia32"', {
+ 'include_dirs+': [
+ '../../src/ia32',
+ ],
+ 'sources': [
+ '../../src/ia32/assembler-ia32-inl.h',
+@@ -595,20 +587,16 @@
+ 'sources': [
+ '../../src/mksnapshot.cc',
+ ],
+ 'conditions': [
+ # The ARM assembler assumes the host is 32 bits, so force building
+ # 32-bit host tools.
+ # TODO(piman): This assumes that the host is ia32 or amd64. Fixing
+ # the code would be better
+- ['target_arch=="arm" and _toolset=="host"', {
+- 'cflags': ['-m32'],
+- 'ldflags': ['-m32'],
+- }]
+ ]
+ },
+ {
+ 'target_name': 'v8_shell',
+ 'type': 'executable',
+ 'dependencies': [
+ 'v8'
+ ],