summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaweł Hajdan <phajdan.jr@gentoo.org>2011-01-02 15:31:35 +0000
committerPaweł Hajdan <phajdan.jr@gentoo.org>2011-01-02 15:31:35 +0000
commit95c04555a947d83b5b6cbc7adad47f60e0fa6ffd (patch)
tree1c64b94e78c2fda7e08746fbb44bc3cb02b97407 /www-client
parentVersion bump. (diff)
downloadgentoo-2-95c04555a947d83b5b6cbc7adad47f60e0fa6ffd.tar.gz
gentoo-2-95c04555a947d83b5b6cbc7adad47f60e0fa6ffd.tar.bz2
gentoo-2-95c04555a947d83b5b6cbc7adad47f60e0fa6ffd.zip
Fix locale-sensitive test failures, bug #350349.
(Portage version: 2.1.9.25/cvs/Linux i686)
Diffstat (limited to 'www-client')
-rw-r--r--www-client/chromium/ChangeLog8
-rw-r--r--www-client/chromium/chromium-10.0.612.1-r1.ebuild18
-rw-r--r--www-client/chromium/chromium-9999.ebuild18
3 files changed, 34 insertions, 10 deletions
diff --git a/www-client/chromium/ChangeLog b/www-client/chromium/ChangeLog
index ae518c1c3e0a..b50c76a02c4b 100644
--- a/www-client/chromium/ChangeLog
+++ b/www-client/chromium/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for www-client/chromium
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/chromium/ChangeLog,v 1.248 2010/12/22 11:51:41 phajdan.jr Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/www-client/chromium/ChangeLog,v 1.249 2011/01/02 15:31:35 phajdan.jr Exp $
+
+ 02 Jan 2011; Pawel Hajdan jr <phajdan.jr@gentoo.org>
+ chromium-10.0.612.1-r1.ebuild, chromium-9999.ebuild:
+ Fix locale-sensitive test failures, bug #350349.
*chromium-10.0.612.1-r1 (22 Dec 2010)
diff --git a/www-client/chromium/chromium-10.0.612.1-r1.ebuild b/www-client/chromium/chromium-10.0.612.1-r1.ebuild
index 33287e834fcd..5390c23ad9a9 100644
--- a/www-client/chromium/chromium-10.0.612.1-r1.ebuild
+++ b/www-client/chromium/chromium-10.0.612.1-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/chromium/chromium-10.0.612.1-r1.ebuild,v 1.1 2010/12/22 11:51:41 phajdan.jr Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/chromium/chromium-10.0.612.1-r1.ebuild,v 1.2 2011/01/02 15:31:35 phajdan.jr Exp $
EAPI="3"
PYTHON_DEPEND="2:2.6"
@@ -287,10 +287,20 @@ src_compile() {
}
src_test() {
+ # For more info see bug #350349.
+ local mylocale='en_US.utf8'
+ if ! locale -a | grep -q "$mylocale"; then
+ eerror "${PN} requires ${mylocale} locale for tests"
+ eerror "Please read the following guides for more information:"
+ eerror " http://www.gentoo.org/doc/en/guide-localization.xml"
+ eerror " http://www.gentoo.org/doc/en/utf-8.xml"
+ die "locale ${mylocale} is not supported"
+ fi
+
# Make test failures non-fatal for now. This needs more investigation.
- maketype=out/Release/base_unittests virtualmake \
+ LC_ALL="${mylocale}" maketype=out/Release/base_unittests virtualmake \
|| eerror "base_unittests failed"
- maketype=out/Release/net_unittests virtualmake \
+ LC_ALL="${mylocale}" maketype=out/Release/net_unittests virtualmake \
|| eerror "net_unittests failed"
}
diff --git a/www-client/chromium/chromium-9999.ebuild b/www-client/chromium/chromium-9999.ebuild
index 353a9c6d4a6d..89995269e41f 100644
--- a/www-client/chromium/chromium-9999.ebuild
+++ b/www-client/chromium/chromium-9999.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/chromium/chromium-9999.ebuild,v 1.118 2010/12/22 11:51:41 phajdan.jr Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/chromium/chromium-9999.ebuild,v 1.119 2011/01/02 15:31:35 phajdan.jr Exp $
EAPI="3"
PYTHON_DEPEND="2:2.6"
@@ -330,10 +330,20 @@ src_compile() {
}
src_test() {
+ # For more info see bug #350349.
+ local mylocale='en_US.utf8'
+ if ! locale -a | grep -q "$mylocale"; then
+ eerror "${PN} requires ${mylocale} locale for tests"
+ eerror "Please read the following guides for more information:"
+ eerror " http://www.gentoo.org/doc/en/guide-localization.xml"
+ eerror " http://www.gentoo.org/doc/en/utf-8.xml"
+ die "locale ${mylocale} is not supported"
+ fi
+
# Make test failures non-fatal for now. This needs more investigation.
- maketype=out/Release/base_unittests virtualmake \
+ LC_ALL="${mylocale}" maketype=out/Release/base_unittests virtualmake \
|| eerror "base_unittests failed"
- maketype=out/Release/net_unittests virtualmake \
+ LC_ALL="${mylocale}" maketype=out/Release/net_unittests virtualmake \
|| eerror "net_unittests failed"
}