summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarcelo Góes <vanquirius@gentoo.org>2007-04-14 19:11:04 +0000
committerMarcelo Góes <vanquirius@gentoo.org>2007-04-14 19:11:04 +0000
commit952da3aeb42a76ebb9c931f792c8fa1803f1d6f6 (patch)
tree6e7b59a6b2e4c042afed911f3b17c8a3a63b1ea4 /www-client
parentRemove package.mask entries for removed Xfce 4.2 pkgs. (diff)
downloadgentoo-2-952da3aeb42a76ebb9c931f792c8fa1803f1d6f6.tar.gz
gentoo-2-952da3aeb42a76ebb9c931f792c8fa1803f1d6f6.tar.bz2
gentoo-2-952da3aeb42a76ebb9c931f792c8fa1803f1d6f6.zip
2.1_pre28 version bump.
(Portage version: 2.1.2.2)
Diffstat (limited to 'www-client')
-rw-r--r--www-client/links/ChangeLog9
-rw-r--r--www-client/links/files/digest-links-2.1_pre286
-rw-r--r--www-client/links/links-2.1_pre28.ebuild127
3 files changed, 140 insertions, 2 deletions
diff --git a/www-client/links/ChangeLog b/www-client/links/ChangeLog
index d176adf9fc33..56990844649e 100644
--- a/www-client/links/ChangeLog
+++ b/www-client/links/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for www-client/links
-# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/links/ChangeLog,v 1.84 2006/12/18 20:36:21 eroyf Exp $
+# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/www-client/links/ChangeLog,v 1.85 2007/04/14 19:11:04 vanquirius Exp $
+
+*links-2.1_pre28 (14 Apr 2007)
+
+ 14 Apr 2007; Marcelo Goes <vanquirius@gentoo.org> +links-2.1_pre28.ebuild:
+ 2.1_pre28 version bump.
18 Dec 2006; Alexander H. Færøy <eroyf@gentoo.org>
links-2.1_pre26.ebuild:
diff --git a/www-client/links/files/digest-links-2.1_pre28 b/www-client/links/files/digest-links-2.1_pre28
new file mode 100644
index 000000000000..dc0ce1f0b628
--- /dev/null
+++ b/www-client/links/files/digest-links-2.1_pre28
@@ -0,0 +1,6 @@
+MD5 1f59217d4906622693eb3e1532871a72 links-2.1pre22-utf8.diff.bz2 4189
+RMD160 fa0c4719aa5ac0244bd165d010b9c303bfead5d3 links-2.1pre22-utf8.diff.bz2 4189
+SHA256 42982ee8f605f793226f07da9ed5cb9d5be613d1f8e4bb6270533bbd7cd42b9b links-2.1pre22-utf8.diff.bz2 4189
+MD5 815afe558dd548258eeb03b01cce01ce links-2.1pre28.tar.bz2 3915943
+RMD160 42ac2adf24509216bc26629c48ea5362eb53b267 links-2.1pre28.tar.bz2 3915943
+SHA256 203531be7c84ebe3a5d53c6d6cda4f4a27626dec620ec5aa8926414d0bee5995 links-2.1pre28.tar.bz2 3915943
diff --git a/www-client/links/links-2.1_pre28.ebuild b/www-client/links/links-2.1_pre28.ebuild
new file mode 100644
index 000000000000..7150f488f3be
--- /dev/null
+++ b/www-client/links/links-2.1_pre28.ebuild
@@ -0,0 +1,127 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-client/links/links-2.1_pre28.ebuild,v 1.1 2007/04/14 19:11:04 vanquirius Exp $
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="links is a fast lightweight text and graphic web-browser"
+HOMEPAGE="http://links.twibright.com/"
+# To handle pre-version ...
+MY_P="${P/_/}"
+S="${WORKDIR}/${MY_P}"
+SRC_URI="http://links.twibright.com/download/${MY_P}.tar.bz2
+ mirror://gentoo/${PN}-2.1pre22-utf8.diff.bz2"
+
+LICENSE="GPL-2"
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="directfb fbcon gpm javascript jpeg livecd png sdl ssl svga tiff unicode X"
+
+# Note: if X or fbcon usegflag are enabled, links will be built in graphic
+# mode. libpng is required to compile links in graphic mode
+# (not required in text mode), so let's add libpng for X? and fbcon?
+
+# We've also made USE=livecd compile in graphics mode. This closes bug #75685.
+
+RDEPEND="ssl? ( >=dev-libs/openssl-0.9.6c )
+ gpm? ( sys-libs/gpm )
+ png? ( >=media-libs/libpng-1.2.1 )
+ jpeg? ( >=media-libs/jpeg-6b )
+ fbcon? ( >=media-libs/libpng-1.2.1
+ >=media-libs/jpeg-6b
+ sys-libs/gpm )
+ tiff? ( >=media-libs/tiff-3.5.7 )
+ svga? ( >=media-libs/svgalib-1.4.3
+ >=media-libs/libpng-1.2.1 )
+ X? ( || ( x11-libs/libXext
+ virtual/x11 )
+ >=media-libs/libpng-1.2.1 )
+ directfb? ( dev-libs/DirectFB )
+ sdl? ( >=media-libs/libsdl-1.2.0 )
+ sys-libs/zlib
+ virtual/libc
+ sys-libs/ncurses"
+
+DEPEND="${RDEPEND}
+ sys-devel/automake
+ sys-devel/autoconf
+ sys-devel/gcc
+ dev-util/pkgconfig
+ javascript? ( >=sys-devel/flex-2.5.4a )"
+
+src_unpack (){
+ unpack ${A}; cd "${S}"
+
+ epatch "${FILESDIR}"/configure-LANG.patch #131440
+
+ if use unicode ; then
+ epatch "${WORKDIR}/${PN}-2.1pre22-utf8.diff"
+ cd "${S}/intl" && ./gen-intl && cd .. || die "gen-intl filed"
+ fi
+}
+
+src_compile (){
+ local myconf
+
+ if use X || use fbcon || use directfb || use svga || use livecd; then
+ myconf="${myconf} --enable-graphics"
+ fi
+
+ # Note: --enable-static breaks.
+
+ # Note: ./configure only support 'gpm' features auto-detection, so
+ # we use the autoconf trick
+ ( use gpm || use fbcon || use livecd ) || export ac_cv_lib_gpm_Gpm_Open="no"
+
+ export LANG=C
+
+ if use fbcon || use livecd; then
+ myconf="${myconf} --with-fb"
+ else
+ myconf="${myconf} --without-fb"
+ fi
+
+ # force --with-libjpeg if livecd flag is set
+ if use livecd; then
+ myconf="${myconf} --with-libjpeg"
+ fi
+
+ # hack to allow cross-compilation
+ export CC="$(tc-getCC)"
+
+ econf \
+ $(use_with X x) \
+ $(use_with png libpng) \
+ $(use_with jpeg libjpeg) \
+ $(use_with tiff libtiff) \
+ $(use_with svga svgalib) \
+ $(use_with directfb) \
+ $(use_with ssl) \
+ $(use_with sdl) \
+ $(use_enable javascript) \
+ ${myconf} || die "configure failed"
+ emake || die "make failed"
+}
+
+src_install() {
+ einstall || die
+
+ # Only install links icon if X driver was compiled in ...
+ use X && doicon graphics/links.xpm
+
+ dodoc AUTHORS BUGS ChangeLog NEWS README SITES TODO
+ dohtml doc/links_cal/*
+
+ # Install a compatibility symlink links2:
+ dosym links /usr/bin/links2
+}
+
+
+pkg_postinst() {
+ if use svga ; then
+ elog "You had the svga USE flag enabled, but for security reasons"
+ elog "the links2 binary is NOT setuid by default. In order to"
+ elog "enable links2 to work in SVGA, please change the permissions"
+ elog "of /usr/bin/links2 to enable suid."
+ fi
+}