summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaweł Hajdan <phajdan.jr@gentoo.org>2014-01-03 07:32:47 +0000
committerPaweł Hajdan <phajdan.jr@gentoo.org>2014-01-03 07:32:47 +0000
commit74f418bc17021d31ff1a5a8891a43ea9b4c31e04 (patch)
tree2b84a9727b72e505e961d8bccb39579e8f796881 /www-client
parentFix location of CAPI documentation to be version-specific, fixing bug 496086. (diff)
downloadgentoo-2-74f418bc17021d31ff1a5a8891a43ea9b4c31e04.tar.gz
gentoo-2-74f418bc17021d31ff1a5a8891a43ea9b4c31e04.tar.bz2
gentoo-2-74f418bc17021d31ff1a5a8891a43ea9b4c31e04.zip
Correctly handle python dependencies, bug #496326 by nzqr.
(Portage version: 2.2.7/cvs/Linux i686, signed Manifest commit with key 30427902)
Diffstat (limited to 'www-client')
-rw-r--r--www-client/chromium/ChangeLog8
-rw-r--r--www-client/chromium/chromium-32.0.1700.68.ebuild24
-rw-r--r--www-client/chromium/chromium-33.0.1750.3.ebuild24
3 files changed, 40 insertions, 16 deletions
diff --git a/www-client/chromium/ChangeLog b/www-client/chromium/ChangeLog
index edbe6a599c38..c9c1805406b7 100644
--- a/www-client/chromium/ChangeLog
+++ b/www-client/chromium/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for www-client/chromium
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/chromium/ChangeLog,v 1.1005 2013/12/20 01:51:27 floppym Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/www-client/chromium/ChangeLog,v 1.1006 2014/01/03 07:32:47 phajdan.jr Exp $
+
+ 02 Jan 2014; Pawel Hajdan jr <phajdan.jr@gentoo.org>
+ chromium-32.0.1700.68.ebuild, chromium-33.0.1750.3.ebuild:
+ Correctly handle python dependencies, bug #496326 by nzqr.
*chromium-32.0.1700.68 (20 Dec 2013)
diff --git a/www-client/chromium/chromium-32.0.1700.68.ebuild b/www-client/chromium/chromium-32.0.1700.68.ebuild
index 5c53cd32f121..6e495249d683 100644
--- a/www-client/chromium/chromium-32.0.1700.68.ebuild
+++ b/www-client/chromium/chromium-32.0.1700.68.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/chromium/chromium-32.0.1700.68.ebuild,v 1.1 2013/12/20 01:51:27 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/chromium/chromium-32.0.1700.68.ebuild,v 1.2 2014/01/03 07:32:47 phajdan.jr Exp $
EAPI="5"
PYTHON_COMPAT=( python{2_6,2_7} )
@@ -71,15 +71,11 @@ RDEPEND=">=app-accessibility/speech-dispatcher-0.8:=
kerberos? ( virtual/krb5 )
selinux? ( sec-policy/selinux-chromium )"
DEPEND="${RDEPEND}
- ${PYTHON_DEPS}
!arm? (
dev-lang/yasm
)
dev-lang/perl
dev-perl/JSON
- >=dev-python/jinja-2.7
- dev-python/ply
- dev-python/simplejson
>=dev-util/gperf-3.0.3
dev-util/ninja
sys-apps/hwids
@@ -88,7 +84,6 @@ DEPEND="${RDEPEND}
virtual/pkgconfig
test? (
dev-libs/openssl:0
- dev-python/pyftpdlib
)"
# For nvidia-drivers blocker, see bug #413637 .
RDEPEND+="
@@ -97,6 +92,21 @@ RDEPEND+="
virtual/ttf-fonts
tcmalloc? ( !<x11-drivers/nvidia-drivers-331.20 )"
+# Python dependencies. The DEPEND part needs to be kept in sync
+# with python_check_deps.
+DEPEND+=" $(python_gen_any_dep '
+ >=dev-python/jinja-2.7[${PYTHON_USEDEP}]
+ dev-python/ply[${PYTHON_USEDEP}]
+ dev-python/simplejson[${PYTHON_USEDEP}]
+ test? ( dev-python/pyftpdlib[${PYTHON_USEDEP}] )
+')"
+python_check_deps() {
+ has_version ">=dev-python/jinja-2.7[${PYTHON_USEDEP}]" && \
+ has_version "dev-python/ply[${PYTHON_USEDEP}]" && \
+ has_version "dev-python/simplejson[${PYTHON_USEDEP}]" && \
+ { ! use test || has_version "dev-python/pyftpdlib[${PYTHON_USEDEP}]"; }
+}
+
if ! has chromium_pkg_die ${EBUILD_DEATH_HOOKS}; then
EBUILD_DEATH_HOOKS+=" chromium_pkg_die";
fi
diff --git a/www-client/chromium/chromium-33.0.1750.3.ebuild b/www-client/chromium/chromium-33.0.1750.3.ebuild
index d3af8b63d2b3..fa75b3026480 100644
--- a/www-client/chromium/chromium-33.0.1750.3.ebuild
+++ b/www-client/chromium/chromium-33.0.1750.3.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/chromium/chromium-33.0.1750.3.ebuild,v 1.1 2013/12/18 12:24:37 phajdan.jr Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/chromium/chromium-33.0.1750.3.ebuild,v 1.2 2014/01/03 07:32:47 phajdan.jr Exp $
EAPI="5"
PYTHON_COMPAT=( python{2_6,2_7} )
@@ -71,15 +71,11 @@ RDEPEND=">=app-accessibility/speech-dispatcher-0.8:=
kerberos? ( virtual/krb5 )
selinux? ( sec-policy/selinux-chromium )"
DEPEND="${RDEPEND}
- ${PYTHON_DEPS}
!arm? (
dev-lang/yasm
)
dev-lang/perl
dev-perl/JSON
- >=dev-python/jinja-2.7
- dev-python/ply
- dev-python/simplejson
>=dev-util/gperf-3.0.3
dev-util/ninja
sys-apps/hwids
@@ -88,7 +84,6 @@ DEPEND="${RDEPEND}
virtual/pkgconfig
test? (
dev-libs/openssl:0
- dev-python/pyftpdlib
)"
# For nvidia-drivers blocker, see bug #413637 .
RDEPEND+="
@@ -97,6 +92,21 @@ RDEPEND+="
virtual/ttf-fonts
tcmalloc? ( !<x11-drivers/nvidia-drivers-331.20 )"
+# Python dependencies. The DEPEND part needs to be kept in sync
+# with python_check_deps.
+DEPEND+=" $(python_gen_any_dep '
+ >=dev-python/jinja-2.7[${PYTHON_USEDEP}]
+ dev-python/ply[${PYTHON_USEDEP}]
+ dev-python/simplejson[${PYTHON_USEDEP}]
+ test? ( dev-python/pyftpdlib[${PYTHON_USEDEP}] )
+')"
+python_check_deps() {
+ has_version ">=dev-python/jinja-2.7[${PYTHON_USEDEP}]" && \
+ has_version "dev-python/ply[${PYTHON_USEDEP}]" && \
+ has_version "dev-python/simplejson[${PYTHON_USEDEP}]" && \
+ { ! use test || has_version "dev-python/pyftpdlib[${PYTHON_USEDEP}]"; }
+}
+
if ! has chromium_pkg_die ${EBUILD_DEATH_HOOKS}; then
EBUILD_DEATH_HOOKS+=" chromium_pkg_die";
fi