summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRaúl Porcel <armin76@gentoo.org>2007-07-20 16:24:55 +0000
committerRaúl Porcel <armin76@gentoo.org>2007-07-20 16:24:55 +0000
commit697ae4ee3fbb6692a45433dfb8628240c01e8336 (patch)
tree98d6b139b7a34fa86d14e39b9cd1108dfaec72ee /www-client
parentKeyword for ~arm, armin76 made me. (diff)
downloadgentoo-2-697ae4ee3fbb6692a45433dfb8628240c01e8336.tar.gz
gentoo-2-697ae4ee3fbb6692a45433dfb8628240c01e8336.tar.bz2
gentoo-2-697ae4ee3fbb6692a45433dfb8628240c01e8336.zip
Fix desktop files, bug 185869, and version bump wrt security #185737
(Portage version: 2.1.3_rc8)
Diffstat (limited to 'www-client')
-rw-r--r--www-client/seamonkey-bin/ChangeLog8
-rw-r--r--www-client/seamonkey-bin/files/digest-seamonkey-bin-1.1.33
-rw-r--r--www-client/seamonkey-bin/files/icon/seamonkey-bin.desktop2
-rw-r--r--www-client/seamonkey-bin/seamonkey-bin-1.1.3.ebuild71
4 files changed, 82 insertions, 2 deletions
diff --git a/www-client/seamonkey-bin/ChangeLog b/www-client/seamonkey-bin/ChangeLog
index 21c36806f4a8..8a5f92067f07 100644
--- a/www-client/seamonkey-bin/ChangeLog
+++ b/www-client/seamonkey-bin/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for www-client/seamonkey-bin
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/seamonkey-bin/ChangeLog,v 1.16 2007/07/02 14:39:56 peper Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/seamonkey-bin/ChangeLog,v 1.17 2007/07/20 16:24:55 armin76 Exp $
+
+*seamonkey-bin-1.1.3 (20 Jul 2007)
+
+ 20 Jul 2007; Raúl Porcel <armin76@gentoo.org>
+ files/icon/seamonkey-bin.desktop, +seamonkey-bin-1.1.3.ebuild:
+ Fix desktop files, bug 185869, and version bump wrt security #185737
02 Jul 2007; Piotr Jaroszyński <peper@gentoo.org>
seamonkey-bin-1.1.2.ebuild:
diff --git a/www-client/seamonkey-bin/files/digest-seamonkey-bin-1.1.3 b/www-client/seamonkey-bin/files/digest-seamonkey-bin-1.1.3
new file mode 100644
index 000000000000..9b0e01274f93
--- /dev/null
+++ b/www-client/seamonkey-bin/files/digest-seamonkey-bin-1.1.3
@@ -0,0 +1,3 @@
+MD5 501b3e59bc2b8811b5cf658a33d1a853 seamonkey-1.1.3.en-US.linux-i686.tar.gz 14786385
+RMD160 fb9c53a2ba417a115f127b1f8531ae656a3e1c35 seamonkey-1.1.3.en-US.linux-i686.tar.gz 14786385
+SHA256 f06b1db0a10e460310ec37e0db555574694a7c85167c1aced9a02da42a1a4bac seamonkey-1.1.3.en-US.linux-i686.tar.gz 14786385
diff --git a/www-client/seamonkey-bin/files/icon/seamonkey-bin.desktop b/www-client/seamonkey-bin/files/icon/seamonkey-bin.desktop
index 92fe336d191d..78fa325a0b36 100644
--- a/www-client/seamonkey-bin/files/icon/seamonkey-bin.desktop
+++ b/www-client/seamonkey-bin/files/icon/seamonkey-bin.desktop
@@ -5,4 +5,4 @@ Exec=/usr/bin/seamonkey-bin %U
Icon=seamonkey-bin.png
Terminal=false
Type=Application
-Categories=Application;Network;
+Categories=Network;WebBrowser;
diff --git a/www-client/seamonkey-bin/seamonkey-bin-1.1.3.ebuild b/www-client/seamonkey-bin/seamonkey-bin-1.1.3.ebuild
new file mode 100644
index 000000000000..df2575f79aef
--- /dev/null
+++ b/www-client/seamonkey-bin/seamonkey-bin-1.1.3.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-client/seamonkey-bin/seamonkey-bin-1.1.3.ebuild,v 1.1 2007/07/20 16:24:55 armin76 Exp $
+
+inherit eutils mozilla-launcher multilib
+
+DESCRIPTION="Mozilla Application Suite - web browser, email, HTML editor, IRC"
+SRC_URI="http://releases.mozilla.org/pub/mozilla.org/seamonkey/releases/${PV}/seamonkey-${PV}.en-US.linux-i686.tar.gz"
+HOMEPAGE="http://www.mozilla.org/projects/seamonkey/"
+RESTRICT="strip"
+
+KEYWORDS="-* ~amd64 ~x86"
+SLOT="0"
+LICENSE="MPL-1.1 GPL-2 LGPL-2.1"
+IUSE=""
+
+DEPEND="app-arch/unzip"
+RDEPEND="x11-libs/libXrender
+ x11-libs/libXt
+ x11-libs/libXmu
+ x86? (
+ >=x11-libs/gtk+-2.2
+ =virtual/libstdc++-3.3
+ )
+ amd64? (
+ >=app-emulation/emul-linux-x86-baselibs-1.0
+ >=app-emulation/emul-linux-x86-gtklibs-1.0
+ app-emulation/emul-linux-x86-compat
+ )
+ >=www-client/mozilla-launcher-1.56"
+
+S="${WORKDIR}/seamonkey"
+
+pkg_setup() {
+ # This is a binary x86 package => ABI=x86
+ # Please keep this in future versions
+ # Danny van Dyk <kugelfang@gentoo.org> 2005/03/26
+ has_multilib_profile && ABI="x86"
+}
+
+src_install() {
+ declare MOZILLA_FIVE_HOME=/opt/seamonkey
+
+ # Install seamonkey in /opt
+ dodir ${MOZILLA_FIVE_HOME%/*}
+ mv ${S} ${D}${MOZILLA_FIVE_HOME}
+
+ # Install /usr/bin/seamonkey-bin
+ install_mozilla_launcher_stub seamonkey-bin ${MOZILLA_FIVE_HOME}
+
+ # Install icon and .desktop for menu entry
+ doicon ${FILESDIR}/icon/${PN}-icon.png
+ domenu ${FILESDIR}/icon/${PN}.desktop
+}
+
+pkg_preinst() {
+ declare MOZILLA_FIVE_HOME=/opt/seamonkey
+
+ # Remove entire installed instance to prevent all kinds of
+ # problems... see bug 44772 for example
+ rm -rf "${ROOT}${MOZILLA_FIVE_HOME}"
+}
+
+pkg_postinst() {
+ use amd64 && einfo "NB: You just installed a 32-bit seamonkey"
+ update_mozilla_launcher_symlinks
+}
+
+pkg_postrm() {
+ update_mozilla_launcher_symlinks
+}