summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2013-07-31 22:31:02 +0000
committerMike Gilbert <floppym@gentoo.org>2013-07-31 22:31:02 +0000
commit65344275b8388be346eeda6acc95a434dd27aba1 (patch)
treedb2e1495cd608b674db25eee13f4009eee0f9c39 /www-client
parentAdjust src_test so that we always run all tests instead of dying on the first... (diff)
downloadgentoo-2-65344275b8388be346eeda6acc95a434dd27aba1.tar.gz
gentoo-2-65344275b8388be346eeda6acc95a434dd27aba1.tar.bz2
gentoo-2-65344275b8388be346eeda6acc95a434dd27aba1.zip
Apply src_test change to live ebuild.
(Portage version: 2.2.0_alpha191/cvs/Linux x86_64, signed Manifest commit with key 0BBEEA1FEA4843A4)
Diffstat (limited to 'www-client')
-rw-r--r--www-client/chromium/ChangeLog5
-rw-r--r--www-client/chromium/chromium-9999-r1.ebuild32
2 files changed, 28 insertions, 9 deletions
diff --git a/www-client/chromium/ChangeLog b/www-client/chromium/ChangeLog
index abb81fa24eae..b70cdd14bf42 100644
--- a/www-client/chromium/ChangeLog
+++ b/www-client/chromium/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for www-client/chromium
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/chromium/ChangeLog,v 1.925 2013/07/31 22:29:32 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/chromium/ChangeLog,v 1.926 2013/07/31 22:31:02 floppym Exp $
+
+ 31 Jul 2013; Mike Gilbert <floppym@gentoo.org> chromium-9999-r1.ebuild:
+ Apply src_test change to live ebuild.
31 Jul 2013; Mike Gilbert <floppym@gentoo.org> chromium-29.0.1547.32.ebuild,
chromium-30.0.1581.2.ebuild:
diff --git a/www-client/chromium/chromium-9999-r1.ebuild b/www-client/chromium/chromium-9999-r1.ebuild
index 9c09bdefda98..ea72eb7032b7 100644
--- a/www-client/chromium/chromium-9999-r1.ebuild
+++ b/www-client/chromium/chromium-9999-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/chromium/chromium-9999-r1.ebuild,v 1.205 2013/07/31 15:40:26 phajdan.jr Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/chromium/chromium-9999-r1.ebuild,v 1.206 2013/07/31 22:31:02 floppym Exp $
EAPI="5"
PYTHON_COMPAT=( python{2_6,2_7} )
@@ -474,26 +474,40 @@ src_compile() {
src_test() {
# For more info see bug #350349.
- local mylocale='en_US.utf8'
- if ! locale -a | grep -q "$mylocale"; then
- eerror "${PN} requires ${mylocale} locale for tests"
+ local LC_ALL="en_US.utf8"
+
+ if ! locale -a | grep -q "${LC_ALL}"; then
+ eerror "${PN} requires ${LC_ALL} locale for tests"
eerror "Please read the following guides for more information:"
eerror " http://www.gentoo.org/doc/en/guide-localization.xml"
eerror " http://www.gentoo.org/doc/en/utf-8.xml"
- die "locale ${mylocale} is not supported"
+ die "locale ${LC_ALL} is not supported"
fi
+ # If we have the right locale, export it to the environment
+ export LC_ALL
+
# For more info see bug #370957.
if [[ $UID -eq 0 ]]; then
die "Tests must be run as non-root. Please use FEATURES=userpriv."
fi
+ # virtualmake dies on failure, so we run our tests in a function
+ VIRTUALX_COMMAND="chromium_test" virtualmake
+}
+
+chromium_test() {
+ # Keep track of the cumulative exit status for all tests
+ local exitstatus=0
+
runtest() {
local cmd=$1
shift
- local filter="--gtest_filter=$(IFS=:; echo "-${*}")"
- einfo "${cmd}" "${filter}"
- LC_ALL="${mylocale}" VIRTUALX_COMMAND="${cmd}" virtualmake "${filter}"
+ local IFS=:
+ set -- "${cmd}" "--gtest_filter=-$*"
+ einfo "$@"
+ "$@"
+ (( exitstatus |= $? ))
}
local excluded_base_unittests=(
@@ -537,6 +551,8 @@ src_test() {
"SQLiteFeaturesTest.FTS2" # bug #461286
)
runtest out/Release/sql_unittests "${excluded_sql_unittests[@]}"
+
+ return ${exitstatus}
}
src_install() {