summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2009-03-20 19:42:42 +0000
committerJeroen Roovers <jer@gentoo.org>2009-03-20 19:42:42 +0000
commit49e1c71b2159c0ad5567c8ad5505b160ddbfa3d0 (patch)
treea93a3aadfdf368e0a5e02e867bff95156bf93da2 /www-client
parentRemove invalid code inside findtclver() which doesn't work with bash-4.0. (diff)
downloadgentoo-2-49e1c71b2159c0ad5567c8ad5505b160ddbfa3d0.tar.gz
gentoo-2-49e1c71b2159c0ad5567c8ad5505b160ddbfa3d0.tar.bz2
gentoo-2-49e1c71b2159c0ad5567c8ad5505b160ddbfa3d0.zip
Define a dummy src_configure, thanks to Rafal Lalik for reporting (bug #263010).
(Portage version: 2.2_rc26/cvs/Linux i686)
Diffstat (limited to 'www-client')
-rw-r--r--www-client/opera/ChangeLog7
-rw-r--r--www-client/opera/opera-10.00_pre4205.ebuild10
-rw-r--r--www-client/opera/opera-10.00_pre4214.ebuild10
-rw-r--r--www-client/opera/opera-9.27.ebuild12
-rw-r--r--www-client/opera/opera-9.64.ebuild10
5 files changed, 39 insertions, 10 deletions
diff --git a/www-client/opera/ChangeLog b/www-client/opera/ChangeLog
index e42602d2767f..8e03097eead3 100644
--- a/www-client/opera/ChangeLog
+++ b/www-client/opera/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for www-client/opera
# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/opera/ChangeLog,v 1.334 2009/03/18 16:38:17 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/opera/ChangeLog,v 1.335 2009/03/20 19:42:42 jer Exp $
+
+ 20 Mar 2009; Jeroen Roovers <jer@gentoo.org> opera-9.27.ebuild,
+ opera-9.64.ebuild, opera-10.00_pre4205.ebuild, opera-10.00_pre4214.ebuild:
+ Define a dummy src_configure, thanks to Rafal Lalik for reporting (bug
+ #263010).
18 Mar 2009; Jeroen Roovers <jer@gentoo.org> -opera-10.00_pre4166.ebuild:
Remove old.
diff --git a/www-client/opera/opera-10.00_pre4205.ebuild b/www-client/opera/opera-10.00_pre4205.ebuild
index 2594953c3d0b..97044c7a78ee 100644
--- a/www-client/opera/opera-10.00_pre4205.ebuild
+++ b/www-client/opera/opera-10.00_pre4205.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/opera/opera-10.00_pre4205.ebuild,v 1.4 2009/03/19 17:41:57 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/opera/opera-10.00_pre4205.ebuild,v 1.5 2009/03/20 19:42:42 jer Exp $
EAPI="2"
@@ -141,9 +141,15 @@ src_unpack() {
}
+src_configure() {
+ # This workaround is sadly needed because gnome2.eclass doesn't check
+ # whether a configure script exists.
+ true
+}
+
src_compile() {
# This workaround is sadly needed because gnome2.eclass doesn't check
- # whether a configure script or Makefile exists.
+ # whether a Makefile exists.
true
}
diff --git a/www-client/opera/opera-10.00_pre4214.ebuild b/www-client/opera/opera-10.00_pre4214.ebuild
index b1aa0b7c8beb..592c529e6460 100644
--- a/www-client/opera/opera-10.00_pre4214.ebuild
+++ b/www-client/opera/opera-10.00_pre4214.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/opera/opera-10.00_pre4214.ebuild,v 1.2 2009/03/18 16:30:01 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/opera/opera-10.00_pre4214.ebuild,v 1.3 2009/03/20 19:42:42 jer Exp $
EAPI="2"
@@ -132,9 +132,15 @@ src_unpack() {
}
+src_configure() {
+ # This workaround is sadly needed because gnome2.eclass doesn't check
+ # whether a configure script exists.
+ true
+}
+
src_compile() {
# This workaround is sadly needed because gnome2.eclass doesn't check
- # whether a configure script or Makefile exists.
+ # whether a Makefile exists.
true
}
diff --git a/www-client/opera/opera-9.27.ebuild b/www-client/opera/opera-9.27.ebuild
index 5f450af5845c..4beaa0dcf82c 100644
--- a/www-client/opera/opera-9.27.ebuild
+++ b/www-client/opera/opera-9.27.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/opera/opera-9.27.ebuild,v 1.7 2008/06/17 15:27:43 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/opera/opera-9.27.ebuild,v 1.8 2009/03/20 19:42:42 jer Exp $
GCONF_DEBUG="no"
@@ -94,9 +94,15 @@ src_unpack() {
install.sh || die "sed failed"
}
+src_configure() {
+ # This workaround is sadly needed because gnome2.eclass doesn't check
+ # whether a configure script exists.
+ true
+}
+
src_compile() {
# This workaround is sadly needed because gnome2.eclass doesn't check
- # whether a configure script or Makefile exists.
+ # whether a Makefile exists.
true
}
diff --git a/www-client/opera/opera-9.64.ebuild b/www-client/opera/opera-9.64.ebuild
index 2db8d10a9a2f..273c1a0a9609 100644
--- a/www-client/opera/opera-9.64.ebuild
+++ b/www-client/opera/opera-9.64.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/opera/opera-9.64.ebuild,v 1.5 2009/03/18 16:30:01 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/opera/opera-9.64.ebuild,v 1.6 2009/03/20 19:42:42 jer Exp $
EAPI="2"
@@ -140,9 +140,15 @@ src_unpack() {
}
+src_configure() {
+ # This workaround is sadly needed because gnome2.eclass doesn't check
+ # whether a configure script exists.
+ true
+}
+
src_compile() {
# This workaround is sadly needed because gnome2.eclass doesn't check
- # whether a configure script or Makefile exists.
+ # whether a Makefile exists.
true
}