summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2009-11-12 17:38:31 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2009-11-12 17:38:31 +0000
commit3738a9026e6abca81d6927775105a9be3e3c30da (patch)
treee523ae71e4442ac200b3df73c28560fb1060af15 /www-client
parentAdding reference to bug #289081 to previous version bump (diff)
downloadgentoo-2-3738a9026e6abca81d6927775105a9be3e3c30da.tar.gz
gentoo-2-3738a9026e6abca81d6927775105a9be3e3c30da.tar.bz2
gentoo-2-3738a9026e6abca81d6927775105a9be3e3c30da.zip
Version bumped, bug #284181.
(Portage version: 2.1.7.4/cvs/Linux x86_64)
Diffstat (limited to 'www-client')
-rw-r--r--www-client/kazehakase/ChangeLog7
-rw-r--r--www-client/kazehakase/kazehakase-0.5.8.ebuild58
2 files changed, 64 insertions, 1 deletions
diff --git a/www-client/kazehakase/ChangeLog b/www-client/kazehakase/ChangeLog
index 0e86d47ee47b..269abb929498 100644
--- a/www-client/kazehakase/ChangeLog
+++ b/www-client/kazehakase/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for www-client/kazehakase
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/kazehakase/ChangeLog,v 1.76 2009/10/25 11:15:06 volkmar Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/kazehakase/ChangeLog,v 1.77 2009/11/12 17:38:31 matsuu Exp $
+
+*kazehakase-0.5.8 (12 Nov 2009)
+
+ 12 Nov 2009; MATSUU Takuto <matsuu@gentoo.org> +kazehakase-0.5.8.ebuild:
+ Version bumped, bug #284181.
25 Oct 2009; Mounir Lamouri <volkmar@gentoo.org> kazehakase-0.5.7.ebuild:
Stable for ppc, bug 275706
diff --git a/www-client/kazehakase/kazehakase-0.5.8.ebuild b/www-client/kazehakase/kazehakase-0.5.8.ebuild
new file mode 100644
index 000000000000..8852a4813330
--- /dev/null
+++ b/www-client/kazehakase/kazehakase-0.5.8.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-client/kazehakase/kazehakase-0.5.8.ebuild,v 1.1 2009/11/12 17:38:31 matsuu Exp $
+
+EAPI="2"
+inherit eutils flag-o-matic
+
+IUSE="hyperestraier migemo ruby ssl webkit"
+
+DESCRIPTION="a browser with gecko engine like Epiphany or Galeon."
+SRC_URI="mirror://sourceforge.jp/${PN}/43802/${P}.tar.gz"
+HOMEPAGE="http://kazehakase.sourceforge.jp/"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+LICENSE="GPL-2"
+
+DEPEND=">=x11-libs/gtk+-2.17.7
+ dev-libs/dbus-glib
+ net-libs/xulrunner:1.9
+ ssl? ( >=net-libs/gnutls-1.2.0 )
+ ruby? ( dev-ruby/ruby-gtk2 dev-ruby/ruby-gettext )
+ hyperestraier? ( >=app-text/hyperestraier-1.2 )
+ webkit? ( >=net-libs/webkit-gtk-1.1.1 )"
+# coverage? ( dev-python/coverage )
+# cutter? ( >=dev-libs/cutter-1.0.6 )
+
+RDEPEND="${DEPEND}
+ migemo? ( app-text/migemo )"
+
+DEPEND="${DEPEND}
+ dev-util/pkgconfig"
+
+src_configure() {
+ local myconf
+
+ # Bug 159949
+ replace-flags -Os -O2
+
+ use ruby || myconf="${myconf} --with-ruby=no --with-rgettext=no"
+ use ssl || myconf="${myconf} --disable-ssl"
+
+ # The "e" in heyper is not a mistake, it is a typo in the source package
+ econf \
+ --with-gecko-engine=libxul \
+ $(use_enable migemo) \
+ $(use_enable hyperestraier heyper-estraier) \
+ ${myconf} || die
+}
+
+src_compile() {
+ emake -j1 || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS ChangeLog NEWS README* TODO*
+}