summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaweł Hajdan <phajdan.jr@gentoo.org>2010-01-07 18:46:49 +0000
committerPaweł Hajdan <phajdan.jr@gentoo.org>2010-01-07 18:46:49 +0000
commit34a2fc4991e6c3fc1d5a42408cbe90f7418590bd (patch)
tree5aea726a1981f5af17778d72928164e200e9a1c6 /www-client
parentgive unpack support for tl2009 (diff)
downloadgentoo-2-34a2fc4991e6c3fc1d5a42408cbe90f7418590bd.tar.gz
gentoo-2-34a2fc4991e6c3fc1d5a42408cbe90f7418590bd.tar.bz2
gentoo-2-34a2fc4991e6c3fc1d5a42408cbe90f7418590bd.zip
Drop the libevent patch for the live (9999) ebuild, as it landed upstream.
Remove the old version of the patch and the ebuild that used it. (Portage version: 2.1.6.13/cvs/Linux i686)
Diffstat (limited to 'www-client')
-rw-r--r--www-client/chromium/ChangeLog8
-rw-r--r--www-client/chromium/chromium-4.0.251.0.ebuild139
-rw-r--r--www-client/chromium/chromium-9999.ebuild4
-rw-r--r--www-client/chromium/files/chromium-use_system_libevent.patch203
4 files changed, 8 insertions, 346 deletions
diff --git a/www-client/chromium/ChangeLog b/www-client/chromium/ChangeLog
index c242f3ff78ae..8961eebcb495 100644
--- a/www-client/chromium/ChangeLog
+++ b/www-client/chromium/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for www-client/chromium
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/chromium/ChangeLog,v 1.35 2010/01/07 16:30:07 phajdan.jr Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/chromium/ChangeLog,v 1.36 2010/01/07 18:46:48 phajdan.jr Exp $
+
+ 07 Jan 2010; Pawel Hajdan jr <phajdan.jr@gentoo.org>
+ -chromium-4.0.251.0.ebuild, chromium-9999.ebuild,
+ -files/chromium-use_system_libevent.patch:
+ Drop the libevent patch for the live (9999) ebuild, as it landed upstream.
+ Remove the old version of the patch and the ebuild that used it.
*chromium-4.0.288.1 (07 Jan 2010)
diff --git a/www-client/chromium/chromium-4.0.251.0.ebuild b/www-client/chromium/chromium-4.0.251.0.ebuild
deleted file mode 100644
index abf80f1ce7ad..000000000000
--- a/www-client/chromium/chromium-4.0.251.0.ebuild
+++ /dev/null
@@ -1,139 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/chromium/chromium-4.0.251.0.ebuild,v 1.5 2009/12/22 20:51:11 phajdan.jr Exp $
-
-EAPI="2"
-inherit eutils multilib toolchain-funcs
-
-DESCRIPTION="Open-source version of Google Chrome web browser"
-HOMEPAGE="http://chromium.org/"
-#SRC_URI="http://build.chromium.org/buildbot/archives/${P}.tar.bz2"
-SRC_URI="mirror://gentoo/${P}.tar.bz2"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="+ffmpeg"
-
-RDEPEND="app-arch/bzip2
- >=dev-libs/libevent-1.4.13
- dev-libs/libxml2
- dev-libs/libxslt
- >=dev-libs/nss-3.12.2
- >=gnome-base/gconf-2.24.0
- media-fonts/corefonts
- >=media-libs/alsa-lib-1.0.19
- media-libs/jpeg
- media-libs/libpng
- ffmpeg? ( >=media-video/ffmpeg-0.5_p19787 )
- sys-libs/zlib
- >=x11-libs/gtk+-2.14.7
- || (
- x11-themes/gnome-icon-theme
- x11-themes/tango-icon-theme
- x11-themes/xfce4-icon-theme
- )"
-# dev-db/sqlite:3
-DEPEND="${RDEPEND}
- >=dev-util/gperf-3.0.3
- >=dev-util/pkgconfig-0.23"
-
-export CHROMIUM_HOME=/usr/$(get_libdir)/chromium-browser
-
-src_prepare() {
- # Gentoo uses .kde4, not .kde
- sed -e 's/\.kde/.kde4/' -i net/proxy/proxy_config_service_linux.cc \
- || die "kde proxy sed failed"
- # Changing this in ~/include.gypi does not work
- sed -i "s/'-Werror'/''/" build/common.gypi || die "Werror sed failed"
- # Prevent automatic -march=pentium4 -msse2 enabling on x86, http://crbug.com/9007
- epatch "${FILESDIR}"/${PN}-drop_sse2.patch
- # Add configuration flag to use system libevent
- epatch "${FILESDIR}"/${PN}-use_system_libevent.patch
-
- # Disable prefixing to allow linking against system zlib
- sed -e '/^#include "mozzconf.h"$/d' \
- -i third_party/{,WebKit/WebCore/platform/image-decoders}/zlib/zconf.h \
- || die "zlib sed failed"
-}
-
-src_configure() {
- # CFLAGS/LDFLAGS
- mkdir -p "${S}"/.gyp
- cat << EOF > "${S}"/.gyp/include.gypi
-{
- 'target_defaults': {
- 'cflags': [ '${CFLAGS// /','}' ],
- 'ldflags': [ '${LDFLAGS// /','}' ],
- },
-}
-EOF
- export HOME="${S}"
-
- # Configuration options (system libraries)
- local myconf="-Duse_system_zlib=1 -Duse_system_bzip2=1 -Duse_system_libevent=1 -Duse_system_libjpeg=1 -Duse_system_libpng=1 -Duse_system_libxml=1 -Duse_system_libxslt=1 -Duse_system_ffmpeg=1"
- # -Duse_system_sqlite=1 : http://crbug.com/22208
- # Others still bundled: icu (not possible?), hunspell (changes required for sandbox support)
-
- # Sandbox paths
- myconf="${myconf} -Dlinux_sandbox_path=${CHROMIUM_HOME}/chrome_sandbox -Dlinux_sandbox_chrome_path=${CHROMIUM_HOME}/chrome"
-
- if use amd64; then
- myconf="${myconf} -Dtarget_arch=x64"
- fi
- if [[ "$(gcc-major-version)$(gcc-minor-version)" == "44" ]]; then
- myconf="${myconf} -Dno_strict_aliasing=1 -Dgcc_version=44"
- fi
-
- build/gyp_chromium -f make build/all.gyp ${myconf} --depth=. || die "gyp failed"
-}
-
-src_compile() {
- emake -r V=1 chrome chrome_sandbox BUILDTYPE=Release \
- rootdir="${S}" \
- CC=$(tc-getCC) \
- CXX=$(tc-getCXX) \
- AR=$(tc-getAR) \
- RANLIB=$(tc-getRANLIB) \
- || die "compilation failed"
-}
-
-src_install() {
- # Chromium does not have "install" target in the build system.
-
- dodir ${CHROMIUM_HOME}
-
- exeinto ${CHROMIUM_HOME}
- doexe out/Release/chrome
- doexe out/Release/chrome_sandbox
- fperms 4755 ${CHROMIUM_HOME}/chrome_sandbox
- doexe out/Release/xdg-settings
- doexe "${FILESDIR}"/chromium-launcher.sh
-
- insinto ${CHROMIUM_HOME}
- doins out/Release/chrome.pak
-
- doins -r out/Release/locales
- doins -r out/Release/resources
-
- # chrome.1 is for chromium --help
- newman out/Release/chromium-browser.1 chrome.1
- newman out/Release/chromium-browser.1 chromium.1
-
- if use ffmpeg; then
- # Chromium looks for these in its folder
- # See media_posix.cc and base_paths_linux.cc
- dosym /usr/$(get_libdir)/libavcodec.so.52 ${CHROMIUM_HOME}
- dosym /usr/$(get_libdir)/libavformat.so.52 ${CHROMIUM_HOME}
- dosym /usr/$(get_libdir)/libavutil.so.50 ${CHROMIUM_HOME}
- fi
-
- # Plugins symlink
- dosym /usr/$(get_libdir)/nsbrowser/plugins ${CHROMIUM_HOME}/plugins
-
- newicon out/Release/product_logo_48.png ${PN}-browser.png
- dosym ${CHROMIUM_HOME}/chromium-launcher.sh /usr/bin/chromium
- make_desktop_entry chromium "Chromium" ${PN}-browser "Network;WebBrowser"
- sed -e "/^Exec/s/$/ %U/" -i "${D}"/usr/share/applications/*.desktop \
- || die "desktop file sed failed"
-}
diff --git a/www-client/chromium/chromium-9999.ebuild b/www-client/chromium/chromium-9999.ebuild
index c76851d89632..cea59ddbb8fc 100644
--- a/www-client/chromium/chromium-9999.ebuild
+++ b/www-client/chromium/chromium-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/chromium/chromium-9999.ebuild,v 1.15 2010/01/07 16:01:23 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/chromium/chromium-9999.ebuild,v 1.16 2010/01/07 18:46:48 phajdan.jr Exp $
EAPI="2"
inherit eutils multilib toolchain-funcs subversion
@@ -90,8 +90,6 @@ src_prepare() {
sed -i "s/'-Werror'/''/" build/common.gypi || die "Werror sed failed"
# Prevent automatic -march=pentium4 -msse2 enabling on x86, http://crbug.com/9007
epatch "${FILESDIR}"/${PN}-drop_sse2.patch
- # Add configuration flag to use system libevent
- epatch "${FILESDIR}"/${PN}-use_system_libevent-1.4.13.patch
# Fix native build on ARM, http://crbug.com/31274
epatch "${FILESDIR}"/${PN}-drop_armel_m32.patch
diff --git a/www-client/chromium/files/chromium-use_system_libevent.patch b/www-client/chromium/files/chromium-use_system_libevent.patch
deleted file mode 100644
index 60d431c95564..000000000000
--- a/www-client/chromium/files/chromium-use_system_libevent.patch
+++ /dev/null
@@ -1,203 +0,0 @@
-diff -Naur chromium-4.0.212.0_p26343.orig/base/message_pump_libevent.cc chromium-4.0.212.0_p26343/base/message_pump_libevent.cc
---- chromium-4.0.212.0_p26343.orig/base/message_pump_libevent.cc 2009-09-17 17:06:50.000000000 +0200
-+++ chromium-4.0.212.0_p26343/base/message_pump_libevent.cc 2009-09-17 17:11:01.000000000 +0200
-@@ -12,7 +12,11 @@
- #include "base/scoped_nsautorelease_pool.h"
- #include "base/scoped_ptr.h"
- #include "base/time.h"
-+#if defined(USE_SYSTEM_LIBEVENT)
-+#include <event.h>
-+#else
- #include "third_party/libevent/event.h"
-+#endif
-
- // Lifecycle of struct event
- // Libevent uses two main data structures:
-diff -Naur chromium-4.0.212.0_p26343.orig/chrome/browser/debugger/devtools_remote_listen_socket.cc chromium-4.0.212.0_p26343/chrome/browser/debugger/devtools_remote_listen_socket.cc
---- chromium-4.0.212.0_p26343.orig/chrome/browser/debugger/devtools_remote_listen_socket.cc 2009-09-17 17:06:51.000000000 +0200
-+++ chromium-4.0.212.0_p26343/chrome/browser/debugger/devtools_remote_listen_socket.cc 2009-09-17 17:10:49.000000000 +0200
-@@ -18,8 +18,12 @@
- #include "base/message_loop.h"
- #include "base/message_pump_libevent.h"
- #include "net/base/net_errors.h"
-+#if defined(USE_SYSTEM_LIBEVENT)
-+#include <event.h>
-+#else
- #include "third_party/libevent/event.h"
- #endif
-+#endif
-
- #include "base/eintr_wrapper.h"
- #include "base/platform_thread.h"
-diff -Naur chromium-4.0.212.0_p26343.orig/net/base/listen_socket.cc chromium-4.0.212.0_p26343/net/base/listen_socket.cc
---- chromium-4.0.212.0_p26343.orig/net/base/listen_socket.cc 2009-09-17 17:06:23.000000000 +0200
-+++ chromium-4.0.212.0_p26343/net/base/listen_socket.cc 2009-09-17 17:10:12.000000000 +0200
-@@ -13,8 +13,12 @@
- #include <sys/socket.h>
- #include <arpa/inet.h>
- #include "net/base/net_errors.h"
-+#if defined(USE_SYSTEM_LIBEVENT)
-+#include <event.h>
-+#else
- #include "third_party/libevent/event.h"
- #endif
-+#endif
-
- #include "base/eintr_wrapper.h"
- #include "net/base/net_util.h"
-diff -Naur chromium-4.0.212.0_p26343.orig/net/base/telnet_server.cc chromium-4.0.212.0_p26343/net/base/telnet_server.cc
---- chromium-4.0.212.0_p26343.orig/net/base/telnet_server.cc 2009-09-17 17:06:23.000000000 +0200
-+++ chromium-4.0.212.0_p26343/net/base/telnet_server.cc 2009-09-17 17:10:06.000000000 +0200
-@@ -13,7 +13,11 @@
- #include <sys/socket.h>
- #include "base/message_loop.h"
- #include "net/base/net_errors.h"
-+#if defined(USE_SYSTEM_LIBEVENT)
-+#include <event.h>
-+#else
- #include "third_party/libevent/event.h"
-+#endif
- #include "base/message_pump_libevent.h"
- #endif
-
-diff -Naur chromium-4.0.212.0_p26343.orig/net/socket/tcp_client_socket_libevent.cc chromium-4.0.212.0_p26343/net/socket/tcp_client_socket_libevent.cc
---- chromium-4.0.212.0_p26343.orig/net/socket/tcp_client_socket_libevent.cc 2009-09-17 17:06:23.000000000 +0200
-+++ chromium-4.0.212.0_p26343/net/socket/tcp_client_socket_libevent.cc 2009-09-17 17:09:49.000000000 +0200
-@@ -15,8 +15,11 @@
- #include "base/trace_event.h"
- #include "net/base/io_buffer.h"
- #include "net/base/net_errors.h"
-+#if defined(USE_SYSTEM_LIBEVENT)
-+#include <event.h>
-+#else
- #include "third_party/libevent/event.h"
--
-+#endif
-
- namespace net {
-
-diff -Naur chromium-4.0.212.0_p26343.orig/third_party/libevent/libevent.gyp chromium-4.0.212.0_p26343/third_party/libevent/libevent.gyp
---- chromium-4.0.212.0_p26343.orig/third_party/libevent/libevent.gyp 2009-09-17 17:06:23.000000000 +0200
-+++ chromium-4.0.212.0_p26343/third_party/libevent/libevent.gyp 2009-09-17 17:00:06.000000000 +0200
-@@ -3,52 +3,76 @@
- # found in the LICENSE file.
-
- {
-- 'targets': [
-- {
-- 'target_name': 'libevent',
-- 'product_name': 'event',
-- 'type': '<(library)',
-- 'sources': [
-- 'buffer.c',
-- 'evbuffer.c',
-- 'evdns.c',
-- 'event.c',
-- 'event_tagging.c',
-- 'evrpc.c',
-- 'evutil.c',
-- 'http.c',
-- 'log.c',
-- 'poll.c',
-- 'select.c',
-- 'signal.c',
-- 'strlcpy.c',
-+ 'variables': {
-+ 'use_system_libevent%': 0,
-+ },
-+ 'conditions': [
-+ ['use_system_libevent==0', {
-+ 'targets': [
-+ {
-+ 'target_name': 'libevent',
-+ 'product_name': 'event',
-+ 'type': '<(library)',
-+ 'sources': [
-+ 'buffer.c',
-+ 'evbuffer.c',
-+ 'evdns.c',
-+ 'event.c',
-+ 'event_tagging.c',
-+ 'evrpc.c',
-+ 'evutil.c',
-+ 'http.c',
-+ 'log.c',
-+ 'poll.c',
-+ 'select.c',
-+ 'signal.c',
-+ 'strlcpy.c',
-+ ],
-+ 'defines': [
-+ 'HAVE_CONFIG_H',
-+ ],
-+ 'include_dirs': [
-+ '.', # libevent includes some of its own headers with #include <...>
-+ # instead of #include "..."
-+ ],
-+ 'conditions': [
-+ # libevent has platform-specific implementation files. Since its
-+ # native build uses autoconf, platform-specific config.h files are
-+ # provided and live in platform-specific directories.
-+ [ 'OS == "linux"', {
-+ 'sources': [ 'epoll.c', 'epoll_sub.c' ],
-+ 'include_dirs': [ 'linux' ],
-+ 'link_settings':
-+ { 'libraries': [
-+ # We need rt for clock_gettime().
-+ # TODO(port) Maybe on FreeBSD as well?
-+ '-lrt',
-+ ],
-+ },
-+ }
-+ ],
-+ [ 'OS == "mac" or OS == "freebsd"', { 'sources': [ 'kqueue.c' ],
-+ 'include_dirs': [ 'mac' ] } ],
-+ ],
-+ },
- ],
-- 'defines': [
-- 'HAVE_CONFIG_H',
-+ }, {
-+ 'targets': [
-+ {
-+ 'target_name': 'libevent',
-+ 'type': 'settings',
-+ 'direct_dependent_settings': {
-+ 'defines': [
-+ 'USE_SYSTEM_LIBEVENT',
-+ ],
-+ },
-+ 'link_settings': {
-+ 'libraries': [
-+ '-levent',
-+ ],
-+ },
-+ }
- ],
-- 'include_dirs': [
-- '.', # libevent includes some of its own headers with #include <...>
-- # instead of #include "..."
-- ],
-- 'conditions': [
-- # libevent has platform-specific implementation files. Since its
-- # native build uses autoconf, platform-specific config.h files are
-- # provided and live in platform-specific directories.
-- [ 'OS == "linux"', {
-- 'sources': [ 'epoll.c', 'epoll_sub.c' ],
-- 'include_dirs': [ 'linux' ],
-- 'link_settings':
-- { 'libraries': [
-- # We need rt for clock_gettime().
-- # TODO(port) Maybe on FreeBSD as well?
-- '-lrt',
-- ],
-- },
-- }
-- ],
-- [ 'OS == "mac" or OS == "freebsd"', { 'sources': [ 'kqueue.c' ],
-- 'include_dirs': [ 'mac' ] } ],
-- ],
-- },
-+ }],
- ],
- }