summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2007-08-24 15:43:15 +0000
committerMart Raudsepp <leio@gentoo.org>2007-08-24 15:43:15 +0000
commit1de25ece68511f9b5f54ae4952cfe3742e366e0d (patch)
tree4a031129831d287f98053a0f79c16eb34b1b4b05 /www-client
parentinitial ebuild (diff)
downloadgentoo-2-1de25ece68511f9b5f54ae4952cfe3742e366e0d.tar.gz
gentoo-2-1de25ece68511f9b5f54ae4952cfe3742e366e0d.tar.bz2
gentoo-2-1de25ece68511f9b5f54ae4952cfe3742e366e0d.zip
Version bump. ~arch echangelog sucks hard, so I'm not going to repeat the details here, see the _hand-edited_ ChangeLog instead
(Portage version: 2.1.3.6)
Diffstat (limited to 'www-client')
-rw-r--r--www-client/epiphany/ChangeLog11
-rw-r--r--www-client/epiphany/epiphany-2.18.3.ebuild85
-rw-r--r--www-client/epiphany/files/digest-epiphany-2.18.33
3 files changed, 98 insertions, 1 deletions
diff --git a/www-client/epiphany/ChangeLog b/www-client/epiphany/ChangeLog
index 3a84049902e7..ea4541921642 100644
--- a/www-client/epiphany/ChangeLog
+++ b/www-client/epiphany/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for www-client/epiphany
# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/epiphany/ChangeLog,v 1.123 2007/08/11 16:45:49 leio Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/epiphany/ChangeLog,v 1.124 2007/08/24 15:43:15 leio Exp $
+
+*epiphany-2.18.3 (24 Aug 2007)
+
+ 24 Aug 2007; Mart Raudsepp <leio@gentoo.org> +epiphany-2.18.3.ebuild:
+ Version bump to 2.18.3. This includes the following upstream fixes:
+ * Make User-Agent Firefox compatible with USE=xulrunner too
+ * Cancel already progressing print jobs properly
+ * Fix go button behaviour to open the link in a new tab on middle button
+ release, not press
11 Aug 2007; Mart Raudsepp <leio@gentoo.org> -epiphany-2.14.2.1-r1.ebuild,
-epiphany-2.14.3.ebuild, -epiphany-2.18.1.ebuild:
diff --git a/www-client/epiphany/epiphany-2.18.3.ebuild b/www-client/epiphany/epiphany-2.18.3.ebuild
new file mode 100644
index 000000000000..77cc770cf12b
--- /dev/null
+++ b/www-client/epiphany/epiphany-2.18.3.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-client/epiphany/epiphany-2.18.3.ebuild,v 1.1 2007/08/24 15:43:15 leio Exp $
+
+WANT_AUTOMAKE=1.9
+inherit eutils gnome2 multilib autotools
+
+DESCRIPTION="GNOME webbrowser based on the mozilla rendering engine"
+HOMEPAGE="http://www.gnome.org/projects/epiphany/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="doc python xulrunner spell"
+
+RDEPEND=">=dev-libs/glib-2.12
+ >=x11-libs/gtk+-2.10
+ >=dev-libs/libxml2-2.6.12
+ >=dev-libs/libxslt-1.1.7
+ >=gnome-base/libglade-2.3.1
+ >=gnome-base/gnome-vfs-2.9.2
+ >=gnome-base/libgnome-2.14
+ >=gnome-base/libgnomeui-2.14
+ >=gnome-base/gnome-desktop-2.9.91
+ >=x11-libs/startup-notification-0.5
+ >=dev-libs/dbus-glib-0.71
+ >=gnome-base/gconf-2
+ >=app-text/iso-codes-0.35
+ !xulrunner? ( >=www-client/mozilla-firefox-1.5 )
+ xulrunner? ( net-libs/xulrunner )
+ python? (
+ >=dev-lang/python-2.3
+ >=dev-python/pygtk-2.7.1
+ >=dev-python/gnome-python-2.6 )
+ spell? ( app-text/enchant )
+ x11-themes/gnome-icon-theme"
+
+DEPEND="${RDEPEND}
+ app-text/scrollkeeper
+ >=dev-util/pkgconfig-0.9
+ >=dev-util/intltool-0.35
+ >=app-text/gnome-doc-utils-0.3.2
+ >=gnome-base/gnome-common-2.12.0
+ doc? ( >=dev-util/gtk-doc-1 )"
+
+DOCS="AUTHORS ChangeLog* HACKING MAINTAINERS NEWS README TODO"
+
+pkg_setup() {
+ G2CONF="--disable-scrollkeeper \
+ $(use_enable spell spell-checker)
+ $(use_enable python)"
+
+ if use xulrunner; then
+ G2CONF="${G2CONF} --with-gecko=xulrunner"
+ else
+ G2CONF="${G2CONF} --with-gecko=firefox"
+ fi
+}
+
+src_unpack() {
+ gnome2_src_unpack
+
+ # This is for honoring LINGUAS env vars.
+ # Remove this once upstream starts using intltool-0.35.5 for making tarballs:
+ intltoolize --force || die
+
+ # Fix tests
+ echo "data/bme.desktop.in" >> ${S}/po/POTFILES.skip
+ echo "data/epiphany.desktop.in" >> ${S}/po/POTFILES.skip
+}
+
+src_compile() {
+ addpredict /usr/$(get_libdir)/mozilla-firefox/components/xpti.dat
+ addpredict /usr/$(get_libdir)/mozilla-firefox/components/xpti.dat.tmp
+ addpredict /usr/$(get_libdir)/mozilla-firefox/components/compreg.dat.tmp
+
+ addpredict /usr/$(get_libdir)/xulrunner/components/xpti.dat
+ addpredict /usr/$(get_libdir)/xulrunner/components/xpti.dat.tmp
+ addpredict /usr/$(get_libdir)/xulrunner/components/compreg.dat.tmp
+
+ addpredict /usr/$(get_libdir)/mozilla/components/xpti.dat
+ addpredict /usr/$(get_libdir)/mozilla/components/xpti.dat.tmp
+
+ gnome2_src_compile
+}
diff --git a/www-client/epiphany/files/digest-epiphany-2.18.3 b/www-client/epiphany/files/digest-epiphany-2.18.3
new file mode 100644
index 000000000000..cf55727ccf45
--- /dev/null
+++ b/www-client/epiphany/files/digest-epiphany-2.18.3
@@ -0,0 +1,3 @@
+MD5 2e77f3f0651a27cac29224e82c3cc793 epiphany-2.18.3.tar.bz2 4772883
+RMD160 3d18c44fabd8d94a941239a9a13802666a869eaf epiphany-2.18.3.tar.bz2 4772883
+SHA256 ccceb15371782b2cfed2f7e4c078336dd20a0d864d9c1e31b28518aa5a25e6de epiphany-2.18.3.tar.bz2 4772883