summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaweł Hajdan <phajdan.jr@gentoo.org>2013-05-25 00:13:09 +0000
committerPaweł Hajdan <phajdan.jr@gentoo.org>2013-05-25 00:13:09 +0000
commit15d8ec214db0da3f34c9fd22b1a53bb0540b6e04 (patch)
treee2ce07578595aa1e3f63f6a3279e82d211309746 /www-client
parentold revsions removed. (diff)
downloadgentoo-2-15d8ec214db0da3f34c9fd22b1a53bb0540b6e04.tar.gz
gentoo-2-15d8ec214db0da3f34c9fd22b1a53bb0540b6e04.tar.bz2
gentoo-2-15d8ec214db0da3f34c9fd22b1a53bb0540b6e04.zip
Dev channel bump. Switch from make-based to ninja-based build. Fix bug #469144 by Alphat-PC.
(Portage version: 2.1.11.62/cvs/Linux i686, signed Manifest commit with key 30427902)
Diffstat (limited to 'www-client')
-rw-r--r--www-client/chromium/ChangeLog10
-rw-r--r--www-client/chromium/chromium-29.0.1516.3.ebuild545
-rw-r--r--www-client/chromium/chromium-9999-r1.ebuild40
-rw-r--r--www-client/chromium/files/chromium-system-ffmpeg-r6.patch136
4 files changed, 714 insertions, 17 deletions
diff --git a/www-client/chromium/ChangeLog b/www-client/chromium/ChangeLog
index 769bd7e8e899..c3faaf39a984 100644
--- a/www-client/chromium/ChangeLog
+++ b/www-client/chromium/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for www-client/chromium
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/chromium/ChangeLog,v 1.887 2013/05/24 18:27:24 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/chromium/ChangeLog,v 1.888 2013/05/25 00:13:09 phajdan.jr Exp $
+
+*chromium-29.0.1516.3 (25 May 2013)
+
+ 25 May 2013; Pawel Hajdan jr <phajdan.jr@gentoo.org>
+ +files/chromium-system-ffmpeg-r6.patch, +chromium-29.0.1516.3.ebuild,
+ chromium-9999-r1.ebuild:
+ Dev channel bump. Switch from make-based to ninja-based build. Fix bug
+ #469144 by Alphat-PC.
24 May 2013; Agostino Sarubbo <ago@gentoo.org> -chromium-26.0.1410.43.ebuild,
-chromium-26.0.1410.63.ebuild, -chromium-27.0.1453.81.ebuild:
diff --git a/www-client/chromium/chromium-29.0.1516.3.ebuild b/www-client/chromium/chromium-29.0.1516.3.ebuild
new file mode 100644
index 000000000000..6294d45f97d8
--- /dev/null
+++ b/www-client/chromium/chromium-29.0.1516.3.ebuild
@@ -0,0 +1,545 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-client/chromium/chromium-29.0.1516.3.ebuild,v 1.1 2013/05/25 00:13:09 phajdan.jr Exp $
+
+EAPI="5"
+PYTHON_COMPAT=( python{2_6,2_7} )
+
+CHROMIUM_LANGS="am ar bg bn ca cs da de el en_GB es es_LA et fa fi fil fr gu he
+ hi hr hu id it ja kn ko lt lv ml mr ms nb nl pl pt_BR pt_PT ro ru sk sl sr
+ sv sw ta te th tr uk vi zh_CN zh_TW"
+
+inherit chromium eutils flag-o-matic multilib multiprocessing \
+ pax-utils portability python-any-r1 toolchain-funcs versionator virtualx
+
+DESCRIPTION="Open-source version of Google Chrome web browser"
+HOMEPAGE="http://chromium.org/"
+SRC_URI="https://commondatastorage.googleapis.com/chromium-browser-official/${P}-lite.tar.xz
+ test? ( https://commondatastorage.googleapis.com/chromium-browser-official/${P}-testdata.tar.xz )"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="bindist cups gnome gnome-keyring gps kerberos pulseaudio selinux +system-ffmpeg system-sqlite tcmalloc"
+
+# Native Client binaries are compiled with different set of flags, bug #452066.
+QA_FLAGS_IGNORED=".*\.nexe"
+
+# Native Client binaries may be stripped by the build system, which uses the
+# right tools for it, bug #469144 .
+QA_PRESTRIPPED=".*\.nexe"
+
+RDEPEND=">=app-accessibility/speech-dispatcher-0.8:=
+ app-arch/bzip2:=
+ app-arch/snappy:=
+ system-sqlite? ( dev-db/sqlite:3 )
+ cups? (
+ dev-libs/libgcrypt:=
+ >=net-print/cups-1.3.11:=
+ )
+ >=dev-lang/v8-3.17.6:=
+ =dev-lang/v8-3.19*
+ >=dev-libs/elfutils-0.149
+ dev-libs/expat:=
+ >=dev-libs/icu-49.1.1-r1:=
+ >=dev-libs/jsoncpp-0.5.0-r1:=
+ >=dev-libs/libevent-1.4.13:=
+ dev-libs/libxml2:=[icu]
+ dev-libs/libxslt:=
+ dev-libs/nspr:=
+ >=dev-libs/nss-3.12.3:=
+ dev-libs/protobuf:=
+ dev-libs/re2:=
+ gnome? ( >=gnome-base/gconf-2.24.0:= )
+ gnome-keyring? ( >=gnome-base/gnome-keyring-2.28.2:= )
+ gps? ( >=sci-geosciences/gpsd-3.7:=[shm] )
+ >=media-libs/alsa-lib-1.0.19:=
+ media-libs/flac:=
+ media-libs/harfbuzz:=
+ >=media-libs/libjpeg-turbo-1.2.0-r1:=
+ media-libs/libpng:0=
+ media-libs/libvpx:=
+ >=media-libs/libwebp-0.2.0_rc1:=
+ !arm? ( !x86? ( >=media-libs/mesa-9.1:=[gles2] ) )
+ media-libs/opus:=
+ media-libs/speex:=
+ pulseaudio? ( media-sound/pulseaudio:= )
+ system-ffmpeg? ( || (
+ >=media-video/ffmpeg-1.0:=[opus]
+ >=media-video/libav-9.5:=[opus]
+ ) )
+ sys-apps/dbus:=
+ sys-apps/pciutils:=
+ sys-libs/zlib:=[minizip]
+ virtual/udev
+ virtual/libusb:1=
+ x11-libs/gtk+:2=
+ x11-libs/libXinerama:=
+ x11-libs/libXScrnSaver:=
+ x11-libs/libXtst:=
+ kerberos? ( virtual/krb5 )
+ selinux? ( sec-policy/selinux-chromium )"
+DEPEND="${RDEPEND}
+ ${PYTHON_DEPS}
+ !arm? (
+ >=dev-lang/nacl-toolchain-newlib-0_p9093
+ dev-lang/yasm
+ )
+ dev-lang/perl
+ dev-python/jinja
+ dev-python/ply
+ dev-python/simplejson
+ >=dev-util/gperf-3.0.3
+ dev-util/ninja
+ sys-apps/hwids
+ >=sys-devel/bison-2.4.3
+ sys-devel/flex
+ virtual/pkgconfig
+ test? ( dev-python/pyftpdlib )"
+RDEPEND+="
+ !=www-client/chromium-9999
+ x11-misc/xdg-utils
+ virtual/ttf-fonts"
+
+if ! has chromium_pkg_die ${EBUILD_DEATH_HOOKS}; then
+ EBUILD_DEATH_HOOKS+=" chromium_pkg_die";
+fi
+
+pkg_setup() {
+ if [[ "${SLOT}" == "0" ]]; then
+ CHROMIUM_SUFFIX=""
+ else
+ CHROMIUM_SUFFIX="-${SLOT}"
+ fi
+ CHROMIUM_HOME="/usr/$(get_libdir)/chromium-browser${CHROMIUM_SUFFIX}"
+
+ # Make sure the build system will use the right python, bug #344367.
+ python-any-r1_pkg_setup
+
+ chromium_suid_sandbox_check_kernel_config
+
+ if use bindist && ! use system-ffmpeg; then
+ elog "bindist enabled: H.264 video support will be disabled."
+ fi
+ if ! use bindist; then
+ elog "bindist disabled: Resulting binaries may not be legal to re-distribute."
+ fi
+}
+
+src_prepare() {
+ if ! use arm; then
+ mkdir -p out/Release/gen/sdk/toolchain || die
+ # Do not preserve SELinux context, bug #460892 .
+ cp -a --no-preserve=context /usr/$(get_libdir)/nacl-toolchain-newlib \
+ out/Release/gen/sdk/toolchain/linux_x86_newlib || die
+ touch out/Release/gen/sdk/toolchain/linux_x86_newlib/stamp.untar || die
+ fi
+
+ epatch "${FILESDIR}/${PN}-gpsd-r0.patch"
+ epatch "${FILESDIR}/${PN}-system-ffmpeg-r6.patch"
+
+ epatch_user
+
+ # Remove most bundled libraries. Some are still needed.
+ find third_party -type f \! -iname '*.gyp*' \
+ \! -path 'third_party/WebKit/*' \
+ \! -path 'third_party/angle/*' \
+ \! -path 'third_party/cacheinvalidation/*' \
+ \! -path 'third_party/cld/*' \
+ \! -path 'third_party/cros_system_api/*' \
+ \! -path 'third_party/ffmpeg/*' \
+ \! -path 'third_party/flot/*' \
+ \! -path 'third_party/hunspell/*' \
+ \! -path 'third_party/hyphen/*' \
+ \! -path 'third_party/iccjpeg/*' \
+ \! -path 'third_party/jstemplate/*' \
+ \! -path 'third_party/khronos/*' \
+ \! -path 'third_party/leveldatabase/*' \
+ \! -path 'third_party/libjingle/*' \
+ \! -path 'third_party/libphonenumber/*' \
+ \! -path 'third_party/libsrtp/*' \
+ \! -path 'third_party/libxml/chromium/*' \
+ \! -path 'third_party/libXNVCtrl/*' \
+ \! -path 'third_party/libyuv/*' \
+ \! -path 'third_party/lss/*' \
+ \! -path 'third_party/mesa/*' \
+ \! -path 'third_party/modp_b64/*' \
+ \! -path 'third_party/mongoose/*' \
+ \! -path 'third_party/mt19937ar/*' \
+ \! -path 'third_party/npapi/*' \
+ \! -path 'third_party/openmax/*' \
+ \! -path 'third_party/ots/*' \
+ \! -path 'third_party/pywebsocket/*' \
+ \! -path 'third_party/qcms/*' \
+ \! -path 'third_party/sfntly/*' \
+ \! -path 'third_party/skia/*' \
+ \! -path 'third_party/smhasher/*' \
+ \! -path 'third_party/sqlite/*' \
+ \! -path 'third_party/tcmalloc/*' \
+ \! -path 'third_party/tlslite/*' \
+ \! -path 'third_party/trace-viewer/*' \
+ \! -path 'third_party/undoview/*' \
+ \! -path 'third_party/v8-i18n/*' \
+ \! -path 'third_party/webdriver/*' \
+ \! -path 'third_party/webrtc/*' \
+ \! -path 'third_party/widevine/*' \
+ \! -path 'third_party/x86inc/*' \
+ \! -path 'third_party/zlib/google/*' \
+ -delete || die
+
+ # Remove bundled v8.
+ find v8 -type f \! -iname '*.gyp*' -delete || die
+}
+
+src_configure() {
+ local myconf=""
+
+ # Never tell the build system to "enable" SSE2, it has a few unexpected
+ # additions, bug #336871.
+ myconf+=" -Ddisable_sse2=1"
+
+ # Optional tcmalloc. Note it causes problems with e.g. NVIDIA
+ # drivers, bug #413637.
+ myconf+=" $(gyp_use tcmalloc linux_use_tcmalloc)"
+
+ # Disable glibc Native Client toolchain, we don't need it (bug #417019).
+ myconf+=" -Ddisable_glibc=1"
+
+ # TODO: also build with pnacl
+ myconf+=" -Ddisable_pnacl=1"
+
+ # It would be awkward for us to tar the toolchain and get it untarred again
+ # during the build.
+ myconf+=" -Ddisable_newlib_untar=1"
+
+ # Make it possible to remove third_party/adobe.
+ echo > "${T}/flapper_version.h" || die
+ myconf+=" -Dflapper_version_h_file=${T}/flapper_version.h"
+
+ # Use system-provided libraries.
+ # TODO: use_system_hunspell (upstream changes needed).
+ # TODO: use_system_libsrtp (bug #459932).
+ # TODO: use_system_ssl (http://crbug.com/58087).
+ # TODO: use_system_sqlite (http://crbug.com/22208).
+ myconf+="
+ -Duse_system_bzip2=1
+ -Duse_system_flac=1
+ -Duse_system_harfbuzz=1
+ -Duse_system_icu=1
+ -Duse_system_jsoncpp=1
+ -Duse_system_libevent=1
+ -Duse_system_libjpeg=1
+ -Duse_system_libpng=1
+ -Duse_system_libusb=1
+ -Duse_system_libvpx=1
+ -Duse_system_libwebp=1
+ -Duse_system_libxml=1
+ -Duse_system_libxslt=1
+ -Duse_system_minizip=1
+ -Duse_system_nspr=1
+ -Duse_system_opus=1
+ -Duse_system_protobuf=1
+ -Duse_system_re2=1
+ -Duse_system_snappy=1
+ -Duse_system_speex=1
+ -Duse_system_v8=1
+ -Duse_system_xdg_utils=1
+ -Duse_system_zlib=1
+ $(gyp_use system-ffmpeg use_system_ffmpeg)"
+
+ # TODO: Use system mesa on x86, bug #457130 .
+ if ! use x86 && ! use arm; then
+ myconf+="
+ -Duse_system_mesa=1"
+ fi
+
+ # TODO: patch gyp so that this arm conditional is not needed.
+ if ! use arm; then
+ myconf+="
+ -Duse_system_yasm=1"
+ fi
+
+ # TODO: re-enable on vp9 libvpx release (http://crbug.com/174287).
+ myconf+="
+ -Dmedia_use_libvpx=0"
+
+ # Optional dependencies.
+ # TODO: linux_link_kerberos, bug #381289.
+ myconf+="
+ $(gyp_use cups)
+ $(gyp_use gnome use_gconf)
+ $(gyp_use gnome-keyring use_gnome_keyring)
+ $(gyp_use gnome-keyring linux_link_gnome_keyring)
+ $(gyp_use gps linux_use_libgps)
+ $(gyp_use gps linux_link_libgps)
+ $(gyp_use kerberos)
+ $(gyp_use pulseaudio)"
+
+ if use system-sqlite; then
+ elog "Enabling system sqlite. WebSQL - http://www.w3.org/TR/webdatabase/"
+ elog "will not work. Please report sites broken by this"
+ elog "to https://bugs.gentoo.org"
+ myconf+="
+ -Duse_system_sqlite=1
+ -Denable_sql_database=0"
+ fi
+
+ # Use explicit library dependencies instead of dlopen.
+ # This makes breakages easier to detect by revdep-rebuild.
+ myconf+="
+ -Dlinux_link_gsettings=1
+ -Dlinux_link_libpci=1
+ -Dlinux_link_libspeechd=1
+ -Dlibspeechd_h_prefix=speech-dispatcher/"
+
+ # TODO: use the file at run time instead of effectively compiling it in.
+ myconf+="
+ -Dusb_ids_path=/usr/share/misc/usb.ids"
+
+ # Enable SUID sandbox.
+ myconf+="
+ -Dlinux_sandbox_path=${CHROMIUM_HOME}/chrome_sandbox
+ -Dlinux_sandbox_chrome_path=${CHROMIUM_HOME}/chrome"
+
+ # Never use bundled gold binary. Disable gold linker flags for now.
+ myconf+="
+ -Dlinux_use_gold_binary=0
+ -Dlinux_use_gold_flags=0"
+
+ # Always support proprietary codecs.
+ myconf+=" -Dproprietary_codecs=1"
+
+ if ! use bindist && ! use system-ffmpeg; then
+ # Enable H.624 support in bundled ffmpeg.
+ myconf+=" -Dffmpeg_branding=Chrome"
+ fi
+
+ # Set up Google API keys, see http://www.chromium.org/developers/how-tos/api-keys .
+ # Note: these are for Gentoo use ONLY. For your own distribution,
+ # please get your own set of keys. Feel free to contact chromium@gentoo.org
+ # for more info.
+ myconf+=" -Dgoogle_api_key=AIzaSyDEAOvatFo0eTgsV_ZlEzx0ObmepsMzfAc
+ -Dgoogle_default_client_id=329227923882.apps.googleusercontent.com
+ -Dgoogle_default_client_secret=vgKG0NNv7GoDpbtoFNLxCUXu"
+
+ local myarch="$(tc-arch)"
+ if [[ $myarch = amd64 ]] ; then
+ myconf+=" -Dtarget_arch=x64"
+ elif [[ $myarch = x86 ]] ; then
+ myconf+=" -Dtarget_arch=ia32"
+ elif [[ $myarch = arm ]] ; then
+ # TODO: re-enable NaCl (NativeClient).
+ myconf+=" -Dtarget_arch=arm
+ -Dsysroot=
+ -Darmv7=0
+ -Darm_neon=0
+ -Ddisable_nacl=1"
+ else
+ die "Failed to determine target arch, got '$myarch'."
+ fi
+
+ # Make sure that -Werror doesn't get added to CFLAGS by the build system.
+ # Depending on GCC version the warnings are different and we don't want
+ # the build to fail because of that.
+ myconf+=" -Dwerror="
+
+ # Avoid CFLAGS problems, bug #352457, bug #390147.
+ if ! use custom-cflags; then
+ replace-flags "-Os" "-O2"
+ strip-flags
+ fi
+
+ # Make sure the build system will use the right tools, bug #340795.
+ tc-export AR CC CXX RANLIB
+
+ # Tools for building programs to be executed on the build system, bug #410883.
+ export AR_host=$(tc-getBUILD_AR)
+ export CC_host=$(tc-getBUILD_CC)
+ export CXX_host=$(tc-getBUILD_CXX)
+ export LD_host=${CXX_host}
+
+ build/linux/unbundle/replace_gyp_files.py ${myconf} || die
+ egyp_chromium ${myconf} || die
+}
+
+src_compile() {
+ # TODO: add media_unittests after fixing compile (bug #462546).
+ local test_targets=""
+ for x in base cacheinvalidation content crypto \
+ googleurl gpu net printing sql; do
+ test_targets+=" ${x}_unittests"
+ done
+
+ local ninja_targets="chrome chrome_sandbox chromedriver"
+ if use test; then
+ ninja_targets+=" $test_targets"
+ fi
+
+ # Even though ninja autodetects number of CPUs, we respect
+ # user's options, for debugging with -j 1 or any other reason.
+ ninja -C out/Release -v -j $(makeopts_jobs) ${ninja_targets} || die
+
+ pax-mark m out/Release/chrome
+ if use test; then
+ for x in $test_targets; do
+ pax-mark m out/Release/${x}
+ done
+ fi
+}
+
+src_test() {
+ # For more info see bug #350349.
+ local mylocale='en_US.utf8'
+ if ! locale -a | grep -q "$mylocale"; then
+ eerror "${PN} requires ${mylocale} locale for tests"
+ eerror "Please read the following guides for more information:"
+ eerror " http://www.gentoo.org/doc/en/guide-localization.xml"
+ eerror " http://www.gentoo.org/doc/en/utf-8.xml"
+ die "locale ${mylocale} is not supported"
+ fi
+
+ # For more info see bug #370957.
+ if [[ $UID -eq 0 ]]; then
+ die "Tests must be run as non-root. Please use FEATURES=userpriv."
+ fi
+
+ runtest() {
+ local cmd=$1
+ shift
+ local filter="--gtest_filter=$(IFS=:; echo "-${*}")"
+ einfo "${cmd}" "${filter}"
+ LC_ALL="${mylocale}" VIRTUALX_COMMAND="${cmd}" virtualmake "${filter}"
+ }
+
+ local excluded_base_unittests=(
+ "ICUStringConversionsTest.*" # bug #350347
+ "MessagePumpLibeventTest.*" # bug #398591
+ "TimeTest.JsTime" # bug #459614
+ "SecurityTest.NewOverflow" # bug #465724
+ )
+ runtest out/Release/base_unittests "${excluded_base_unittests[@]}"
+
+ runtest out/Release/cacheinvalidation_unittests
+
+ local excluded_content_unittests=(
+ "RendererDateTimePickerTest.*" # bug #465452
+ )
+ runtest out/Release/content_unittests "${excluded_content_unittests[@]}"
+
+ runtest out/Release/crypto_unittests
+ runtest out/Release/googleurl_unittests
+ runtest out/Release/gpu_unittests
+
+ # TODO: add media_unittests after fixing compile (bug #462546).
+ # runtest out/Release/media_unittests
+
+ local excluded_net_unittests=(
+ "NetUtilTest.IDNToUnicode*" # bug 361885
+ "NetUtilTest.FormatUrl*" # see above
+ "DnsConfigServiceTest.GetSystemConfig" # bug #394883
+ "CertDatabaseNSSTest.ImportServerCert_SelfSigned" # bug #399269
+ "CertDatabaseNSSTest.TrustIntermediateCa*" # http://crbug.com/224612
+ "URLFetcher*" # bug #425764
+ "HTTPSOCSPTest.*" # bug #426630
+ "HTTPSEVCRLSetTest.*" # see above
+ "HTTPSCRLSetTest.*" # see above
+ "*SpdyFramerTest.BasicCompression*" # bug #465444
+ )
+ runtest out/Release/net_unittests "${excluded_net_unittests[@]}"
+
+ runtest out/Release/printing_unittests
+
+ local excluded_sql_unittests=(
+ "SQLiteFeaturesTest.FTS2" # bug #461286
+ )
+ runtest out/Release/sql_unittests "${excluded_sql_unittests[@]}"
+}
+
+src_install() {
+ exeinto "${CHROMIUM_HOME}"
+ doexe out/Release/chrome || die
+
+ doexe out/Release/chrome_sandbox || die
+ fperms 4755 "${CHROMIUM_HOME}/chrome_sandbox"
+
+ doexe out/Release/chromedriver || die
+
+ if ! use arm; then
+ doexe out/Release/nacl_helper{,_bootstrap} || die
+ insinto "${CHROMIUM_HOME}"
+ doins out/Release/nacl_irt_*.nexe || die
+ doins out/Release/libppGoogleNaClPluginChrome.so || die
+ fi
+
+ newexe "${FILESDIR}"/chromium-launcher-r3.sh chromium-launcher.sh || die
+ if [[ "${CHROMIUM_SUFFIX}" != "" ]]; then
+ sed "s:chromium-browser:chromium-browser${CHROMIUM_SUFFIX}:g" \
+ -i "${ED}"/"${CHROMIUM_HOME}"/chromium-launcher.sh || die
+ sed "s:chromium.desktop:chromium${CHROMIUM_SUFFIX}.desktop:g" \
+ -i "${ED}"/"${CHROMIUM_HOME}"/chromium-launcher.sh || die
+ sed "s:plugins:plugins --user-data-dir=\${HOME}/.config/chromium${CHROMIUM_SUFFIX}:" \
+ -i "${ED}"/"${CHROMIUM_HOME}"/chromium-launcher.sh || die
+ fi
+
+ # It is important that we name the target "chromium-browser",
+ # xdg-utils expect it; bug #355517.
+ dosym "${CHROMIUM_HOME}/chromium-launcher.sh" /usr/bin/chromium-browser${CHROMIUM_SUFFIX} || die
+ # keep the old symlink around for consistency
+ dosym "${CHROMIUM_HOME}/chromium-launcher.sh" /usr/bin/chromium${CHROMIUM_SUFFIX} || die
+
+ # Allow users to override command-line options, bug #357629.
+ dodir /etc/chromium || die
+ insinto /etc/chromium
+ newins "${FILESDIR}/chromium.default" "default" || die
+
+ pushd out/Release/locales > /dev/null || die
+ chromium_remove_language_paks
+ popd
+
+ insinto "${CHROMIUM_HOME}"
+ doins out/Release/*.pak || die
+
+ doins -r out/Release/locales || die
+ doins -r out/Release/resources || die
+
+ newman out/Release/chrome.1 chromium${CHROMIUM_SUFFIX}.1 || die
+ newman out/Release/chrome.1 chromium-browser${CHROMIUM_SUFFIX}.1 || die
+
+ if ! use system-ffmpeg; then
+ doexe out/Release/libffmpegsumo.so || die
+ fi
+
+ # Install icons and desktop entry.
+ local branding size
+ for size in 16 22 24 32 48 64 128 256 ; do
+ case ${size} in
+ 16|32) branding="chrome/app/theme/default_100_percent/chromium" ;;
+ *) branding="chrome/app/theme/chromium" ;;
+ esac
+ newicon -s ${size} "${branding}/product_logo_${size}.png" \
+ chromium-browser${CHROMIUM_SUFFIX}.png
+ done
+
+ local mime_types="text/html;text/xml;application/xhtml+xml;"
+ mime_types+="x-scheme-handler/http;x-scheme-handler/https;" # bug #360797
+ mime_types+="x-scheme-handler/ftp;" # bug #412185
+ mime_types+="x-scheme-handler/mailto;x-scheme-handler/webcal;" # bug #416393
+ make_desktop_entry \
+ chromium-browser${CHROMIUM_SUFFIX} \
+ "Chromium${CHROMIUM_SUFFIX}" \
+ chromium-browser${CHROMIUM_SUFFIX} \
+ "Network;WebBrowser" \
+ "MimeType=${mime_types}\nStartupWMClass=chromium-browser"
+ sed -e "/^Exec/s/$/ %U/" -i "${ED}"/usr/share/applications/*.desktop || die
+
+ # Install GNOME default application entry (bug #303100).
+ if use gnome; then
+ dodir /usr/share/gnome-control-center/default-apps || die
+ insinto /usr/share/gnome-control-center/default-apps
+ newins "${FILESDIR}"/chromium-browser.xml chromium-browser${CHROMIUM_SUFFIX}.xml || die
+ if [[ "${CHROMIUM_SUFFIX}" != "" ]]; then
+ sed "s:chromium-browser:chromium-browser${CHROMIUM_SUFFIX}:g" -i \
+ "${ED}"/usr/share/gnome-control-center/default-apps/chromium-browser${CHROMIUM_SUFFIX}.xml
+ fi
+ fi
+}
diff --git a/www-client/chromium/chromium-9999-r1.ebuild b/www-client/chromium/chromium-9999-r1.ebuild
index 9a4cd1a7ed63..447f6be429eb 100644
--- a/www-client/chromium/chromium-9999-r1.ebuild
+++ b/www-client/chromium/chromium-9999-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/chromium/chromium-9999-r1.ebuild,v 1.194 2013/05/09 20:59:28 phajdan.jr Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/chromium/chromium-9999-r1.ebuild,v 1.195 2013/05/25 00:13:09 phajdan.jr Exp $
EAPI="5"
PYTHON_COMPAT=( python{2_6,2_7} )
@@ -9,7 +9,7 @@ CHROMIUM_LANGS="am ar bg bn ca cs da de el en_GB es es_LA et fa fi fil fr gu he
hi hr hu id it ja kn ko lt lv ml mr ms nb nl pl pt_BR pt_PT ro ru sk sl sr
sv sw ta te th tr uk vi zh_CN zh_TW"
-inherit chromium eutils flag-o-matic multilib \
+inherit chromium eutils flag-o-matic multilib multiprocessing \
pax-utils portability python-any-r1 subversion toolchain-funcs versionator virtualx
DESCRIPTION="Open-source version of Google Chrome web browser"
@@ -24,6 +24,10 @@ IUSE="bindist cups gnome gnome-keyring gps kerberos pulseaudio selinux +system-f
# Native Client binaries are compiled with different set of flags, bug #452066.
QA_FLAGS_IGNORED=".*\.nexe"
+# Native Client binaries may be stripped by the build system, which uses the
+# right tools for it, bug #469144 .
+QA_PRESTRIPPED=".*\.nexe"
+
RDEPEND=">=app-accessibility/speech-dispatcher-0.8:=
app-arch/bzip2:=
app-arch/snappy:=
@@ -33,7 +37,7 @@ RDEPEND=">=app-accessibility/speech-dispatcher-0.8:=
>=net-print/cups-1.3.11:=
)
>=dev-lang/v8-3.17.6:=
- =dev-lang/v8-3.18*
+ =dev-lang/v8-3.19*
>=dev-libs/elfutils-0.149
dev-libs/expat:=
>=dev-libs/icu-49.1.1-r1:=
@@ -81,13 +85,14 @@ DEPEND="${RDEPEND}
dev-lang/yasm
)
dev-lang/perl
+ dev-python/jinja
dev-python/ply
dev-python/simplejson
>=dev-util/gperf-3.0.3
+ dev-util/ninja
sys-apps/hwids
>=sys-devel/bison-2.4.3
sys-devel/flex
- >=sys-devel/make-3.81-r2
virtual/pkgconfig
test? ( dev-python/pyftpdlib )"
RDEPEND+="
@@ -180,14 +185,14 @@ pkg_setup() {
src_prepare() {
if ! use arm; then
- mkdir -p out/Release/obj/gen/sdk/toolchain || die
+ mkdir -p out/Release/gen/sdk/toolchain || die
# Do not preserve SELinux context, bug #460892 .
cp -a --no-preserve=context /usr/$(get_libdir)/nacl-toolchain-newlib \
- out/Release/obj/gen/sdk/toolchain/linux_x86_newlib || die
- touch out/Release/obj/gen/sdk/toolchain/linux_x86_newlib/stamp.untar || die
+ out/Release/gen/sdk/toolchain/linux_x86_newlib || die
+ touch out/Release/gen/sdk/toolchain/linux_x86_newlib/stamp.untar || die
fi
- epatch "${FILESDIR}/${PN}-system-ffmpeg-r5.patch"
+ epatch "${FILESDIR}/${PN}-system-ffmpeg-r6.patch"
epatch_user
@@ -410,6 +415,12 @@ src_configure() {
# Tools for building programs to be executed on the build system, bug #410883.
tc-export_build_env BUILD_AR BUILD_CC BUILD_CXX
+ # Tools for building programs to be executed on the build system, bug #410883.
+ export AR_host=$(tc-getBUILD_AR)
+ export CC_host=$(tc-getBUILD_CC)
+ export CXX_host=$(tc-getBUILD_CXX)
+ export LD_host=${CXX_host}
+
build/linux/unbundle/replace_gyp_files.py ${myconf} || die
egyp_chromium ${myconf} || die
}
@@ -422,17 +433,14 @@ src_compile() {
test_targets+=" ${x}_unittests"
done
- local make_targets="chrome chrome_sandbox chromedriver"
+ local ninja_targets="chrome chrome_sandbox chromedriver"
if use test; then
- make_targets+=" $test_targets"
+ ninja_targets+=" $test_targets"
fi
- # See bug #410883 for more info about the .host mess.
- emake ${make_targets} BUILDTYPE=Release V=1 \
- CC.host="${BUILD_CC}" CFLAGS.host="${BUILD_CFLAGS}" \
- CXX.host="${BUILD_CXX}" CXXFLAGS.host="${BUILD_CXXFLAGS}" \
- LINK.host="${BUILD_CXX}" LDFLAGS.host="${BUILD_LDFLAGS}" \
- AR.host="${BUILD_AR}" || die
+ # Even though ninja autodetects number of CPUs, we respect
+ # user's options, for debugging with -j 1 or any other reason.
+ ninja -C out/Release -v -j $(makeopts_jobs) ${ninja_targets} || die
pax-mark m out/Release/chrome
if use test; then
diff --git a/www-client/chromium/files/chromium-system-ffmpeg-r6.patch b/www-client/chromium/files/chromium-system-ffmpeg-r6.patch
new file mode 100644
index 000000000000..3ac050bd4468
--- /dev/null
+++ b/www-client/chromium/files/chromium-system-ffmpeg-r6.patch
@@ -0,0 +1,136 @@
+--- a/media/filters/ffmpeg_glue.h
++++ b/media/filters/ffmpeg_glue.h
+@@ -28,9 +28,9 @@
+ #include "base/basictypes.h"
+ #include "base/memory/scoped_ptr.h"
+ #include "media/base/media_export.h"
++#include "media/ffmpeg/ffmpeg_common.h"
+
+ struct AVFormatContext;
+-struct AVIOContext;
+
+ namespace media {
+
+--- a/media/media.gyp
++++ b/media/media.gyp
+@@ -363,6 +363,9 @@
+ 'dependencies': [
+ '../third_party/ffmpeg/ffmpeg.gyp:ffmpeg',
+ ],
++ 'export_dependent_settings': [
++ '../third_party/ffmpeg/ffmpeg.gyp:ffmpeg',
++ ],
+ }, { # media_use_ffmpeg == 0
+ # Exclude the sources that depend on ffmpeg.
+ 'sources!': [
+--- a/media/ffmpeg/ffmpeg_common.cc.orig 2013-01-17 00:07:51.635057013 +0000
++++ b/media/ffmpeg/ffmpeg_common.cc 2013-01-17 00:15:50.867406811 +0000
+@@ -10,6 +10,8 @@
+ #include "media/base/video_frame.h"
+ #include "media/base/video_util.h"
+
++#undef SampleFormat
++
+ namespace media {
+
+ // Why FF_INPUT_BUFFER_PADDING_SIZE? FFmpeg assumes all input buffers are
+@@ -85,8 +85,10 @@
+ return kCodecGSM_MS;
+ case AV_CODEC_ID_PCM_MULAW:
+ return kCodecPCM_MULAW;
++#ifndef CHROMIUM_OMIT_AV_CODEC_ID_OPUS
+ case AV_CODEC_ID_OPUS:
+ return kCodecOpus;
++#endif
+ default:
+ DVLOG(1) << "Unknown audio CodecID: " << codec_id;
+ }
+@@ -130,8 +132,10 @@
+ return AV_CODEC_ID_GSM_MS;
+ case kCodecPCM_MULAW:
+ return AV_CODEC_ID_PCM_MULAW;
++#ifndef CHROMIUM_OMIT_AV_CODEC_ID_OPUS
+ case kCodecOpus:
+ return AV_CODEC_ID_OPUS;
++#endif
+ default:
+ DVLOG(1) << "Unknown AudioCodec: " << audio_codec;
+ }
+@@ -149,8 +153,10 @@
+ return kCodecMPEG4;
+ case AV_CODEC_ID_VP8:
+ return kCodecVP8;
++#ifndef CHROMIUM_OMIT_AV_CODEC_ID_VP9
+ case AV_CODEC_ID_VP9:
+ return kCodecVP9;
++#endif
+ default:
+ DVLOG(1) << "Unknown video CodecID: " << codec_id;
+ }
+@@ -167,8 +173,10 @@
+ return AV_CODEC_ID_MPEG4;
+ case kCodecVP8:
+ return AV_CODEC_ID_VP8;
++#ifndef CHROMIUM_OMIT_AV_CODEC_ID_VP9
+ case kCodecVP9:
+ return AV_CODEC_ID_VP9;
++#endif
+ default:
+ DVLOG(1) << "Unknown VideoCodec: " << video_codec;
+ }
+--- a/media/filters/ffmpeg_demuxer.cc.orig 2013-05-09 18:04:25.089276403 +0000
++++ b/media/filters/ffmpeg_demuxer.cc 2013-05-09 18:05:16.289599070 +0000
+@@ -111,12 +111,15 @@
+ // Get side data if any. For now, the only type of side_data is VP8 Alpha. We
+ // keep this generic so that other side_data types in the future can be
+ // handled the same way as well.
+- av_packet_split_side_data(packet.get());
+ int side_data_size = 0;
+- uint8* side_data = av_packet_get_side_data(
++ uint8* side_data = NULL;
++#ifndef CHROMIUM_OMIT_AV_PKT_DATA_MATROSKA_BLOCKADDITIONAL
++ av_packet_split_side_data(packet.get());
++ side_data = av_packet_get_side_data(
+ packet.get(),
+ AV_PKT_DATA_MATROSKA_BLOCKADDITIONAL,
+ &side_data_size);
++#endif
+
+ // If a packet is returned by FFmpeg's av_parser_parse2() the packet will
+ // reference inner memory of FFmpeg. As such we should transfer the packet
+--- a/media/base/media_posix.cc.orig 2013-05-24 20:59:12.963046035 +0000
++++ b/media/base/media_posix.cc 2013-05-24 20:59:50.593275882 +0000
+@@ -11,12 +11,15 @@
+ #include "base/path_service.h"
+ #include "base/strings/stringize_macros.h"
+ #include "media/ffmpeg/ffmpeg_common.h"
++
++#if !defined(USE_SYSTEM_FFMPEG)
+ #include "third_party/ffmpeg/ffmpeg_stubs.h"
+
+ using third_party_ffmpeg::kNumStubModules;
+ using third_party_ffmpeg::kModuleFfmpegsumo;
+ using third_party_ffmpeg::InitializeStubs;
+ using third_party_ffmpeg::StubPathMap;
++#endif
+
+ namespace media {
+ namespace internal {
+@@ -46,6 +49,9 @@
+ #endif
+
+ bool InitializeMediaLibraryInternal(const base::FilePath& module_dir) {
++#if defined(USE_SYSTEM_FFMPEG)
++ return true;
++#else
+ StubPathMap paths;
+
+ // First try to initialize with Chrome's sumo library.
+@@ -61,6 +67,7 @@
+ FILE_PATH_LITERAL(DSO_NAME("avformat", AVFORMAT_VERSION))).value());
+
+ return InitializeStubs(paths);
++#endif
+ }
+
+ } // namespace internal