summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMamoru Komachi <usata@gentoo.org>2006-03-24 12:46:13 +0000
committerMamoru Komachi <usata@gentoo.org>2006-03-24 12:46:13 +0000
commit0833309f1424f309ae21d700b03ec6cdcc700538 (patch)
tree61114fb538f9dbc9d210f889927cb0e5e11df39c /www-client
parentMark 2.12.3 stable on ia64 (diff)
downloadgentoo-2-0833309f1424f309ae21d700b03ec6cdcc700538.tar.gz
gentoo-2-0833309f1424f309ae21d700b03ec6cdcc700538.tar.bz2
gentoo-2-0833309f1424f309ae21d700b03ec6cdcc700538.zip
Updated i18n-misc patch. This fixes --disable-nls bug; bug #124702.
(Portage version: 2.0.53)
Diffstat (limited to 'www-client')
-rw-r--r--www-client/dillo/ChangeLog9
-rw-r--r--www-client/dillo/Manifest8
-rw-r--r--www-client/dillo/dillo-0.8.5-r3.ebuild132
-rw-r--r--www-client/dillo/files/digest-dillo-0.8.5-r33
4 files changed, 147 insertions, 5 deletions
diff --git a/www-client/dillo/ChangeLog b/www-client/dillo/ChangeLog
index 97700cdfbe5a..db94833daaad 100644
--- a/www-client/dillo/ChangeLog
+++ b/www-client/dillo/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for www-client/dillo
-# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/dillo/ChangeLog,v 1.44 2005/10/30 04:39:36 usata Exp $
+# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/www-client/dillo/ChangeLog,v 1.45 2006/03/24 12:46:13 usata Exp $
+
+*dillo-0.8.5-r3 (24 Mar 2006)
+
+ 24 Mar 2006; Mamoru KOMACHI <usata@gentoo.org> +dillo-0.8.5-r3.ebuild:
+ Updated i18n-misc patch. This fixes --disable-nls bug; bug #124702.
*dillo-0.8.5-r2 (30 Oct 2005)
diff --git a/www-client/dillo/Manifest b/www-client/dillo/Manifest
index a5e050da13ba..3ebfacc5de89 100644
--- a/www-client/dillo/Manifest
+++ b/www-client/dillo/Manifest
@@ -1,9 +1,11 @@
MD5 a0073369e04671fb1bd75f5d6857ffea ChangeLog 13307
+MD5 e23614bce2d1d77e7df6952b8f3244ca dillo-0.7.3-r7.ebuild 3061
MD5 d59c047c502094e1882c0c09422b385a dillo-0.8.5-r1.ebuild 3606
MD5 1909f58b5dde32ddaf2c2fede0c7b8f1 dillo-0.8.5-r2.ebuild 3612
-MD5 e23614bce2d1d77e7df6952b8f3244ca dillo-0.7.3-r7.ebuild 3061
-MD5 3ff31b5479b2a0244f5711fff3155aed metadata.xml 221
+MD5 896ce69278bb6675eded14c6c693c453 dillo-0.8.5-r3.ebuild 3612
+MD5 e257387d2c71e79a44b93b59e5240db3 files/digest-dillo-0.7.3-r7 226
MD5 8114dfcae2f9f3437c043ed6953f219d files/digest-dillo-0.8.5-r1 226
MD5 b2d1d2280e92c7e86dcfb11fe73eb777 files/digest-dillo-0.8.5-r2 226
-MD5 e257387d2c71e79a44b93b59e5240db3 files/digest-dillo-0.7.3-r7 226
+MD5 ba038100788e11d181e9e819b15bcc9a files/digest-dillo-0.8.5-r3 226
MD5 7750091e1346c986eeb58aef81297fd0 files/dillo-format-string-vulnerability.diff 787
+MD5 3ff31b5479b2a0244f5711fff3155aed metadata.xml 221
diff --git a/www-client/dillo/dillo-0.8.5-r3.ebuild b/www-client/dillo/dillo-0.8.5-r3.ebuild
new file mode 100644
index 000000000000..34cd7b15b0ff
--- /dev/null
+++ b/www-client/dillo/dillo-0.8.5-r3.ebuild
@@ -0,0 +1,132 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-client/dillo/dillo-0.8.5-r3.ebuild,v 1.1 2006/03/24 12:46:13 usata Exp $
+
+inherit flag-o-matic eutils
+
+S2=${WORKDIR}/dillo-gentoo-extras-patch4
+DILLO_I18N_P="${P}-i18n-misc-20060104"
+
+DESCRIPTION="Lean GTK+-based web browser"
+HOMEPAGE="http://www.dillo.org/"
+SRC_URI="http://www.dillo.org/download/${P}.tar.bz2
+ mirror://gentoo/dillo-gentoo-extras-patch4.tar.bz2
+ http://teki.jpn.ph/pc/software/${DILLO_I18N_P}.diff.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~mips ~ppc ~ppc64 ~sparc ~x86"
+MISC_IUSE="nls truetype"
+IUSE="${MISC_IUSE} ipv6 ssl"
+
+RDEPEND="=x11-libs/gtk+-1.2*
+ >=media-libs/jpeg-6b
+ >=sys-libs/zlib-1.1.3
+ >=media-libs/libpng-1.2.1
+ ssl? ( dev-libs/openssl )"
+DEPEND="sys-devel/autoconf
+ sys-devel/automake
+ ${RDEPEND}"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ../${DILLO_I18N_P}.diff || die
+ sh autogen.sh || die
+
+ if [ "${DILLO_ICONSET}" = "kde" ]
+ then
+ einfo "Using Konqueror style icon set"
+ cp ${S2}/pixmaps.konq.h ${S}/src/pixmaps.h
+ elif [ "${DILLO_ICONSET}" = "gnome" ]
+ then
+ einfo "Using Ximian style icon set"
+ cp ${S2}/pixmaps.ximian.h ${S}/src/pixmaps.h
+ elif [ "${DILLO_ICONSET}" = "mozilla" ]
+ then
+ einfo "Using Netscape style icon set"
+ cp ${S2}/pixmaps.netscape.h ${S}/src/pixmaps.h
+ elif [ "${DILLO_ICONSET}" = "cobalt" ]
+ then
+ einfo "Using Cobalt style icon set"
+ cp ${S2}/pixmaps.cobalt.h ${S}/src/pixmaps.h
+ elif [ "${DILLO_ICONSET}" = "bold" ]
+ then
+ einfo "Using bold style icon set"
+ cp ${S2}/pixmaps.bold.h ${S}/src/pixmaps.h
+ elif [ "${DILLO_ICONSET}" = "trans" ]
+ then
+ einfo "Using transparent style icon set"
+ cp ${S2}/pixmaps.trans.h ${S}/src/pixmaps.h
+ elif [ "${DILLO_ICONSET}" = "trad" ]
+ then
+ einfo "Using the traditional icon set"
+ cp ${S2}/pixmaps.trad.h ${S}/src/pixmaps.h
+ else
+ einfo "Using default Dillo icon set"
+ fi
+}
+
+src_compile() {
+ replace-flags "-O2 -mcpu=k6" "-O2 -mcpu=pentium"
+ append-flags "-O"
+
+ local myconf
+
+ # misc features
+ myconf="$(use_enable nls)
+ $(use_enable truetype anti-alias)
+ --enable-tabs
+ --enable-meta-refresh"
+
+ myconf="${myconf}
+ $(use_enable ipv6)
+ $(use_enable ssl)"
+
+ econf ${myconf} || die
+ emake -j1 || die
+}
+
+src_install() {
+ dodir /etc /usr/share/icons/${PN}
+ make DESTDIR=${D} install || die
+
+ dosed /etc/dpidrc
+
+ dodoc AUTHORS COPYING ChangeLog* INSTALL README NEWS
+ docinto doc
+ dodoc doc/*.txt doc/README
+
+ cp ${S2}/icons/*.png ${D}/usr/share/icons/${PN}
+}
+
+pkg_postinst() {
+ einfo "This ebuild for dillo comes with different toolbar icons"
+ einfo "If you want mozilla style icons then try"
+ einfo " DILLO_ICONSET=\"mozilla\" emerge dillo"
+ einfo
+ einfo "If you prefer konqueror style icons then try"
+ einfo " DILLO_ICONSET=\"kde\" emerge dillo"
+ einfo
+ einfo "If you prefer ximian gnome style icons then try"
+ einfo " DILLO_ICONSET=\"gnome\" emerge dillo"
+ einfo
+ einfo "If you prefer cobalt style icons then try"
+ einfo " DILLO_ICONSET=\"cobalt\" emerge dillo"
+ einfo
+ einfo "If you prefer bold style icons then try"
+ einfo " DILLO_ICONSET=\"bold\" emerge dillo"
+ einfo
+ einfo "If you prefer transparent style icons then try"
+ einfo " DILLO_ICONSET=\"trans\" emerge dillo"
+ einfo
+ einfo "If you prefer the traditional icons then try"
+ einfo " DILLO_ICONSET=\"trad\" emerge dillo"
+ einfo
+ einfo "If the DILLO_ICONSET variable is not set, you will get the"
+ einfo "default iconset"
+ einfo
+ einfo "To see what the icons look like, please point your browser to:"
+ einfo "http://dillo.auriga.wearlab.de/Icons/"
+ einfo
+}
diff --git a/www-client/dillo/files/digest-dillo-0.8.5-r3 b/www-client/dillo/files/digest-dillo-0.8.5-r3
new file mode 100644
index 000000000000..23ecbc8772bf
--- /dev/null
+++ b/www-client/dillo/files/digest-dillo-0.8.5-r3
@@ -0,0 +1,3 @@
+MD5 fabc2fa5a657701a23930c510d001a95 dillo-0.8.5-i18n-misc-20060104.diff.bz2 248425
+MD5 d0ab7fa1d40b310deb891388604188f8 dillo-0.8.5.tar.bz2 424795
+MD5 0d0bc7cdd39dc66b80280f73d74bfeaf dillo-gentoo-extras-patch4.tar.bz2 98800