summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Mende <angelos@gentoo.org>2013-03-29 21:37:00 +0000
committerChristoph Mende <angelos@gentoo.org>2013-03-29 21:37:00 +0000
commit0507ef6164517b3d06a58f5f62e491645aeb45c1 (patch)
treea3f5574d0209ea8f59f965fac0cde6bbfcb36d85 /www-client
parent0.9.25 version bump. (diff)
downloadgentoo-2-0507ef6164517b3d06a58f5f62e491645aeb45c1.tar.gz
gentoo-2-0507ef6164517b3d06a58f5f62e491645aeb45c1.tar.bz2
gentoo-2-0507ef6164517b3d06a58f5f62e491645aeb45c1.zip
Convert to vala.eclass
(Portage version: 2.2.0_alpha170/cvs/Linux x86_64, signed Manifest commit with key 84F20B43)
Diffstat (limited to 'www-client')
-rw-r--r--www-client/midori/ChangeLog7
-rw-r--r--www-client/midori/midori-0.4.6-r1.ebuild13
-rw-r--r--www-client/midori/midori-0.4.8.ebuild12
-rw-r--r--www-client/midori/midori-0.4.9.ebuild12
-rw-r--r--www-client/midori/midori-9999.ebuild12
5 files changed, 29 insertions, 27 deletions
diff --git a/www-client/midori/ChangeLog b/www-client/midori/ChangeLog
index 0dedfada89bf..9ef022b34863 100644
--- a/www-client/midori/ChangeLog
+++ b/www-client/midori/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for www-client/midori
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/midori/ChangeLog,v 1.106 2013/03/12 10:19:16 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/midori/ChangeLog,v 1.107 2013/03/29 21:37:00 angelos Exp $
+
+ 29 Mar 2013; Christoph Mende <angelos@gentoo.org> midori-0.4.6-r1.ebuild,
+ midori-0.4.8.ebuild, midori-0.4.9.ebuild, midori-9999.ebuild:
+ Convert to vala.eclass
*midori-0.4.9 (12 Mar 2013)
@@ -446,4 +450,3 @@
27 Mar 2008; Markus Ullmann <jokey@gentoo.org> +metadata.xml:
Add ebuild for bug #215036
-
diff --git a/www-client/midori/midori-0.4.6-r1.ebuild b/www-client/midori/midori-0.4.6-r1.ebuild
index 7f1465c179a4..997e96c7903e 100644
--- a/www-client/midori/midori-0.4.6-r1.ebuild
+++ b/www-client/midori/midori-0.4.6-r1.ebuild
@@ -1,8 +1,9 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/midori/midori-0.4.6-r1.ebuild,v 1.4 2012/08/18 13:27:25 johu Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/midori/midori-0.4.6-r1.ebuild,v 1.5 2013/03/29 21:37:00 angelos Exp $
EAPI=4
+VALA_MIN_API_VERSION=0.14
unset _live_inherits
@@ -14,9 +15,7 @@ else
SRC_URI="mirror://xfce/src/apps/${PN}/${PV%.*}/${P}.tar.bz2"
fi
-inherit eutils fdo-mime gnome2-utils python waf-utils ${_live_inherits}
-
-PV_vala_version=0.16
+inherit eutils fdo-mime gnome2-utils python waf-utils vala ${_live_inherits}
DESCRIPTION="A lightweight web browser based on WebKitGTK+"
HOMEPAGE="http://www.twotoasts.de/index.php?/pages/midori_summary.html"
@@ -44,7 +43,7 @@ RDEPEND="dev-db/sqlite:3
libnotify? ( >=x11-libs/libnotify-0.7 )"
DEPEND="${RDEPEND}
|| ( dev-lang/python:2.7 dev-lang/python:2.6 )
- dev-lang/vala:${PV_vala_version}
+ $(vala_depend)
dev-util/intltool
gnome-base/librsvg
doc? ( dev-util/gtk-doc )
@@ -68,12 +67,12 @@ src_unpack() {
src_prepare() {
epatch "${FILESDIR}"/${P}-dl.patch
+ vala_src_prepare
}
src_configure() {
strip-linguas -i po
- VALAC="$(type -P valac-${PV_vala_version})" \
waf-utils_src_configure \
--disable-docs \
$(use_enable doc apidocs) \
diff --git a/www-client/midori/midori-0.4.8.ebuild b/www-client/midori/midori-0.4.8.ebuild
index 388dbb9ef7bf..39e1167c271d 100644
--- a/www-client/midori/midori-0.4.8.ebuild
+++ b/www-client/midori/midori-0.4.8.ebuild
@@ -1,8 +1,9 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/midori/midori-0.4.8.ebuild,v 1.3 2013/02/06 18:18:15 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/midori/midori-0.4.8.ebuild,v 1.4 2013/03/29 21:37:00 angelos Exp $
EAPI=5
+VALA_MIN_API_VERSION=0.14
PYTHON_COMPAT=( python2_7 )
@@ -16,9 +17,7 @@ else
SRC_URI="mirror://xfce/src/apps/${PN}/${PV%.*}/${P}.tar.bz2"
fi
-inherit eutils fdo-mime gnome2-utils python-any-r1 waf-utils ${_live_inherits}
-
-VALA_VERSION=0.18
+inherit eutils fdo-mime gnome2-utils python-any-r1 waf-utils vala ${_live_inherits}
DESCRIPTION="A lightweight web browser based on WebKitGTK+"
HOMEPAGE="http://twotoasts.de/index.php/midori/"
@@ -48,7 +47,7 @@ RDEPEND=">=dev-db/sqlite-3.6.19:3
zeitgeist? ( >=dev-libs/libzeitgeist-0.3.14 )"
DEPEND="${RDEPEND}
${PYTHON_DEPS}
- dev-lang/vala:${VALA_VERSION}
+ $(vala_depend)
dev-util/intltool
gnome-base/librsvg
doc? ( dev-util/gtk-doc )
@@ -75,12 +74,13 @@ src_prepare() {
# FIXME: The code is not compatible with X- in the names
# epatch "${FILESDIR}"/${P}-desktop_file_validation.patch
+
+ vala_src_prepare
}
src_configure() {
strip-linguas -i po
- VALAC="$(type -P valac-${VALA_VERSION})" \
waf-utils_src_configure \
--disable-docs \
$(use_enable doc apidocs) \
diff --git a/www-client/midori/midori-0.4.9.ebuild b/www-client/midori/midori-0.4.9.ebuild
index b905fc882d8d..ea4f453c1faa 100644
--- a/www-client/midori/midori-0.4.9.ebuild
+++ b/www-client/midori/midori-0.4.9.ebuild
@@ -1,8 +1,9 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/midori/midori-0.4.9.ebuild,v 1.1 2013/03/12 10:19:16 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/midori/midori-0.4.9.ebuild,v 1.2 2013/03/29 21:37:00 angelos Exp $
EAPI=5
+VALA_MIN_API_VERSION=0.14
PYTHON_COMPAT=( python2_7 )
@@ -16,9 +17,7 @@ else
SRC_URI="mirror://xfce/src/apps/${PN}/${PV%.*}/${P}.tar.bz2"
fi
-inherit eutils fdo-mime gnome2-utils python-any-r1 waf-utils ${_live_inherits}
-
-VALA_VERSION=0.18
+inherit eutils fdo-mime gnome2-utils python-any-r1 waf-utils vala ${_live_inherits}
DESCRIPTION="A lightweight web browser based on WebKitGTK+"
HOMEPAGE="http://twotoasts.de/index.php/midori/"
@@ -48,7 +47,7 @@ RDEPEND=">=dev-db/sqlite-3.6.19:3
zeitgeist? ( >=dev-libs/libzeitgeist-0.3.14 )"
DEPEND="${RDEPEND}
${PYTHON_DEPS}
- dev-lang/vala:${VALA_VERSION}
+ $(vala_depend)
dev-util/intltool
gnome-base/librsvg
doc? ( dev-util/gtk-doc )
@@ -72,6 +71,8 @@ src_unpack() {
src_prepare() {
# Force disabled because we don't have this custom renamed in Portage
sed -i -e 's:gcr-3-gtk2:&dIsAbLe:' wscript || die
+
+ vala_src_prepare
}
src_configure() {
@@ -80,7 +81,6 @@ src_configure() {
local myconf
use deprecated || myconf="$(use_enable webkit2)"
- VALAC="$(type -P valac-${VALA_VERSION})" \
waf-utils_src_configure \
--disable-docs \
$(use_enable doc apidocs) \
diff --git a/www-client/midori/midori-9999.ebuild b/www-client/midori/midori-9999.ebuild
index 9b5fcad5c038..d32807201873 100644
--- a/www-client/midori/midori-9999.ebuild
+++ b/www-client/midori/midori-9999.ebuild
@@ -1,8 +1,9 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/midori/midori-9999.ebuild,v 1.46 2013/03/12 10:19:16 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/midori/midori-9999.ebuild,v 1.47 2013/03/29 21:37:00 angelos Exp $
EAPI=5
+VALA_MIN_API_VERSION=0.14
PYTHON_COMPAT=( python2_7 )
@@ -16,9 +17,7 @@ else
SRC_URI="mirror://xfce/src/apps/${PN}/${PV%.*}/${P}.tar.bz2"
fi
-inherit eutils fdo-mime gnome2-utils python-any-r1 waf-utils ${_live_inherits}
-
-VALA_VERSION=0.18
+inherit eutils fdo-mime gnome2-utils python-any-r1 waf-utils vala ${_live_inherits}
DESCRIPTION="A lightweight web browser based on WebKitGTK+"
HOMEPAGE="http://twotoasts.de/index.php/midori/"
@@ -48,7 +47,7 @@ RDEPEND=">=dev-db/sqlite-3.6.19:3
zeitgeist? ( >=dev-libs/libzeitgeist-0.3.14 )"
DEPEND="${RDEPEND}
${PYTHON_DEPS}
- dev-lang/vala:${VALA_VERSION}
+ $(vala_depend)
dev-util/intltool
gnome-base/librsvg
doc? ( dev-util/gtk-doc )
@@ -72,6 +71,8 @@ src_unpack() {
src_prepare() {
# Force disabled because we don't have this custom renamed in Portage
sed -i -e 's:gcr-3-gtk2:&dIsAbLe:' wscript || die
+
+ vala_src_prepare
}
src_configure() {
@@ -80,7 +81,6 @@ src_configure() {
local myconf
use deprecated || myconf="$(use_enable webkit2)"
- VALAC="$(type -P valac-${VALA_VERSION})" \
waf-utils_src_configure \
--disable-docs \
$(use_enable doc apidocs) \