summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Alexander <wired@gentoo.org>2013-05-03 04:08:23 +0000
committerAlex Alexander <wired@gentoo.org>2013-05-03 04:08:23 +0000
commitf13598aa029afca922d90c857eb9d6ba466092ad (patch)
treec7b8ace45839568ce5a45908affed9dacaf67faa /www-client/uget
parentDev channel bump. (diff)
downloadgentoo-2-f13598aa029afca922d90c857eb9d6ba466092ad.tar.gz
gentoo-2-f13598aa029afca922d90c857eb9d6ba466092ad.tar.bz2
gentoo-2-f13598aa029afca922d90c857eb9d6ba466092ad.zip
respect AR - bug #466600 - patch by Ted Tanberry. removed old.
(Portage version: 2.2.0_alpha173/cvs/Linux x86_64, signed Manifest commit with key EB9B4AFA)
Diffstat (limited to 'www-client/uget')
-rw-r--r--www-client/uget/ChangeLog8
-rw-r--r--www-client/uget/files/uget-ar-hardcoded.patch26
-rw-r--r--www-client/uget/uget-1.10.3-r1.ebuild (renamed from www-client/uget/uget-1.10.2.ebuild)15
3 files changed, 44 insertions, 5 deletions
diff --git a/www-client/uget/ChangeLog b/www-client/uget/ChangeLog
index 968a8df062bc..eb1d3ff8293a 100644
--- a/www-client/uget/ChangeLog
+++ b/www-client/uget/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for www-client/uget
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/uget/ChangeLog,v 1.38 2013/04/22 09:09:11 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/uget/ChangeLog,v 1.39 2013/05/03 04:08:22 wired Exp $
+
+*uget-1.10.3-r1 (03 May 2013)
+
+ 03 May 2013; Alex Alexander <wired@gentoo.org> -uget-1.10.2.ebuild,
+ +uget-1.10.3-r1.ebuild, +files/uget-ar-hardcoded.patch:
+ respect AR - bug #466600 - patch by Ted Tanberry. removed old.
22 Apr 2013; Agostino Sarubbo <ago@gentoo.org> uget-1.10.3.ebuild:
Stable for ppc, wrt bug #463152
diff --git a/www-client/uget/files/uget-ar-hardcoded.patch b/www-client/uget/files/uget-ar-hardcoded.patch
new file mode 100644
index 000000000000..f9ce7bb2f1df
--- /dev/null
+++ b/www-client/uget/files/uget-ar-hardcoded.patch
@@ -0,0 +1,26 @@
+--- configure.ac 2013-04-23 21:14:51.367980659 +0200
++++ configure.ac 2013-04-23 21:19:23.096311763 +0200
+@@ -19,6 +19,9 @@
+ ## Use library (static library)
+ AC_PROG_RANLIB
+
++## Determine the archiver
++AM_PROG_AR
++
+ ## Use libtool (share and static library) (add libtoolize to autogen.sh)
+ # AC_PROG_LIBTOOL
+ # LT_PREREQ([2.2.6])
+
+
+--- uglib/Makefile.in 2013-04-23 21:14:51.405980565 +0200
++++ uglib/Makefile.in 2013-04-23 21:17:22.358607880 +0200
+@@ -51,7 +51,7 @@
+ CONFIG_CLEAN_FILES =
+ CONFIG_CLEAN_VPATH_FILES =
+ LIBRARIES = $(noinst_LIBRARIES)
+-AR = ar
++AR = @AR@
+ ARFLAGS = cru
+ libuglib_a_AR = $(AR) $(ARFLAGS)
+ libuglib_a_LIBADD =
+
diff --git a/www-client/uget/uget-1.10.2.ebuild b/www-client/uget/uget-1.10.3-r1.ebuild
index e58f9fbed896..4ae88c95ae5a 100644
--- a/www-client/uget/uget-1.10.2.ebuild
+++ b/www-client/uget/uget-1.10.3-r1.ebuild
@@ -1,12 +1,14 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/uget/uget-1.10.2.ebuild,v 1.2 2012/12/02 17:09:06 eva Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/uget/uget-1.10.3-r1.ebuild,v 1.1 2013/05/03 04:08:22 wired Exp $
EAPI="4"
+inherit base autotools
+
IUSE="aria2 +curl gstreamer hide-temp-files libnotify nls"
if [[ ${PV} == *9999* ]]; then
- inherit autotools git-2
+ inherit git-2
KEYWORDS=""
SRC_URI=""
EGIT_REPO_URI="git://urlget.git.sourceforge.net/gitroot/urlget/uget"
@@ -37,11 +39,16 @@ DEPEND="${RDEPEND}
sys-devel/gettext"
src_prepare() {
+ epatch "${FILESDIR}"/${PN}-ar-hardcoded.patch
+ eautoreconf
+
if [[ ${PV} == *9999* ]]; then
- eautoreconf
intltoolize || die "intltoolize failed"
eautoreconf
fi
+
+ # fix the .desktop file for QA
+ sed -i 's/Network;FileTransfer/Network;FileTransfer;/g' uget-gtk.desktop
}
src_configure() {