summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen de Groot <yngwin@gentoo.org>2012-07-16 12:30:07 +0000
committerBen de Groot <yngwin@gentoo.org>2012-07-16 12:30:07 +0000
commit8065c4b623784612bfeff83b974c61db6fed951f (patch)
tree323944a6317c28ff0b370fb82f15d1b40018d1ec /www-client/qupzilla
parentFix compilation with --as-needed (bug #424067), properly fail on build errors... (diff)
downloadgentoo-2-8065c4b623784612bfeff83b974c61db6fed951f.tar.gz
gentoo-2-8065c4b623784612bfeff83b974c61db6fed951f.tar.bz2
gentoo-2-8065c4b623784612bfeff83b974c61db6fed951f.zip
Version bump. Drop patch which has been applied upstream.
(Portage version: 2.2.0_alpha118/cvs/Linux x86_64)
Diffstat (limited to 'www-client/qupzilla')
-rw-r--r--www-client/qupzilla/ChangeLog7
-rw-r--r--www-client/qupzilla/qupzilla-1.3.1.ebuild43
2 files changed, 49 insertions, 1 deletions
diff --git a/www-client/qupzilla/ChangeLog b/www-client/qupzilla/ChangeLog
index f8b3e7472700..7c9c6023d3bc 100644
--- a/www-client/qupzilla/ChangeLog
+++ b/www-client/qupzilla/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for www-client/qupzilla
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/qupzilla/ChangeLog,v 1.8 2012/07/12 14:50:02 yngwin Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/qupzilla/ChangeLog,v 1.9 2012/07/16 12:30:07 yngwin Exp $
+
+*qupzilla-1.3.1 (16 Jul 2012)
+
+ 16 Jul 2012; Ben de Groot <yngwin@gentoo.org> +qupzilla-1.3.1.ebuild:
+ Version bump. Drop patch which has been applied upstream.
12 Jul 2012; Ben de Groot <yngwin@gentoo.org>
+files/qupzilla-1.3.0-desktop.patch, qupzilla-1.3.0.ebuild:
diff --git a/www-client/qupzilla/qupzilla-1.3.1.ebuild b/www-client/qupzilla/qupzilla-1.3.1.ebuild
new file mode 100644
index 000000000000..93fe0439a571
--- /dev/null
+++ b/www-client/qupzilla/qupzilla-1.3.1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-client/qupzilla/qupzilla-1.3.1.ebuild,v 1.1 2012/07/16 12:30:07 yngwin Exp $
+
+EAPI=4
+
+inherit multilib qt4-r2 vcs-snapshot
+
+MY_P="QupZilla%20${PV}"
+
+DESCRIPTION="Qt WebKit web browser"
+HOMEPAGE="http://www.qupzilla.com/"
+SRC_URI="https://github.com/downloads/QupZilla/qupzilla/${MY_P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="dbus debug kde"
+
+DEPEND="
+ >=x11-libs/qt-core-4.7:4
+ >=x11-libs/qt-gui-4.7:4
+ >=x11-libs/qt-script-4.7:4
+ >=x11-libs/qt-sql-4.7:4
+ >=x11-libs/qt-webkit-4.7:4
+ dbus? ( >=x11-libs/qt-dbus-4.7:4 )
+"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${MY_P}
+
+DOCS="AUTHORS CHANGELOG FAQ TODO"
+
+src_configure() {
+ export QUPZILLA_PREFIX=${EPREFIX}/usr/
+ export USE_LIBPATH=${QUPZILLA_PREFIX}$(get_libdir)
+ export DISABLE_DBUS=$(use dbus && echo false || echo true)
+ export KDE=$(use kde && echo true || echo false)
+
+ eqmake4
+}
+
+# TODO: translation handling