summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavide Pesavento <pesa@gentoo.org>2012-07-12 14:20:32 +0000
committerDavide Pesavento <pesa@gentoo.org>2012-07-12 14:20:32 +0000
commit55c094bbeeb74c7a79e38fec1138c68e46774898 (patch)
tree386a55ff0a2018d40a4ed1804cf20bdf203593f4 /www-client/qupzilla
parentia64 stable wrt bug #418909 (diff)
downloadgentoo-2-55c094bbeeb74c7a79e38fec1138c68e46774898.tar.gz
gentoo-2-55c094bbeeb74c7a79e38fec1138c68e46774898.tar.bz2
gentoo-2-55c094bbeeb74c7a79e38fec1138c68e46774898.zip
Version bump, added dbus USE flag.
(Portage version: 2.2.0_alpha116/cvs/Linux x86_64)
Diffstat (limited to 'www-client/qupzilla')
-rw-r--r--www-client/qupzilla/ChangeLog8
-rw-r--r--www-client/qupzilla/qupzilla-1.3.0.ebuild43
2 files changed, 49 insertions, 2 deletions
diff --git a/www-client/qupzilla/ChangeLog b/www-client/qupzilla/ChangeLog
index 637279ba2fad..acdf6e45049b 100644
--- a/www-client/qupzilla/ChangeLog
+++ b/www-client/qupzilla/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for www-client/qupzilla
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/qupzilla/ChangeLog,v 1.6 2012/06/12 15:45:00 kensington Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/qupzilla/ChangeLog,v 1.7 2012/07/12 14:20:32 pesa Exp $
+
+*qupzilla-1.3.0 (12 Jul 2012)
+
+ 12 Jul 2012; Davide Pesavento <pesa@gentoo.org> +qupzilla-1.3.0.ebuild:
+ Version bump, added dbus USE flag.
12 Jun 2012; Michael Palimaka <kensington@gentoo.org> qupzilla-1.2.0.ebuild:
Update SRC_URI, wrt bug #420843 by Corentin Chary <iksaif@gentoo.org>.
@@ -26,4 +31,3 @@
+qupzilla-1.1.8.ebuild:
Initial commit, moved from qt overlay. Ebuild by Ben de Groot
<yngwin@gmail.com>.
-
diff --git a/www-client/qupzilla/qupzilla-1.3.0.ebuild b/www-client/qupzilla/qupzilla-1.3.0.ebuild
new file mode 100644
index 000000000000..81252865ac04
--- /dev/null
+++ b/www-client/qupzilla/qupzilla-1.3.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-client/qupzilla/qupzilla-1.3.0.ebuild,v 1.1 2012/07/12 14:20:32 pesa Exp $
+
+EAPI=4
+
+inherit multilib qt4-r2 vcs-snapshot
+
+MY_P=QupZilla-${PV}
+
+DESCRIPTION="Qt WebKit web browser"
+HOMEPAGE="http://www.qupzilla.com/"
+SRC_URI="https://github.com/downloads/QupZilla/qupzilla/${MY_P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="dbus debug kde"
+
+DEPEND="
+ >=x11-libs/qt-core-4.7:4
+ >=x11-libs/qt-gui-4.7:4
+ >=x11-libs/qt-script-4.7:4
+ >=x11-libs/qt-sql-4.7:4
+ >=x11-libs/qt-webkit-4.7:4
+ dbus? ( >=x11-libs/qt-dbus-4.7:4 )
+"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${MY_P}
+
+DOCS="AUTHORS CHANGELOG FAQ TODO"
+
+src_configure() {
+ export QUPZILLA_PREFIX=${EPREFIX}/usr/
+ export USE_LIBPATH=${QUPZILLA_PREFIX}$(get_libdir)
+ export DISABLE_DBUS=$(use dbus && echo false || echo true)
+ export KDE=$(use kde && echo true || echo false)
+
+ eqmake4
+}
+
+# TODO: translation handling