summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRaúl Porcel <armin76@gentoo.org>2009-09-10 17:27:13 +0000
committerRaúl Porcel <armin76@gentoo.org>2009-09-10 17:27:13 +0000
commit3501059b5f0eba52aa3d7dcbf2d99f67e03e2d9d (patch)
tree6b64289fc7bef5ed2c87e4bbe3ce973c6275ffd3 /www-client/mozilla-firefox-bin
parentFixing init script ordering to avoid postfix/sasl failure, fixes #239535 (diff)
downloadgentoo-2-3501059b5f0eba52aa3d7dcbf2d99f67e03e2d9d.tar.gz
gentoo-2-3501059b5f0eba52aa3d7dcbf2d99f67e03e2d9d.tar.bz2
gentoo-2-3501059b5f0eba52aa3d7dcbf2d99f67e03e2d9d.zip
Version bump
(Portage version: 2.1.6.13/cvs/Linux ia64)
Diffstat (limited to 'www-client/mozilla-firefox-bin')
-rw-r--r--www-client/mozilla-firefox-bin/ChangeLog9
-rw-r--r--www-client/mozilla-firefox-bin/mozilla-firefox-bin-3.0.14.ebuild169
-rw-r--r--www-client/mozilla-firefox-bin/mozilla-firefox-bin-3.5.3.ebuild180
3 files changed, 357 insertions, 1 deletions
diff --git a/www-client/mozilla-firefox-bin/ChangeLog b/www-client/mozilla-firefox-bin/ChangeLog
index 38ea05d4d484..b67485f48c2e 100644
--- a/www-client/mozilla-firefox-bin/ChangeLog
+++ b/www-client/mozilla-firefox-bin/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for www-client/mozilla-firefox-bin
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/mozilla-firefox-bin/ChangeLog,v 1.204 2009/09/05 20:59:56 keytoaster Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/mozilla-firefox-bin/ChangeLog,v 1.205 2009/09/10 17:27:13 armin76 Exp $
+
+*mozilla-firefox-bin-3.5.3 (10 Sep 2009)
+*mozilla-firefox-bin-3.0.14 (10 Sep 2009)
+
+ 10 Sep 2009; Raúl Porcel <armin76@gentoo.org>
+ +mozilla-firefox-bin-3.0.14.ebuild, +mozilla-firefox-bin-3.5.3.ebuild:
+ Version bump
05 Sep 2009; Tobias Heinlein <keytoaster@gentoo.org>
mozilla-firefox-bin-3.0.13.ebuild:
diff --git a/www-client/mozilla-firefox-bin/mozilla-firefox-bin-3.0.14.ebuild b/www-client/mozilla-firefox-bin/mozilla-firefox-bin-3.0.14.ebuild
new file mode 100644
index 000000000000..c78a934085fa
--- /dev/null
+++ b/www-client/mozilla-firefox-bin/mozilla-firefox-bin-3.0.14.ebuild
@@ -0,0 +1,169 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-client/mozilla-firefox-bin/mozilla-firefox-bin-3.0.14.ebuild,v 1.1 2009/09/10 17:27:13 armin76 Exp $
+EAPI="2"
+
+inherit eutils mozilla-launcher multilib mozextension
+
+LANGS="af ar be bg bn-IN ca cs cy da de el en-GB en-US eo es-AR es-ES et eu fi fr fy-NL ga-IE gl gu-IN he hi-IN hu id is it ja ka kn ko ku lt lv mk mn mr nb-NO nl nn-NO oc pa-IN pl pt-BR pt-PT ro ru si sk sl sq sr sv-SE te th tr uk zh-CN zh-TW"
+NOSHORTLANGS="en-GB es-AR pt-BR zh-CN"
+
+DESCRIPTION="Firefox Web Browser"
+REL_URI="http://releases.mozilla.org/pub/mozilla.org/firefox/releases/"
+SRC_URI="${REL_URI}/${PV}/linux-i686/en-US/firefox-${PV}.tar.bz2"
+HOMEPAGE="http://www.mozilla.com/firefox"
+RESTRICT="strip"
+
+KEYWORDS="-* ~amd64 ~x86"
+SLOT="0"
+LICENSE="|| ( MPL-1.1 GPL-2 LGPL-2.1 )"
+IUSE="restrict-javascript"
+
+for X in ${LANGS} ; do
+ if [ "${X}" != "en" ] && [ "${X}" != "en-US" ]; then
+ SRC_URI="${SRC_URI}
+ linguas_${X/-/_}? ( ${REL_URI}/${PV}/linux-i686/xpi/${X}.xpi -> ${P/-bin/}-${X}.xpi )"
+ fi
+ IUSE="${IUSE} linguas_${X/-/_}"
+ # english is handled internally
+ if [ "${#X}" == 5 ] && ! has ${X} ${NOSHORTLANGS}; then
+ if [ "${X}" != "en-US" ]; then
+ SRC_URI="${SRC_URI}
+ linguas_${X%%-*}? ( ${REL_URI}/${PV}/linux-i686/xpi/${X}.xpi -> ${P/-bin/}-${X}.xpi )"
+ fi
+ IUSE="${IUSE} linguas_${X%%-*}"
+ fi
+done
+
+DEPEND="app-arch/unzip"
+RDEPEND="x11-libs/libXrender
+ x11-libs/libXt
+ x11-libs/libXmu
+ x86? (
+ >=x11-libs/gtk+-2.2
+ )
+ amd64? (
+ >=app-emulation/emul-linux-x86-baselibs-1.0
+ >=app-emulation/emul-linux-x86-gtklibs-1.0
+ app-emulation/emul-linux-x86-compat
+ )"
+
+PDEPEND="restrict-javascript? ( www-plugins/noscript )"
+
+S="${WORKDIR}/firefox"
+
+pkg_setup() {
+ # This is a binary x86 package => ABI=x86
+ # Please keep this in future versions
+ # Danny van Dyk <kugelfang@gentoo.org> 2005/03/26
+ has_multilib_profile && ABI="x86"
+}
+
+linguas() {
+ local LANG SLANG
+ for LANG in ${LINGUAS}; do
+ if has ${LANG} en en_US; then
+ has en ${linguas} || linguas="${linguas:+"${linguas} "}en"
+ continue
+ elif has ${LANG} ${LANGS//-/_}; then
+ has ${LANG//_/-} ${linguas} || linguas="${linguas:+"${linguas} "}${LANG//_/-}"
+ continue
+ elif [[ " ${LANGS} " == *" ${LANG}-"* ]]; then
+ for X in ${LANGS}; do
+ if [[ "${X}" == "${LANG}-"* ]] && \
+ [[ " ${NOSHORTLANGS} " != *" ${X} "* ]]; then
+ has ${X} ${linguas} || linguas="${linguas:+"${linguas} "}${X}"
+ continue 2
+ fi
+ done
+ fi
+ ewarn "Sorry, but ${PN} does not support the ${LANG} LINGUA"
+ done
+}
+
+src_unpack() {
+ unpack firefox-${PV}.tar.bz2
+
+ linguas
+ for X in ${linguas}; do
+ [[ ${X} != "en" ]] && xpi_unpack "${P/-bin/}-${X}.xpi"
+ done
+ if [[ ${linguas} != "" && ${linguas} != "en" ]]; then
+ einfo "Selected language packs (first will be default): ${linguas}"
+ fi
+}
+
+src_install() {
+ declare MOZILLA_FIVE_HOME=/opt/firefox
+
+ # Install icon and .desktop for menu entry
+ newicon "${S}"/chrome/icons/default/default48.png ${PN}-icon.png
+ domenu "${FILESDIR}"/icon/${PN}.desktop
+
+ # Install firefox in /opt
+ dodir ${MOZILLA_FIVE_HOME%/*}
+ mv "${S}" "${D}"${MOZILLA_FIVE_HOME}
+
+ linguas
+ for X in ${linguas}; do
+ [[ ${X} != "en" ]] && xpi_install "${WORKDIR}"/"${P/-bin/}-${X}"
+ done
+
+ local LANG=${linguas%% *}
+ if [[ -n ${LANG} && ${LANG} != "en" ]]; then
+ elog "Setting default locale to ${LANG}"
+ dosed -e "s:general.useragent.locale\", \"en-US\":general.useragent.locale\", \"${LANG}\":" \
+ "${MOZILLA_FIVE_HOME}"/defaults/pref/firefox.js \
+ "${MOZILLA_FIVE_HOME}"/defaults/pref/firefox-l10n.js || \
+ die "sed failed to change locale"
+ fi
+
+ # Create /usr/bin/firefox-bin
+ dodir /usr/bin/
+ cat <<EOF >"${D}"/usr/bin/firefox-bin
+#!/bin/sh
+unset LD_PRELOAD
+exec /opt/firefox/firefox "\$@"
+EOF
+ fperms 0755 /usr/bin/firefox-bin
+
+ # revdep-rebuild entry
+ insinto /etc/revdep-rebuild
+ doins "${FILESDIR}"/10firefox-bin
+
+ # install ldpath env.d
+ doenvd "${FILESDIR}"/71firefox-bin
+
+ rm -rf "${D}"${MOZILLA_FIVE_HOME}/plugins
+ dosym /usr/"$(get_libdir)"/nsbrowser/plugins ${MOZILLA_FIVE_HOME}/plugins
+}
+
+pkg_postinst() {
+ if use x86; then
+ if ! has_version 'gnome-base/gconf' || ! has_version 'gnome-base/orbit' \
+ || ! has_version 'net-misc/curl'; then
+ einfo
+ einfo "For using the crashreporter, you need gnome-base/gconf,"
+ einfo "gnome-base/orbit and net-misc/curl emerged."
+ einfo
+ fi
+ if has_version 'net-misc/curl' && built_with_use --missing \
+ true 'net-misc/curl' nss; then
+ einfo
+ einfo "Crashreporter won't be able to send reports"
+ einfo "if you have curl emerged with the nss USE-flag"
+ einfo
+ fi
+ else
+ einfo
+ einfo "NB: You just installed a 32-bit firefox"
+ einfo
+ einfo "Crashreporter won't work on amd64"
+ einfo
+ fi
+ update_mozilla_launcher_symlinks
+}
+
+pkg_postrm() {
+ update_mozilla_launcher_symlinks
+}
diff --git a/www-client/mozilla-firefox-bin/mozilla-firefox-bin-3.5.3.ebuild b/www-client/mozilla-firefox-bin/mozilla-firefox-bin-3.5.3.ebuild
new file mode 100644
index 000000000000..2c905cd2f20f
--- /dev/null
+++ b/www-client/mozilla-firefox-bin/mozilla-firefox-bin-3.5.3.ebuild
@@ -0,0 +1,180 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-client/mozilla-firefox-bin/mozilla-firefox-bin-3.5.3.ebuild,v 1.1 2009/09/10 17:27:13 armin76 Exp $
+EAPI="2"
+
+inherit eutils mozilla-launcher multilib mozextension
+
+LANGS="af ar be bg bn-IN ca cs cy da de el en-GB en-US eo es-AR es-ES et eu fa fi fr fy-NL ga-IE gl gu-IN he hi-IN hu id is it ja ka kk kn ko ku lt lv mk mr nb-NO nl nn-NO oc pa-IN pl pt-BR pt-PT ro ru si sk sl sq sr sv-SE ta te th uk vi zh-CN zh-TW"
+NOSHORTLANGS="en-GB es-AR pt-BR zh-CN"
+
+MY_PV="${PV/_rc/rc}"
+MY_P="${PN/-bin/}-${MY_PV}"
+
+DESCRIPTION="Firefox Web Browser"
+REL_URI="http://releases.mozilla.org/pub/mozilla.org/firefox/releases/"
+SRC_URI="${REL_URI}/${MY_PV}/linux-i686/en-US/firefox-${MY_PV}.tar.bz2"
+HOMEPAGE="http://www.mozilla.com/firefox"
+RESTRICT="strip"
+
+KEYWORDS="-* ~amd64 ~x86"
+SLOT="0"
+LICENSE="|| ( MPL-1.1 GPL-2 LGPL-2.1 )"
+IUSE="restrict-javascript"
+
+for X in ${LANGS} ; do
+ if [ "${X}" != "en" ] && [ "${X}" != "en-US" ]; then
+ SRC_URI="${SRC_URI}
+ linguas_${X/-/_}? ( ${REL_URI}/${MY_PV}/linux-i686/xpi/${X}.xpi -> ${P/-bin/}-${X}.xpi )"
+ fi
+ IUSE="${IUSE} linguas_${X/-/_}"
+ # english is handled internally
+ if [ "${#X}" == 5 ] && ! has ${X} ${NOSHORTLANGS}; then
+ if [ "${X}" != "en-US" ]; then
+ SRC_URI="${SRC_URI}
+ linguas_${X%%-*}? ( ${REL_URI}/${MY_PV}/linux-i686/xpi/${X}.xpi -> ${P/-bin/}-${X}.xpi )"
+ fi
+ IUSE="${IUSE} linguas_${X%%-*}"
+ fi
+done
+
+DEPEND="app-arch/unzip"
+RDEPEND="dev-libs/dbus-glib
+ x11-libs/libXrender
+ x11-libs/libXt
+ x11-libs/libXmu
+ x86? (
+ >=x11-libs/gtk+-2.2
+ >=media-libs/alsa-lib-1.0.16
+ )
+ amd64? (
+ >=app-emulation/emul-linux-x86-baselibs-1.0
+ >=app-emulation/emul-linux-x86-gtklibs-1.0
+ >=app-emulation/emul-linux-x86-soundlibs-20080418
+ app-emulation/emul-linux-x86-compat
+ )"
+
+PDEPEND="restrict-javascript? ( www-plugins/noscript )"
+
+S="${WORKDIR}/firefox"
+
+pkg_setup() {
+ # This is a binary x86 package => ABI=x86
+ # Please keep this in future versions
+ # Danny van Dyk <kugelfang@gentoo.org> 2005/03/26
+ has_multilib_profile && ABI="x86"
+}
+
+linguas() {
+ local LANG SLANG
+ for LANG in ${LINGUAS}; do
+ if has ${LANG} en en_US; then
+ has en ${linguas} || linguas="${linguas:+"${linguas} "}en"
+ continue
+ elif has ${LANG} ${LANGS//-/_}; then
+ has ${LANG//_/-} ${linguas} || linguas="${linguas:+"${linguas} "}${LANG//_/-}"
+ continue
+ elif [[ " ${LANGS} " == *" ${LANG}-"* ]]; then
+ for X in ${LANGS}; do
+ if [[ "${X}" == "${LANG}-"* ]] && \
+ [[ " ${NOSHORTLANGS} " != *" ${X} "* ]]; then
+ has ${X} ${linguas} || linguas="${linguas:+"${linguas} "}${X}"
+ continue 2
+ fi
+ done
+ fi
+ ewarn "Sorry, but ${PN} does not support the ${LANG} LINGUA"
+ done
+}
+
+src_unpack() {
+ unpack firefox-${MY_PV}.tar.bz2
+
+ linguas
+ for X in ${linguas}; do
+ [[ ${X} != "en" ]] && xpi_unpack "${P/-bin/}-${X}.xpi"
+ done
+ if [[ ${linguas} != "" && ${linguas} != "en" ]]; then
+ einfo "Selected language packs (first will be default): ${linguas}"
+ fi
+}
+
+src_install() {
+ declare MOZILLA_FIVE_HOME=/opt/firefox
+
+ # Install icon and .desktop for menu entry
+ newicon "${S}"/chrome/icons/default/default48.png ${PN}-icon.png
+ domenu "${FILESDIR}"/icon/${PN}.desktop
+
+ # Add StartupNotify=true bug 237317
+ if use startup-notification; then
+ echo "StartupNotify=true" >> "${D}"/usr/share/applications/${PN}.desktop
+ fi
+
+ # Install firefox in /opt
+ dodir ${MOZILLA_FIVE_HOME%/*}
+ mv "${S}" "${D}"${MOZILLA_FIVE_HOME}
+
+ linguas
+ for X in ${linguas}; do
+ [[ ${X} != "en" ]] && xpi_install "${WORKDIR}"/"${P/-bin/}-${X}"
+ done
+
+ local LANG=${linguas%% *}
+ if [[ -n ${LANG} && ${LANG} != "en" ]]; then
+ elog "Setting default locale to ${LANG}"
+ dosed -e "s:general.useragent.locale\", \"en-US\":general.useragent.locale\", \"${LANG}\":" \
+ "${MOZILLA_FIVE_HOME}"/defaults/pref/firefox.js \
+ "${MOZILLA_FIVE_HOME}"/defaults/pref/firefox-l10n.js || \
+ die "sed failed to change locale"
+ fi
+
+ # Create /usr/bin/firefox-bin
+ dodir /usr/bin/
+ cat <<EOF >"${D}"/usr/bin/firefox-bin
+#!/bin/sh
+unset LD_PRELOAD
+exec /opt/firefox/firefox "\$@"
+EOF
+ fperms 0755 /usr/bin/firefox-bin
+
+ # revdep-rebuild entry
+ insinto /etc/revdep-rebuild
+ doins "${FILESDIR}"/10firefox-bin
+
+ # install ldpath env.d
+ doenvd "${FILESDIR}"/71firefox-bin
+
+ rm -rf "${D}"${MOZILLA_FIVE_HOME}/plugins
+ dosym /usr/"$(get_libdir)"/nsbrowser/plugins ${MOZILLA_FIVE_HOME}/plugins
+}
+
+pkg_postinst() {
+ if use x86; then
+ if ! has_version 'gnome-base/gconf' || ! has_version 'gnome-base/orbit' \
+ || ! has_version 'net-misc/curl'; then
+ einfo
+ einfo "For using the crashreporter, you need gnome-base/gconf,"
+ einfo "gnome-base/orbit and net-misc/curl emerged."
+ einfo
+ fi
+ if has_version 'net-misc/curl' && built_with_use --missing \
+ true 'net-misc/curl' nss; then
+ einfo
+ einfo "Crashreporter won't be able to send reports"
+ einfo "if you have curl emerged with the nss USE-flag"
+ einfo
+ fi
+ else
+ einfo
+ einfo "NB: You just installed a 32-bit firefox"
+ einfo
+ einfo "Crashreporter won't work on amd64"
+ einfo
+ fi
+ update_mozilla_launcher_symlinks
+}
+
+pkg_postrm() {
+ update_mozilla_launcher_symlinks
+}