summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2008-06-07 09:03:57 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2008-06-07 09:03:57 +0000
commit5053fdddf85c3c5897faf42429540c29a8a3d85f (patch)
treedbfc5b32c3be9386cd3ff5d9c1211b5764b53bb1 /www-client/jd
parentAdded a few trivial fixes for gcc-4.3 in gcc4-support.patch, and filter optim... (diff)
downloadgentoo-2-5053fdddf85c3c5897faf42429540c29a8a3d85f.tar.gz
gentoo-2-5053fdddf85c3c5897faf42429540c29a8a3d85f.tar.bz2
gentoo-2-5053fdddf85c3c5897faf42429540c29a8a3d85f.zip
Version bumped.
(Portage version: 2.1.5_rc6)
Diffstat (limited to 'www-client/jd')
-rw-r--r--www-client/jd/ChangeLog8
-rw-r--r--www-client/jd/jd-2.0.0_beta080601.ebuild73
2 files changed, 80 insertions, 1 deletions
diff --git a/www-client/jd/ChangeLog b/www-client/jd/ChangeLog
index aa7cda94c268..734068f981f1 100644
--- a/www-client/jd/ChangeLog
+++ b/www-client/jd/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for www-client/jd
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/jd/ChangeLog,v 1.1 2008/05/23 15:51:46 matsuu Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/jd/ChangeLog,v 1.2 2008/06/07 09:03:57 matsuu Exp $
+
+*jd-2.0.0_beta080601 (02 Jun 2008)
+
+ 07 Jun 2008; MATSUU Takuto <matsuu@gentoo.org>
+ +jd-2.0.0_beta080601.ebuild:
+ Version bumped.
*jd-2.0.0_beta080418 (23 May 2008)
diff --git a/www-client/jd/jd-2.0.0_beta080601.ebuild b/www-client/jd/jd-2.0.0_beta080601.ebuild
new file mode 100644
index 000000000000..224676a40d85
--- /dev/null
+++ b/www-client/jd/jd-2.0.0_beta080601.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-client/jd/jd-2.0.0_beta080601.ebuild,v 1.1 2008/06/07 09:03:57 matsuu Exp $
+
+inherit eutils autotools
+
+MY_P="${P/_p/-}"
+MY_P="${MY_P/_/-}"
+
+DESCRIPTION="gtk2 based 2ch browser written in C++"
+HOMEPAGE="http://jd4linux.sourceforge.jp/"
+SRC_URI="mirror://sourceforge.jp/jd4linux/31373/${MY_P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="gnome gnutls"
+#IUSE="gnome gnutls migemo"
+
+RDEPEND=">=dev-cpp/gtkmm-2.8
+ >=dev-libs/glib-2
+ gnome? ( >=gnome-base/libgnomeui-2 )
+ !gnome? (
+ x11-libs/libSM
+ x11-libs/libICE
+ )
+ gnutls? ( >=net-libs/gnutls-1.2 )
+ !gnutls? ( >=dev-libs/openssl-0.9 )"
+# migemo? ( app-text/cmigemo )
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+S="${WORKDIR}/${MY_P}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ eautoreconf
+}
+
+src_compile() {
+ local myconf=""
+
+ # use gnomeui sm instead of Xorg SM/ICE
+ if use gnome ; then
+ myconf="${myconf} --with-sessionlib=gnomeui"
+ else
+ myconf="${myconf} --with-sessionlib=xsmp"
+ fi
+
+ if use gnutls ; then
+ myconf="${myconf} --without-openssl"
+ else
+ myconf="${myconf} --with-openssl"
+ fi
+
+ #if use migemo ; then
+ # myconf="${myconf} --with-migemo --with-migemodict=/usr/share/migemo/migemo-dict"
+ #else
+ # myconf="${myconf} --without-migemo"
+ #fi
+
+ econf ${myconf} || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ doicon ${PN}.png
+ domenu ${PN}.desktop
+ dodoc AUTHORS ChangeLog NEWS README
+}