summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2010-05-06 21:31:07 +0000
committerPacho Ramos <pacho@gentoo.org>2010-05-06 21:31:07 +0000
commit5028f5f18d566d017f46403ebc8680d03f18c4ba (patch)
tree5de5dd20f5ca9143fc4f08ccc250e4f8d15eb7db /www-client/galeon
parentFix patch name (diff)
downloadgentoo-2-5028f5f18d566d017f46403ebc8680d03f18c4ba.tar.gz
gentoo-2-5028f5f18d566d017f46403ebc8680d03f18c4ba.tar.bz2
gentoo-2-5028f5f18d566d017f46403ebc8680d03f18c4ba.zip
Let it work with xul-1.9.2 and sync with fedora/debian patches.
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'www-client/galeon')
-rw-r--r--www-client/galeon/ChangeLog10
-rw-r--r--www-client/galeon/galeon-2.0.7-r2.ebuild52
2 files changed, 61 insertions, 1 deletions
diff --git a/www-client/galeon/ChangeLog b/www-client/galeon/ChangeLog
index 24cd332789d6..5b7f04a0c6c5 100644
--- a/www-client/galeon/ChangeLog
+++ b/www-client/galeon/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for www-client/galeon
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/galeon/ChangeLog,v 1.55 2010/01/10 17:22:05 hanno Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/galeon/ChangeLog,v 1.56 2010/05/06 21:31:07 pacho Exp $
+
+*galeon-2.0.7-r2 (06 May 2010)
+
+ 06 May 2010; Pacho Ramos <pacho@gentoo.org> +galeon-2.0.7-r2.ebuild:
+ Revision bump to sync with latest fedora and debian patches. Most notable
+ changes include xulrunner-1.9.2 (thanks a lot to Hicham HAOUARI in bug
+ #310411 and #302552), updated plugin patch (fixes bug #303605 reported by
+ Thomas Raschbacher) and some updates to adapt to new gnome-session.
10 Jan 2010; Hanno Boeck <hanno@gentoo.org> -galeon-2.0.4.ebuild,
-files/galeon-2.0.4-maketest.diff, -galeon-2.0.7.ebuild,
diff --git a/www-client/galeon/galeon-2.0.7-r2.ebuild b/www-client/galeon/galeon-2.0.7-r2.ebuild
new file mode 100644
index 000000000000..81f1e12bb9fd
--- /dev/null
+++ b/www-client/galeon/galeon-2.0.7-r2.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-client/galeon/galeon-2.0.7-r2.ebuild,v 1.1 2010/05/06 21:31:07 pacho Exp $
+
+EAPI="2"
+inherit autotools gnome2 eutils
+
+DESCRIPTION="A GNOME Web browser based on gecko (mozilla's rendering engine)"
+HOMEPAGE="http://galeon.sourceforge.net"
+SRC_URI="mirror://sourceforge/galeon/${P}.tar.bz2
+ mirror://gentoo/${P}-patches-r1.tar.bz2"
+
+LICENSE="GPL-2"
+IUSE=""
+KEYWORDS="~amd64 ~ia64 ~ppc -sparc ~x86"
+SLOT="0"
+RDEPEND=">=net-libs/xulrunner-1.9.2
+ >=x11-libs/gtk+-2.12.0
+ >=dev-libs/libxml2-2.6.6
+ >=gnome-base/libgnomeui-2.5.2
+ >=gnome-base/gnome-vfs-2
+ >=gnome-base/gnome-desktop-2.10.0
+ >=gnome-base/libglade-2.3.1"
+DEPEND="${RDEPEND}
+ app-text/rarian
+ dev-util/pkgconfig
+ >=dev-util/intltool-0.30
+ >=sys-devel/gettext-0.11"
+
+DOCS="AUTHORS ChangeLog FAQ README README.ExtraPrefs THANKS TODO NEWS"
+
+src_prepare() {
+ gnome2_src_prepare
+ cd "${S}"
+
+ for i in "${WORKDIR}/${P}-patches-r1/*"; do
+ epatch $i || die "patch $i failed"
+ done
+
+ sed -i s/libxul-embedding-unstable/libxul/ configure.in || die
+ sed -i s/TextZoom/FullZoom/ mozilla/GaleonWrapper.cpp || die
+ eautoreconf
+}
+
+src_configure() {
+ myconf="--with-mozilla=libxul"
+ econf ${myconf} || die "configure failed"
+}
+
+src_compile() {
+ emake MOZILLA_HOME="$(pkg-config libxul --variable=sdkdir)"/bin || die "compile failed"
+}