summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHanno Böck <hanno@gentoo.org>2005-06-06 21:52:35 +0000
committerHanno Böck <hanno@gentoo.org>2005-06-06 21:52:35 +0000
commit2b5b5f2818e51b9dca9f2f861e205ca3a2a74639 (patch)
treecc601339b89a581a6e98638fd859f8df87533006 /www-client/galeon
parentfix compile issue if heimdal is installed without existing heimdal in place. ... (diff)
downloadgentoo-2-2b5b5f2818e51b9dca9f2f861e205ca3a2a74639.tar.gz
gentoo-2-2b5b5f2818e51b9dca9f2f861e205ca3a2a74639.tar.bz2
gentoo-2-2b5b5f2818e51b9dca9f2f861e205ca3a2a74639.zip
galeon version bump
(Portage version: 2.0.51.22-r1)
Diffstat (limited to 'www-client/galeon')
-rw-r--r--www-client/galeon/ChangeLog7
-rw-r--r--www-client/galeon/files/digest-galeon-1.3.211
-rw-r--r--www-client/galeon/galeon-1.3.21.ebuild46
3 files changed, 53 insertions, 1 deletions
diff --git a/www-client/galeon/ChangeLog b/www-client/galeon/ChangeLog
index da37796babb2..dfe200793e7d 100644
--- a/www-client/galeon/ChangeLog
+++ b/www-client/galeon/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for www-client/galeon
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/galeon/ChangeLog,v 1.11 2005/06/06 21:41:26 hanno Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/galeon/ChangeLog,v 1.12 2005/06/06 21:52:35 hanno Exp $
+
+*galeon-1.3.21 (06 Jun 2005)
+
+ 06 Jun 2005; Hanno Boeck <hanno@gentoo.org> +galeon-1.3.21.ebuild:
+ Version bump.
06 Jun 2005; Hanno Boeck <hanno@gentoo.org> galeon-1.3.20.ebuild:
Add dependency to gnome-desktop.
diff --git a/www-client/galeon/files/digest-galeon-1.3.21 b/www-client/galeon/files/digest-galeon-1.3.21
new file mode 100644
index 000000000000..e0c5e05b0fd9
--- /dev/null
+++ b/www-client/galeon/files/digest-galeon-1.3.21
@@ -0,0 +1 @@
+MD5 5106e037bb52bdb234b3fc09c1e0a3f3 galeon-1.3.21.tar.bz2 4080353
diff --git a/www-client/galeon/galeon-1.3.21.ebuild b/www-client/galeon/galeon-1.3.21.ebuild
new file mode 100644
index 000000000000..65048373be83
--- /dev/null
+++ b/www-client/galeon/galeon-1.3.21.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-client/galeon/galeon-1.3.21.ebuild,v 1.1 2005/06/06 21:52:35 hanno Exp $
+
+inherit gnome2 debug libtool eutils
+
+DESCRIPTION="A GNOME Web browser based on gecko (mozilla's rendering engine)"
+HOMEPAGE="http://galeon.sourceforge.net"
+SRC_URI="mirror://sourceforge/galeon/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+IUSE="firefox"
+KEYWORDS="~x86 ~ppc ~alpha ~sparc ~amd64 ~ia64"
+SLOT="0"
+
+S=${WORKDIR}/${P}
+
+RDEPEND="virtual/x11
+ !firefox? ( >=www-client/mozilla-1.7.6-r1 )
+ firefox? ( >=www-client/mozilla-firefox-1.0.2-r1 )
+ >=dev-libs/glib-2
+ >=x11-libs/gtk+-2.4.0
+ >=dev-libs/libxml2-2.6.6
+ >=gnome-base/gconf-2.3.2
+ >=gnome-base/orbit-2
+ >=gnome-base/libbonobo-2
+ >=gnome-base/libbonoboui-2.1.1
+ >=gnome-base/libgnomeui-2.5.2
+ >=gnome-base/gnome-vfs-2
+ >=gnome-base/gnome-desktop-2.10.0
+ >=gnome-base/libglade-2.3.1
+ app-text/scrollkeeper"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ >=dev-util/intltool-0.30
+ >=sys-devel/gettext-0.11"
+
+src_compile() {
+ use firefox && myconf="--with-mozilla=firefox"
+ use firefox || myconf="--with-mozilla=mozilla"
+
+ econf ${myconf} || die "configure failed"
+ make || die "compile failed"
+}
+
+DOCS="AUTHORS COPYING COPYING.README ChangeLog FAQ INSTALL README README.ExtraPrefs THANKS TODO NEWS"